Atmel BLE API: Modules

Atmel BLE API 1.2.1
Description of WINC3400 BLE Software Interface data types and APIs
Modules
Here is a list of all modules:
COMMON
GAP API
GATT client API
GATT server API
L2CAP API
HTPT API
Platform API
Generated on Fri Aug 18 2017 00:42:11 for Atmel BLE API by doxygen 1.8.13


Atmel BLE API: COMMON

Macros | Typedefs | Enumerations
COMMON

Macros

#define | AT_BLE_ADDR_LEN 6
#define | AT_BLE_MAX_KEY_LEN (16)
#define | AT_BLE_PASSKEY_LEN (6)
#define | AT_BLE_GAP_WHITELIST_ADDR_MAX_COUNT (8)
#define | AT_BLE_GAP_WHITELIST_IRK_MAX_COUNT (8)
#define | AT_BLE_ADV_MAX_SIZE 31
#define | AT_BLE_UUID_16_LEN (2)
#define | AT_BLE_UUID_32_LEN (4)
#define | AT_BLE_UUID_128_LEN (16)
#define | AT_BLE_ADV_INTERVAL_MIN 0x0020
#define | AT_BLE_ADV_NONCON_INTERVAL_MIN 0x00A0
#define | AT_BLE_ADV_INTERVAL_MAX 0x4000
#define | AT_BLE_SCAN_INTERVAL_MIN 0x0004
#define | AT_BLE_SCAN_INTERVAL_MAX 0x4000
#define | AT_BLE_SCAN_WINDOW_MIN 0x0004
#define | AT_BLE_SCAN_WINDOW_MAX 0x4000
#define | AT_CNX_INTERVAL_MIN 6
#define | AT_CNX_INTERVAL_MAX 3200
#define | AT_CNX_LATENCY_MIN 0
#define | AT_CNX_LATENCY_MAX 499
#define | AT_CNX_SUP_TO_MIN 10
#define | AT_CNX_SUP_TO_MAX 3200
#define | AT_BLE_MAX_ATT_LEN 512
#define | AT_DEFAULT_MTU 0x0017

Typedefs

typedef uint16_t at_ble_handle_t

Enumerations

enum at_ble_status_t {
AT_BLE_SUCCESS =0, AT_BLE_FAILURE, AT_BLE_INVALID_PARAM, AT_BLE_PRIVACY_CFG_PB,
AT_BLE_COMMAND_DISALLOWED, AT_BLE_INVALID_STATE, AT_BLE_INVALID_HANDLE, AT_BLE_INSUFF_RESOURCE,
AT_BLE_INVALID_ATTRIBUTE_VAL_LEN, AT_BLE_TIMEOUT
}
enum at_ble_parameters_t {
AT_BLE_GAP_GEN_DISC_ADV_MIN =0, AT_BLE_GAP_LIM_ADV_TIMEOUT, AT_BLE_GAP_GEN_DISC_SCAN, AT_BLE_GAP_LIM_DISC_SCAN,
AT_BLE_GAP_CONN_EST_ADV_TIMEOUT, AT_BLE_GAP_CONN_PARAM_TIMEOUT, AT_BLE_GAP_LIM_DISC_ADV_INT_MIN, AT_BLE_GAP_LIM_DISC_ADV_INT_MAX,
AT_BLE_GAP_GEN_DISC_ADV_INT_MIN, AT_BLE_GAP_GEN_DISC_ADV_INT_MAX, AT_BLE_GAP_CONN_ADV_INT_MIN, AT_BLE_GAP_CONN_ADV_INT_MAX,
AT_BLE_GAP_CONN_SCAN_INT, AT_BLE_GAP_CONN_SCAN_WIND, AT_BLE_GAP_CONN_HIGH_SCAN_INT, AT_BLE_GAP_CONN_HIGH_SCAN_WIND,
AT_BLE_GAP_GEN_DISC_SCAN_INT, AT_BLE_GAP_GEN_DISC_SCAN_WIND, AT_BLE_GAP_LIM_DISC_SCAN_INT, AT_BLE_GAP_LIM_DISC_SCAN_WIND,
AT_BLE_GAP_CONN_EST_ADV, AT_BLE_GAP_CONN_EST_INT_MIN, AT_BLE_GAP_CONN_EST_INT_MAX, AT_BLE_GAP_CONN_EST_SCAN_INT,
AT_BLE_GAP_CONN_EST_SCAN_WIND, AT_BLE_GAP_CONN_EST_SUPERV_TIMEOUT, AT_BLE_GAP_CONN_EST_LATENCY, AT_BLE_GAP_CONN_EST_MIN_CE_LEN,
AT_BLE_GAP_CONN_EST_MAX_CE_LEN, AT_BLE_GAP_PRIVATE_ADDR_INT, AT_BLE_GAP_CONN_PAUSE_CENTRAL, AT_BLE_GAP_CONN_PAUSE_PERIPHERAL
}
enum at_ble_gap_role {
AT_BLE_GAP_NO_ROLE = 0x00, AT_BLE_GAP_OBSERVER_SCA = 0x01, AT_BLE_GAP_BROADCASTER_ADV = 0x02, AT_BLE_GAP_CENTRAL_MST = (0x04 | AT_BLE_GAP_OBSERVER_SCA),
AT_BLE_GAP_PERIPHERAL_SLV = (0x08 | AT_BLE_GAP_BROADCASTER_ADV)
}
enum at_ble_adv_type_t {
AT_BLE_ADV_TYPE_UNDIRECTED = 0x00, AT_BLE_ADV_TYPE_DIRECTED, AT_BLE_ADV_TYPE_SCANNABLE_UNDIRECTED, AT_BLE_ADV_TYPE_NONCONN_UNDIRECTED,
AT_BLE_ADV_TYPE_SCAN_RESPONSE
}
enum at_ble_events_t {
AT_BLE_UNDEFINED_EVENT, AT_BLE_SCAN_INFO, AT_BLE_SCAN_REPORT, AT_BLE_RAND_ADDR_CHANGED,
AT_BLE_CONNECTED, AT_BLE_DISCONNECTED, AT_BLE_CONN_PARAM_UPDATE_DONE, AT_BLE_CONN_PARAM_UPDATE_REQUEST,
AT_BLE_RX_POWER_VALUE, AT_BLE_PAIR_DONE, AT_BLE_PAIR_REQUEST, AT_BLE_SLAVE_SEC_REQUEST,
AT_BLE_PAIR_KEY_REQUEST, AT_BLE_ENCRYPTION_REQUEST, AT_BLE_ENCRYPTION_STATUS_CHANGED, AT_BLE_RESOLV_RAND_ADDR_STATUS,
AT_BLE_PRIMARY_SERVICE_FOUND, AT_BLE_INCLUDED_SERVICE_FOUND, AT_BLE_CHARACTERISTIC_FOUND, AT_BLE_DESCRIPTOR_FOUND,
AT_BLE_DISCOVERY_COMPLETE, AT_BLE_CHARACTERISTIC_READ_RESPONSE, AT_BLE_CHARACTERISTIC_READ_MULTIBLE_RESPONSE, AT_BLE_CHARACTERISTIC_WRITE_RESPONSE,
AT_BLE_NOTIFICATION_RECIEVED, AT_BLE_INDICATION_RECIEVED, AT_BLE_INDICATION_CONFIRMED, AT_BLE_CHARACTERISTIC_CHANGED,
AT_BLE_SERVICE_CHANGED_NOTIFICATION_CONFIRMED, AT_BLE_WRITE_AUTHORIZE_REQUEST, AT_BLE_READ_AUTHORIZE_REQUEST, AT_BLE_L2CAP_RX,
AT_BLE_HTPT_CREATE_DB_CFM, AT_BLE_HTPT_ERROR_IND, AT_BLE_HTPT_DISABLE_IND, AT_BLE_HTPT_TEMP_SEND_CFM,
AT_BLE_HTPT_MEAS_INTV_CHG_IND, AT_BLE_HTPT_CFG_INDNTF_IND, AT_BLE_WIFIPROV_SCAN_MODE_CHANGE_IND, AT_BLE_WIFIPROV_COMPLETE_IND,
AT_BLE_CUSTOM_EVENT, AT_BLE_TX_POWER_VALUE, AT_BLE_TX_POWER_SET, AT_BLE_MAX_PA_GAIN_VALUE,
AT_BLE_MTU_CHANGED_CMD_COMPLETE, AT_BLE_CHARACTERISTIC_WRITE_CMD_CMP, AT_BLE_NOTIFICATION_CONFIRMED
}
enum at_ble_addr_type_t {
AT_BLE_ADDRESS_PUBLIC, AT_BLE_ADDRESS_RANDOM_STATIC, AT_BLE_ADDRESS_RANDOM_PRIVATE_RESOLVABLE, AT_BLE_ADDRESS_RANDOM_PRIVATE_NON_RESOLVABLE,
AT_BLE_ADDRESS_INVALID
}
enum | at_ble_disconnect_reason_t { AT_BLE_TERMINATED_BY_USER, AT_BLE_UNACCEPTABLE_INTERVAL }
enum at_ble_iocab_t {
AT_BLE_IO_CAP_DISPLAY_ONLY, AT_BLE_IO_CAP_DISPLAY_YES_NO, AT_BLE_IO_CAP_KB_ONLY, AT_BLE_IO_CAP_NO_INPUT_NO_OUTPUT,
AT_BLE_IO_CAP_KB_DISPLAY
}
enum at_ble_key_dis_t {
AT_BLE_KEY_DIST_NONE = 0x00, AT_BLE_KEY_DIST_ENC = (1 << 0), AT_BLE_KEY_DIST_ID = (1 << 1), AT_BLE_KEY_DIST_SIGN = (1 << 2),
AT_BLE_KEY_DIS_ALL
}
enum at_ble_auth_levels_t {
AT_BLE_NO_SEC = 0x00, AT_BLE_MODE1_L1_NOAUTH_PAIR_ENC, AT_BLE_MODE1_L2_AUTH_PAIR_ENC, AT_BLE_MODE2_L1_NOAUTH_DATA_SGN,
AT_BLE_MODE2_L2_AUTH_DATA_SGN
}
enum | at_ble_uuid_type_t { AT_BLE_UUID_16, AT_BLE_UUID_32, AT_BLE_UUID_128, AT_BLE_UUID_INVALID }
enum at_ble_char_properties_t {
AT_BLE_CHAR_BROADCST = (1 << 0), AT_BLE_CHAR_READ = (1 << 1), AT_BLE_CHAR_WRITE_WITHOUT_RESPONSE = (1 << 2), AT_BLE_CHAR_WRITE = (1 << 3),
AT_BLE_CHAR_NOTIFY = (1 << 4), AT_BLE_CHAR_INDICATE = (1 << 5), AT_BLE_CHAR_SIGNED_WRITE = (1 << 6), AT_BLE_CHAR_RELIABLE_WRITE = (1 << 7),
AT_BLE_CHAR_WRITEABLE_AUX = (1 << 8)
}
enum | at_ble_filter_type_t { AT_BLE_ADV_FP_ANY, AT_BLE_ADV_FP_FILTER_SCANREQ, AT_BLE_ADV_FP_FILTER_CONNREQ, AT_BLE_ADV_FP_FILTER_BOTH }
enum | at_ble_adv_mode_t { AT_BLE_ADV_NON_DISCOVERABLE, AT_BLE_ADV_GEN_DISCOVERABLE, AT_BLE_ADV_LIM_DISCOVERABLE, AT_BLE_ADV_BROADCASTER_MODE }
enum | at_ble_scan_mode_t { AT_BLE_SCAN_GEN_DISCOVERY, AT_BLE_SCAN_LIM_DISCOVERY, AT_BLE_SCAN_OBSERVER_MODE }
enum | at_ble_scan_type_t { AT_BLE_SCAN_PASSIVE, AT_BLE_SCAN_ACTIVE }
enum at_ble_attr_permissions_t {
AT_BLE_ATTR_NO_PERMISSIONS = 0x00, AT_BLE_ATTR_READABLE_NO_AUTHN_NO_AUTHR = 0x01, AT_BLE_ATTR_READABLE_REQ_AUTHN_NO_AUTHR = 0x02, AT_BLE_ATTR_READABLE_NO_AUTHN_REQ_AUTHR = 0x03,
AT_BLE_ATTR_READABLE_REQ_AUTHN_REQ_AUTHR = 0x04, AT_BLE_ATTR_WRITABLE_NO_AUTHN_NO_AUTHR = 0x10, AT_BLE_ATTR_WRITABLE_REQ_AUTHN_NO_AUTHR = 0x20, AT_BLE_ATTR_WRITABLE_NO_AUTHN_REQ_AUTHR = 0x30,
AT_BLE_ATTR_WRITABLE_REQ_AUTHN_REQ_AUTHR = 0x40
}
enum at_ble_char_pres_format_t {
AT_BLE_PRES_FORMAT_BOOLEAN = 0X01, AT_BLE_PRES_FORMAT_2BIT = 0X02, AT_BLE_PRES_FORMAT_NIBBLE = 0X03, AT_BLE_PRES_FORMAT_UINT8 = 0X04,
AT_BLE_PRES_FORMAT_UINT12 = 0X05, AT_BLE_PRES_FORMAT_UINT16 = 0X06, AT_BLE_PRES_FORMAT_UINT24 = 0X07, AT_BLE_PRES_FORMAT_UINT32 = 0X08,
AT_BLE_PRES_FORMAT_UINT48 = 0X09, AT_BLE_PRES_FORMAT_UINT64 = 0X0A, AT_BLE_PRES_FORMAT_UINT128 = 0X0B, AT_BLE_PRES_FORMAT_SINT8 = 0X0C,
AT_BLE_PRES_FORMAT_SINT12 = 0X0D, AT_BLE_PRES_FORMAT_SINT16 = 0X0E, AT_BLE_PRES_FORMAT_SINT24 = 0X0F, AT_BLE_PRES_FORMAT_SINT32 = 0X10,
AT_BLE_PRES_FORMAT_SINT48 = 0X11, AT_BLE_PRES_FORMAT_SINT64 = 0X12, AT_BLE_PRES_FORMAT_SINT128 = 0X13, AT_BLE_PRES_FORMAT_FLOAT32 = 0X14,
AT_BLE_PRES_FORMAT_FLOAT64 = 0X15, AT_BLE_PRES_FORMAT_SFLOAT = 0X16, AT_BLE_PRES_FORMAT_FLOAT = 0X17, AT_BLE_PRES_FORMAT_DUINT16 = 0X18,
AT_BLE_PRES_FORMAT_UTF8S = 0X19, AT_BLE_PRES_FORMAT_UTF16S = 0X1A, AT_BLE_PRES_FORMAT_STRUCT = 0X1B
}
enum | at_ble_pair_key_type_t { AT_BLE_PAIR_PASSKEY, AT_BLE_PAIR_OOB }
enum | at_ble_passkey_type_t { AT_BLE_PAIR_PASSKEY_ENTRY, AT_BLE_PAIR_PASSKEY_DISPLAY }
enum | at_ble_auth_t { AT_BLE_AUTH_NO_MITM_NO_BOND, AT_BLE_AUTH_NO_MITM_BOND = 0x01, AT_BLE_AUTH_MITM_NO_BOND = 0x04, AT_BLE_AUTH_MITM_BOND = 0x05 }
enum | at_ble_author_t { GAP_AUTHZ_NOT_SET = 0x00, GAP_AUTHZ_ACCEPT = 0x01, GAP_AUTHZ_REJECT = 0x02 }
enum | at_ble_att_write_perm_t { AT_BLE_WRITE_DISABLE, AT_BLE_WRITE_ENABLE, AT_BLE_WRITE_UNAUTH, AT_BLE_WRITE_AUTH }
enum | at_ble_prf_con_type_t { PRF_CON_DISCOVERY = 0x00, PRF_CON_NORMAL = 0x01 }
enum | at_ble_gattc_discovery_complete_status_t { AT_BLE_DISCOVERY_SUCCESS =0x00, AT_BLE_DISCOVERY_FAILURE }
enum at_ble_htpt_db_config_flag {
HTPT_TEMP_TYPE_CHAR_SUP = 0x01, HTPT_INTERM_TEMP_CHAR_SUP = 0x02, HTPT_MEAS_INTV_CHAR_SUP = 0x04, HTPT_MEAS_INTV_IND_SUP = 0x08,
HTPT_MEAS_INTV_WR_SUP = 0x10, HTPT_ALL_FEAT_SUP = 0x1F
}
enum | at_ble_htpt_sec_level { HTPT_DISABLE = 0x00, HTPT_ENABLE = 0x01, HTPT_UNAUTH = 0x02, HTPT_AUTH = 0x03 }
enum at_ble_htpt_attr_index {
HTPT_TEMP_MEAS_CHAR, HTPT_TEMP_TYPE_CHAR, HTPT_INTERM_TEMP_CHAR, HTPT_MEAS_INTV_CHAR,
HTPT_CHAR_MAX
}
enum | at_ble_htpt_temp_flags { HTPT_FLAG_CELSIUS = 0x00, HTPT_FLAG_FAHRENHEIT, HTPT_FLAG_TIME, HTPT_FLAG_TYPE = 0x04 }
enum at_ble_htpt_temp_type {
HTP_TYPE_ARMPIT = 0x01, HTP_TYPE_BODY = 0x02, HTP_TYPE_EAR = 0x03, HTP_TYPE_FINGER = 0x04,
HTP_TYPE_GASTRO_INTESTINAL_TRACT = 0x05, HTP_TYPE_MOUTH = 0x06, HTP_TYPE_RECTUM = 0x07, HTP_TYPE_TOE = 0x08,
HTP_TYPE_TYMPANUM = 0x09
}
enum | at_ble_htpt_conn_type { HTPT_CONFIG_CONN = 0, HTPT_NORMAL_CONN =1 }
enum | at_ble_htpt_ntfind { HTPT_STOP_NTFIND = 0x0000, HTPT_START_NTF, HTPT_START_IND }
enum | at_ble_htpt_ntf_ind_cfg { HTPT_CFG_STABLE_MEAS_IND = (1 << 0), HTPT_CFG_INTERM_MEAS_NTF = (1 << 1), HTPT_CFG_MEAS_INTV_IND = (1 << 2) }

Detailed Description

Macro Definition Documentation

◆ AT_BLE_ADDR_LEN

#define AT_BLE_ADDR_LEN 6

BLE address length.

◆ AT_BLE_MAX_KEY_LEN

#define AT_BLE_MAX_KEY_LEN (16)

BLE security key maximum length.

◆ AT_BLE_PASSKEY_LEN

#define AT_BLE_PASSKEY_LEN (6)

GAP Security Key Length.

◆ AT_BLE_GAP_WHITELIST_ADDR_MAX_COUNT

#define AT_BLE_GAP_WHITELIST_ADDR_MAX_COUNT (8)

Maximum amount of addresses in a white-list.

◆ AT_BLE_GAP_WHITELIST_IRK_MAX_COUNT

#define AT_BLE_GAP_WHITELIST_IRK_MAX_COUNT (8)

Maximum amount of IRKs in a white-list.

Note
The number of IRKs is limited to 8, even if the hardware supports more.

◆ AT_BLE_ADV_MAX_SIZE

#define AT_BLE_ADV_MAX_SIZE 31

Maximum size of advertising data in octets.

◆ AT_BLE_UUID_16_LEN

#define AT_BLE_UUID_16_LEN (2)

UUID 16 size in bytes.

◆ AT_BLE_UUID_32_LEN

#define AT_BLE_UUID_32_LEN (4)

UUID 32 size in bytes.

◆ AT_BLE_UUID_128_LEN

#define AT_BLE_UUID_128_LEN (16)

UUID 128 size in bytes.

◆ AT_BLE_ADV_INTERVAL_MIN

#define AT_BLE_ADV_INTERVAL_MIN 0x0020

Minimum Advertising interval in 625 us units, i.e. 20 ms.

◆ AT_BLE_ADV_NONCON_INTERVAL_MIN

#define AT_BLE_ADV_NONCON_INTERVAL_MIN 0x00A0

Minimum Advertising interval in 625 us units for non connectable mode, i.e. 100 ms.

◆ AT_BLE_ADV_INTERVAL_MAX

#define AT_BLE_ADV_INTERVAL_MAX 0x4000

Maximum Advertising interval in 625 us units, i.e. 10.24 s.

◆ AT_BLE_SCAN_INTERVAL_MIN

#define AT_BLE_SCAN_INTERVAL_MIN 0x0004

Minimum scanning interval in 625 us units , i.e. 2.5 ms.

◆ AT_BLE_SCAN_INTERVAL_MAX

#define AT_BLE_SCAN_INTERVAL_MAX 0x4000

Maximum scanning interval in 625 us units , i.e. 10.24 s.

◆ AT_BLE_SCAN_WINDOW_MIN

#define AT_BLE_SCAN_WINDOW_MIN 0x0004

Minimum scanning window in 625 us units , i.e. 2.5 ms.

◆ AT_BLE_SCAN_WINDOW_MAX

#define AT_BLE_SCAN_WINDOW_MAX 0x4000

Maximum scanning window in 625 us units , i.e. 10.24 s.

◆ AT_CNX_INTERVAL_MIN

#define AT_CNX_INTERVAL_MIN 6

Minimum Connection interval in 1.250ms units, i.e. 7.5ms.

◆ AT_CNX_INTERVAL_MAX

#define AT_CNX_INTERVAL_MAX 3200

Maximum Connection interval in 1.250ms units, i.e. 4s.

◆ AT_CNX_LATENCY_MIN

#define AT_CNX_LATENCY_MIN 0

Minimum Connection latency (number of connection events that may be missed).

◆ AT_CNX_LATENCY_MAX

#define AT_CNX_LATENCY_MAX 499

Maximum Connection latency (number of connection events that may be missed).

◆ AT_CNX_SUP_TO_MIN

#define AT_CNX_SUP_TO_MIN 10

Minimum Supervision timeout in 10ms units, i.e. 100ms.

◆ AT_CNX_SUP_TO_MAX

#define AT_CNX_SUP_TO_MAX 3200

Maximum Supervision timeout in 10ms units, i.e. 32s.

◆ AT_BLE_MAX_ATT_LEN

#define AT_BLE_MAX_ATT_LEN 512

ATT Maximum Attribute Length.

◆ AT_DEFAULT_MTU

#define AT_DEFAULT_MTU 0x0017

Maximum Transmission Unit.

Typedef Documentation

◆ at_ble_handle_t

typedef uint16_t at_ble_handle_t

BLE connection handle

Enumeration Type Documentation

◆ at_ble_status_t

enum at_ble_status_t

Enumeration for BLE Status.

Enumerator
AT_BLE_SUCCESS | Success.
AT_BLE_FAILURE | Failure.
AT_BLE_INVALID_PARAM | Input Parameter invalid.
AT_BLE_PRIVACY_CFG_PB | Problem with privacy configuration.
AT_BLE_COMMAND_DISALLOWED | Request not allowed in current state.
AT_BLE_INVALID_STATE | Operation disallowed in this state.
AT_BLE_INVALID_HANDLE | Invalid attribute handle.
AT_BLE_INSUFF_RESOURCE | Resources not sufficient to complete the request.
AT_BLE_INVALID_ATTRIBUTE_VAL_LEN | Invalid length of the attribute value.
AT_BLE_TIMEOUT | Time-out.

◆ at_ble_parameters_t

enum at_ble_parameters_t

Enumeration for GAP Parameters.

Enumerator
AT_BLE_GAP_GEN_DISC_ADV_MIN | Minimum time to remain advertising, when in Discoverable mode (mSec). Setting this parameter to 0 turns off the time-out (default).
AT_BLE_GAP_LIM_ADV_TIMEOUT | Maximum time to remain advertising, when in Limited Discoverable mode. In seconds (default 180 seconds)
AT_BLE_GAP_GEN_DISC_SCAN | Minimum time to perform scanning, when performing General Discovery proc (mSec)
AT_BLE_GAP_LIM_DISC_SCAN | Minimum time to perform scanning, when performing Limited Discovery proc (mSec)
AT_BLE_GAP_CONN_EST_ADV_TIMEOUT | Advertising time-out, when performing Connection Establishment proc (mSec)
AT_BLE_GAP_CONN_PARAM_TIMEOUT | Link Layer connection parameter update notification timer, connection parameter update proc (mSec)
AT_BLE_GAP_LIM_DISC_ADV_INT_MIN | Minimum advertising interval, when in limited discoverable mode (n * 0.625 mSec)
AT_BLE_GAP_LIM_DISC_ADV_INT_MAX | Maximum advertising interval, when in limited discoverable mode (n * 0.625 mSec)
AT_BLE_GAP_GEN_DISC_ADV_INT_MIN | Minimum advertising interval, when in General discoverable mode (n * 0.625 mSec)
AT_BLE_GAP_GEN_DISC_ADV_INT_MAX | Maximum advertising interval, when in General discoverable mode (n * 0.625 mSec)
AT_BLE_GAP_CONN_ADV_INT_MIN | Minimum advertising interval, when in Connectable mode (n * 0.625 mSec)
AT_BLE_GAP_CONN_ADV_INT_MAX | Maximum advertising interval, when in Connectable mode (n * 0.625 mSec)
AT_BLE_GAP_CONN_SCAN_INT | Scan interval used during Link Layer Initiating state, when in Connectable mode (n * 0.625 mSec)
AT_BLE_GAP_CONN_SCAN_WIND | Scan window used during Link Layer Initiating state, when in Connectable mode (n * 0.625 mSec)
AT_BLE_GAP_CONN_HIGH_SCAN_INT | Scan interval used during Link Layer Initiating state, when in Connectable mode, high duty scan cycle scan parameters (n * 0.625 mSec)
AT_BLE_GAP_CONN_HIGH_SCAN_WIND | Scan window used during Link Layer Initiating state, when in Connectable mode, high duty scan cycle scan parameters (n * 0.625 mSec)
AT_BLE_GAP_GEN_DISC_SCAN_INT | Scan interval used during Link Layer Scanning state, when in General Discovery proc (n * 0.625 mSec)
AT_BLE_GAP_GEN_DISC_SCAN_WIND | Scan window used during Link Layer Scanning state, when in General Discovery proc (n * 0.625 mSec)
AT_BLE_GAP_LIM_DISC_SCAN_INT | Scan interval used during Link Layer Scanning state, when in Limited Discovery proc (n * 0.625 mSec)
AT_BLE_GAP_LIM_DISC_SCAN_WIND | Scan window used during Link Layer Scanning state, when in Limited Discovery proc (n * 0.625 mSec)
AT_BLE_GAP_CONN_EST_ADV | Advertising interval, when using Connection Establishment proc (n * 0.625 mSec). Obsolete - Do not use.
AT_BLE_GAP_CONN_EST_INT_MIN | Minimum Link Layer connection interval, when using Connection Establishment proc (n * 1.25 mSec)
AT_BLE_GAP_CONN_EST_INT_MAX | Maximum Link Layer connection interval, when using Connection Establishment proc (n * 1.25 mSec)
AT_BLE_GAP_CONN_EST_SCAN_INT | Scan interval used during Link Layer Initiating state, when using Connection Establishment proc (n * 0.625 mSec)
AT_BLE_GAP_CONN_EST_SCAN_WIND | Scan window used during Link Layer Initiating state, when using Connection Establishment proc (n * 0.625 mSec)
AT_BLE_GAP_CONN_EST_SUPERV_TIMEOUT | Link Layer connection supervision time-out, when using Connection Establishment proc (n * 10 mSec)
AT_BLE_GAP_CONN_EST_LATENCY | Link Layer connection slave latency, when using Connection Establishment proc (in number of connection events)
AT_BLE_GAP_CONN_EST_MIN_CE_LEN | Local informational parameter about min length of connection needed, when using Connection Establishment proc (n * 0.625 mSec)
AT_BLE_GAP_CONN_EST_MAX_CE_LEN | Local informational parameter about max length of connection needed, when using Connection Establishment proc (n * 0.625 mSec)
AT_BLE_GAP_PRIVATE_ADDR_INT | Minimum Time Interval between private (resolvable) address changes. In minutes (default 15 minutes)
AT_BLE_GAP_CONN_PAUSE_CENTRAL | Central idle timer. In seconds (default 1 second)
AT_BLE_GAP_CONN_PAUSE_PERIPHERAL | Minimum time upon connection establishment before the peripheral starts a connection update procedure. In seconds (default 5 seconds)

◆ at_ble_gap_role

enum at_ble_gap_role

GAP Role.

Enumerator
AT_BLE_GAP_NO_ROLE | No role set yet.
AT_BLE_GAP_OBSERVER_SCA | Observer role.
AT_BLE_GAP_BROADCASTER_ADV | Broadcaster role.
AT_BLE_GAP_CENTRAL_MST | Master/Central role.
AT_BLE_GAP_PERIPHERAL_SLV | Peripheral/Slave role.

◆ at_ble_adv_type_t

enum at_ble_adv_type_t

GAP Advertising types.

Enumerator
AT_BLE_ADV_TYPE_UNDIRECTED | Connectable undirected.
AT_BLE_ADV_TYPE_DIRECTED | Connectable directed.
AT_BLE_ADV_TYPE_SCANNABLE_UNDIRECTED | Scannable undirected.
AT_BLE_ADV_TYPE_NONCONN_UNDIRECTED | Non connectable undirected.
AT_BLE_ADV_TYPE_SCAN_RESPONSE | (Only used in AT_BLE_SCAN_INFO event.) Signifies a scan response.

◆ at_ble_events_t

enum at_ble_events_t

Events delivered from BLE stack to the application layer.

Enumerator
AT_BLE_UNDEFINED_EVENT | Undefined event received
AT_BLE_SCAN_INFO | Scan info needs to be delivered either adv data or scan response data. Refer to at_ble_scan_info_t
AT_BLE_SCAN_REPORT | Scan report received at the end of scan period if AT_BLE_SCAN_GEN_DISCOVERY or AT_BLE_SCAN_LIM_DISCOVERY are used. Refer to at_ble_scan_report_t
AT_BLE_RAND_ADDR_CHANGED | Used random address. Refer to at_ble_rand_addr_changed_t
AT_BLE_CONNECTED | Connected to a peer device. Refer to at_ble_connected_t
AT_BLE_DISCONNECTED | Peer device connection terminated. Refer to at_ble_disconnected_t
AT_BLE_CONN_PARAM_UPDATE_DONE | Connection parameters updated. It is required to call at_ble_conn_update_reply function to send response back if needed. Refer to at_ble_conn_param_update_done_t
AT_BLE_CONN_PARAM_UPDATE_REQUEST | Peer device asks for connection parameters update. Refer to at_ble_conn_param_update_request_t
AT_BLE_RX_POWER_VALUE | Reported RX power value. Refer to at_ble_rx_power_value_t
AT_BLE_PAIR_DONE | Pairing procedure is completed. Refer to at_ble_pair_done_t
AT_BLE_PAIR_REQUEST | A central device asks for Pairing. Refer to at_ble_pair_request_t
AT_BLE_SLAVE_SEC_REQUEST | Slave security request. Refer to at_ble_slave_sec_request_t
AT_BLE_PAIR_KEY_REQUEST | A passkey or OOB data is requested as part of pairing procedure. Refer to at_ble_pair_key_request_t
AT_BLE_ENCRYPTION_REQUEST | Encryption is requested by a master device. Refer to at_ble_encryption_request_t
AT_BLE_ENCRYPTION_STATUS_CHANGED | Encryption status changed. Refer to at_ble_encryption_status_changed_t
AT_BLE_RESOLV_RAND_ADDR_STATUS | Resolve random address status. Refer to at_ble_resolv_rand_addr_status_t
AT_BLE_PRIMARY_SERVICE_FOUND | A primary service is found. Refer to at_ble_primary_service_found_t
AT_BLE_INCLUDED_SERVICE_FOUND | An included service is found. Refer to at_ble_included_service_found_t
AT_BLE_CHARACTERISTIC_FOUND | A Characteristic is found. Refer to at_ble_characteristic_found_t
AT_BLE_DESCRIPTOR_FOUND | A descriptor is found. Refer to at_ble_descriptor_found_t
AT_BLE_DISCOVERY_COMPLETE | A discover operation has completed. Refer to at_ble_discovery_complete_t
AT_BLE_CHARACTERISTIC_READ_RESPONSE | Characteristic read procedure is done. Refer to at_ble_characteristic_read_response_t
AT_BLE_CHARACTERISTIC_READ_MULTIBLE_RESPONSE | Characteristic multiple read procedure is done. Refer to at_ble_characteristic_read_response_t
AT_BLE_CHARACTERISTIC_WRITE_RESPONSE | Characteristic write procedure is done. Refer to at_ble_characteristic_write_response_t
AT_BLE_NOTIFICATION_RECIEVED | A Notification is received. Refer to at_ble_notification_recieved_t
AT_BLE_INDICATION_RECIEVED | An Indication is received. Refer to at_ble_indication_recieved_t
AT_BLE_INDICATION_CONFIRMED | The peer confirmed that it has received an Indication. Refer to at_ble_indication_confirmed_t
AT_BLE_CHARACTERISTIC_CHANGED | The peer has changed a characteristic value. Refer to at_ble_characteristic_changed_t
AT_BLE_SERVICE_CHANGED_NOTIFICATION_CONFIRMED | The peer has confirmed that it has received the service changed notification. Refer to at_ble_service_changed_notification_confirmed_t
AT_BLE_WRITE_AUTHORIZE_REQUEST | The peer asks for a write Authorization. Refer to at_ble_write_authorize_request_t
AT_BLE_READ_AUTHORIZE_REQUEST | The peer asks for a read Authorization. Refer to at_ble_read_authorize_request_t
AT_BLE_L2CAP_RX | An L2CAP packet received from a registered custom CID. Refer to at_ble_l2cap_rx_t
AT_BLE_HTPT_CREATE_DB_CFM | Health Thermometer Inform APP of database creation status. Refer to at_ble_htpt_create_db_cfm_t
AT_BLE_HTPT_ERROR_IND | Health Thermometer Error indication to APP. Refer to at_ble_prf_server_error_ind_t
AT_BLE_HTPT_DISABLE_IND | Health Thermometer Automatically sent to the APP after a disconnection with the peer device to confirm disabled profile. Refer to at_ble_htpt_disable_ind_t
AT_BLE_HTPT_TEMP_SEND_CFM | Health Thermometer Temperature value confirm to APP. Refer to at_ble_htpt_temp_send_cfm_t
AT_BLE_HTPT_MEAS_INTV_CHG_IND | Health Thermometer Inform APP of new measurement interval value. Refer to at_ble_htpt_meas_intv_chg_ind_t
AT_BLE_HTPT_CFG_INDNTF_IND | Health Thermometer Inform APP of new configuration value. Refer to at_ble_htpt_cfg_indntf_ind_t
AT_BLE_WIFIPROV_SCAN_MODE_CHANGE_IND | WiFi Scan requested. Refer to at_ble_wifiprov_scan_mode_change_ind_t
AT_BLE_WIFIPROV_COMPLETE_IND | WiFi Provisioning complete. Refer to at_ble_wifiprov_complete_ind
AT_BLE_CUSTOM_EVENT | A user-defined event is delivered to the system
AT_BLE_TX_POWER_VALUE | Reported TX power value. Refer to at_ble_tx_power_value_t
AT_BLE_TX_POWER_SET | Indication for tx power set (success or fail). Refer to at_ble_tx_power_set_t
AT_BLE_MAX_PA_GAIN_VALUE | Reported maximum PA gain value. Refer to at_ble_max_PA_gain_value_t
AT_BLE_MTU_CHANGED_CMD_COMPLETE | MTU changed complete
AT_BLE_CHARACTERISTIC_WRITE_CMD_CMP | Characteristic write complete
AT_BLE_NOTIFICATION_CONFIRMED | Notification confirmed

◆ at_ble_addr_type_t

enum at_ble_addr_type_t

BLE can accept either public or random addresses.

Enumerator
AT_BLE_ADDRESS_PUBLIC | a public static address
AT_BLE_ADDRESS_RANDOM_STATIC | a random static address
AT_BLE_ADDRESS_RANDOM_PRIVATE_RESOLVABLE | resolvable private random address
AT_BLE_ADDRESS_RANDOM_PRIVATE_NON_RESOLVABLE | non-resolvable private random address
AT_BLE_ADDRESS_INVALID | Invalid address

◆ at_ble_disconnect_reason_t

enum at_ble_disconnect_reason_t

Disconnection reasons.

Enumerator
AT_BLE_TERMINATED_BY_USER
AT_BLE_UNACCEPTABLE_INTERVAL

◆ at_ble_iocab_t

enum at_ble_iocab_t

IO capabilities of a device.

Enumerator
AT_BLE_IO_CAP_DISPLAY_ONLY | Can only display
AT_BLE_IO_CAP_DISPLAY_YES_NO | Can Display and get a Yes/No input from user
AT_BLE_IO_CAP_KB_ONLY | Has only a keyboard
AT_BLE_IO_CAP_NO_INPUT_NO_OUTPUT | Has no input and no output
AT_BLE_IO_CAP_KB_DISPLAY | Has both a display and a keyboard

◆ at_ble_key_dis_t

enum at_ble_key_dis_t

Security keys distribution list.

Enumerator
AT_BLE_KEY_DIST_NONE | No keys to distribute
AT_BLE_KEY_DIST_ENC | Distribute Encryption Key
AT_BLE_KEY_DIST_ID | Distribute ID Key
AT_BLE_KEY_DIST_SIGN | Distribute Signature Key
AT_BLE_KEY_DIS_ALL | Distribute All Keys

◆ at_ble_auth_levels_t

enum at_ble_auth_levels_t

Security authentication level.

Enumerator
AT_BLE_NO_SEC | no security
AT_BLE_MODE1_L1_NOAUTH_PAIR_ENC | Gap Mode 1 Level 1, Unauthenticated pairing with encryption, Man in the middle protection not checked, a LTK shall be exchanged
AT_BLE_MODE1_L2_AUTH_PAIR_ENC | Gap Mode 1 Level 2, Authenticated pairing with encryption, Man in the middle protection shall be set to 1, a LTK shall be exchanged
AT_BLE_MODE2_L1_NOAUTH_DATA_SGN | Gap Mode 2 Level 1, Unauthenticated pairing with data signing, Man in the middle protection not checked , a CSRK shall be exchanged
AT_BLE_MODE2_L2_AUTH_DATA_SGN | Gap Mode 2 Level 2, Authentication pairing with data signing, Man in the middle protection shall be set to 1, a CSRK shall be exchanged

◆ at_ble_uuid_type_t

enum at_ble_uuid_type_t

UUID Type.

Enumerator
AT_BLE_UUID_16 | 16 Bit UUID
AT_BLE_UUID_32 | 32 Bit UUID
AT_BLE_UUID_128 | 128 Bit UUID
AT_BLE_UUID_INVALID | Invalid UUID

◆ at_ble_char_properties_t

enum at_ble_char_properties_t

Characteristic properties (Each enum value is a single bit; multiple properties can be indicated simultaneously.)

Enumerator
AT_BLE_CHAR_BROADCST
AT_BLE_CHAR_READ
AT_BLE_CHAR_WRITE_WITHOUT_RESPONSE
AT_BLE_CHAR_WRITE
AT_BLE_CHAR_NOTIFY
AT_BLE_CHAR_INDICATE
AT_BLE_CHAR_SIGNED_WRITE
AT_BLE_CHAR_RELIABLE_WRITE
AT_BLE_CHAR_WRITEABLE_AUX

◆ at_ble_filter_type_t

enum at_ble_filter_type_t

Advertising Filter Policy.

Enumerator
AT_BLE_ADV_FP_ANY | Allow both scan and connection requests from anyone
AT_BLE_ADV_FP_FILTER_SCANREQ | Allow both scan request from White List devices only and connection request from anyone
AT_BLE_ADV_FP_FILTER_CONNREQ | Allow both scan request from anyone and connection request from White List devices only
AT_BLE_ADV_FP_FILTER_BOTH | Allow scan and connection requests from White List devices only

◆ at_ble_adv_mode_t

enum at_ble_adv_mode_t

Advertising Mode.

Enumerator
AT_BLE_ADV_NON_DISCOVERABLE | Mode in non-discoverable.
AT_BLE_ADV_GEN_DISCOVERABLE | Mode in general discoverable, AD type general flag in Flags set to 1.
AT_BLE_ADV_LIM_DISCOVERABLE | Mode in limited discoverable, AD type limited flag in Flags set to 1 (This mode is automatically stopped after 180 sec of activity)
AT_BLE_ADV_BROADCASTER_MODE | Broadcaster mode which is a non discoverable and non connectable mode.

◆ at_ble_scan_mode_t

enum at_ble_scan_mode_t

Scan modes used at at_ble_scan_start.

Enumerator
AT_BLE_SCAN_GEN_DISCOVERY | Send advertising report about device that advertise in limited or general mode ,the operation stops after 10 sec of activity
AT_BLE_SCAN_LIM_DISCOVERY | Send advertising report about device that advertise in limited mode ,the operation stops after 10 sec of activity
AT_BLE_SCAN_OBSERVER_MODE | Send any advertising report ,this operation can only be stopped by at_ble_scan_stop

◆ at_ble_scan_type_t

enum at_ble_scan_type_t

Scan types used at at_ble_scan_start.

Enumerator
AT_BLE_SCAN_PASSIVE | Passive scan, without transmitting.
AT_BLE_SCAN_ACTIVE | Active scan, using scan requests.

◆ at_ble_attr_permissions_t

enum at_ble_attr_permissions_t

Attribute Permissions.

Enumerator
AT_BLE_ATTR_NO_PERMISSIONS
AT_BLE_ATTR_READABLE_NO_AUTHN_NO_AUTHR
AT_BLE_ATTR_READABLE_REQ_AUTHN_NO_AUTHR
AT_BLE_ATTR_READABLE_NO_AUTHN_REQ_AUTHR
AT_BLE_ATTR_READABLE_REQ_AUTHN_REQ_AUTHR
AT_BLE_ATTR_WRITABLE_NO_AUTHN_NO_AUTHR
AT_BLE_ATTR_WRITABLE_REQ_AUTHN_NO_AUTHR
AT_BLE_ATTR_WRITABLE_NO_AUTHN_REQ_AUTHR
AT_BLE_ATTR_WRITABLE_REQ_AUTHN_REQ_AUTHR

◆ at_ble_char_pres_format_t

enum at_ble_char_pres_format_t

Presentation Formats.

Enumerator
AT_BLE_PRES_FORMAT_BOOLEAN
AT_BLE_PRES_FORMAT_2BIT
AT_BLE_PRES_FORMAT_NIBBLE
AT_BLE_PRES_FORMAT_UINT8
AT_BLE_PRES_FORMAT_UINT12
AT_BLE_PRES_FORMAT_UINT16
AT_BLE_PRES_FORMAT_UINT24
AT_BLE_PRES_FORMAT_UINT32
AT_BLE_PRES_FORMAT_UINT48
AT_BLE_PRES_FORMAT_UINT64
AT_BLE_PRES_FORMAT_UINT128
AT_BLE_PRES_FORMAT_SINT8
AT_BLE_PRES_FORMAT_SINT12
AT_BLE_PRES_FORMAT_SINT16
AT_BLE_PRES_FORMAT_SINT24
AT_BLE_PRES_FORMAT_SINT32
AT_BLE_PRES_FORMAT_SINT48
AT_BLE_PRES_FORMAT_SINT64
AT_BLE_PRES_FORMAT_SINT128
AT_BLE_PRES_FORMAT_FLOAT32
AT_BLE_PRES_FORMAT_FLOAT64
AT_BLE_PRES_FORMAT_SFLOAT
AT_BLE_PRES_FORMAT_FLOAT
AT_BLE_PRES_FORMAT_DUINT16
AT_BLE_PRES_FORMAT_UTF8S
AT_BLE_PRES_FORMAT_UTF16S
AT_BLE_PRES_FORMAT_STRUCT

◆ at_ble_pair_key_type_t

enum at_ble_pair_key_type_t

Pairing Key Types.

Enumerator
AT_BLE_PAIR_PASSKEY | A passkey is required at_ble_passkey_type_t for more details
AT_BLE_PAIR_OOB | Out of band key is required

◆ at_ble_passkey_type_t

enum at_ble_passkey_type_t

Passkey Types.

Enumerator
AT_BLE_PAIR_PASSKEY_ENTRY | A passkey entry is required
AT_BLE_PAIR_PASSKEY_DISPLAY | A passkey needs to be generated and displayed as part of pairing procedure

◆ at_ble_auth_t

enum at_ble_auth_t

Authorization Types.

Enumerator
AT_BLE_AUTH_NO_MITM_NO_BOND | No Man In The Middle protection(MITM) , No Bonding
AT_BLE_AUTH_NO_MITM_BOND | No MITM , Bonding
AT_BLE_AUTH_MITM_NO_BOND | MITM , No Bonding
AT_BLE_AUTH_MITM_BOND | MITM and Bonding

◆ at_ble_author_t

enum at_ble_author_t

Authorization setting.

Enumerator
GAP_AUTHZ_NOT_SET | Authorization not set, application informed when authorization requested.
GAP_AUTHZ_ACCEPT | Authorization request automatically accepted.
GAP_AUTHZ_REJECT | Authorization request automatically rejected.

◆ at_ble_att_write_perm_t

enum at_ble_att_write_perm_t

Write access.

Enumerator
AT_BLE_WRITE_DISABLE | Disable write access
AT_BLE_WRITE_ENABLE | Enable write access
AT_BLE_WRITE_UNAUTH | Write access require unauthenticated link
AT_BLE_WRITE_AUTH | Write access require authenticated link

◆ at_ble_prf_con_type_t

enum at_ble_prf_con_type_t

Connection type.

Enumerator
PRF_CON_DISCOVERY | Discovery type connection.
PRF_CON_NORMAL | Normal type connection.

◆ at_ble_gattc_discovery_complete_status_t

enum at_ble_gattc_discovery_complete_status_t

Discovery status.

Enumerator
AT_BLE_DISCOVERY_SUCCESS | GATTC discover operation complete.
AT_BLE_DISCOVERY_FAILURE | GATTC discover operation found no services.

◆ at_ble_htpt_db_config_flag

enum at_ble_htpt_db_config_flag

Health Thermometer Database Configuration Flags.

Enumerator
HTPT_TEMP_TYPE_CHAR_SUP | Indicate if Temperature Type Char. is supported.
HTPT_INTERM_TEMP_CHAR_SUP | Indicate if Intermediate Temperature Char. is supported.
HTPT_MEAS_INTV_CHAR_SUP | Indicate if Measurement Interval Char. is supported.
HTPT_MEAS_INTV_IND_SUP | Indicate if Measurement Interval Char. supports indications.
HTPT_MEAS_INTV_WR_SUP | Indicate if Measurement Interval Char. is writable.
HTPT_ALL_FEAT_SUP | All Features supported.

◆ at_ble_htpt_sec_level

enum at_ble_htpt_sec_level

Health Thermometer Service Security Level.

Enumerator
HTPT_DISABLE | Service can be browsed but attributes cannot be accessed.
HTPT_ENABLE | Service can be browsed and attributes can be accessed according to attribute permission.
HTPT_UNAUTH | Service can be used with minimum Unauthenticated Link (Just Work Pairing)
HTPT_AUTH | Service can be used with Authenticated Link (Pin code Pairing)

◆ at_ble_htpt_attr_index

enum at_ble_htpt_attr_index

Health Thermometer Attribute Table Indexes.

Enumerator
HTPT_TEMP_MEAS_CHAR
HTPT_TEMP_TYPE_CHAR
HTPT_INTERM_TEMP_CHAR
HTPT_MEAS_INTV_CHAR
HTPT_CHAR_MAX

◆ at_ble_htpt_temp_flags

enum at_ble_htpt_temp_flags

Health Thermometer Temperature Measurement Flags field bit values.

Enumerator
HTPT_FLAG_CELSIUS | Temperature Units Flag - Celsius.
HTPT_FLAG_FAHRENHEIT | Temperature Units Flag - Fahrenheit.
HTPT_FLAG_TIME | Time Stamp Flag.
HTPT_FLAG_TYPE | Temperature Type Flag.

◆ at_ble_htpt_temp_type

enum at_ble_htpt_temp_type

Health Thermometer Temperature Type Description.

Enumerator
HTP_TYPE_ARMPIT | Armpit.
HTP_TYPE_BODY | Body (general)
HTP_TYPE_EAR | Ear (usually ear lobe)
HTP_TYPE_FINGER | Finger.
HTP_TYPE_GASTRO_INTESTINAL_TRACT | Gastro-intestinal Tract.
HTP_TYPE_MOUTH | Mouth.
HTP_TYPE_RECTUM | Rectum.
HTP_TYPE_TOE | Toe.
HTP_TYPE_TYMPANUM | Tympanum (ear drum)

◆ at_ble_htpt_conn_type

enum at_ble_htpt_conn_type

Health Thermometer Connection Type.

Enumerator
HTPT_CONFIG_CONN
HTPT_NORMAL_CONN

◆ at_ble_htpt_ntfind

enum at_ble_htpt_ntfind

Health Thermometer Enable/Disable Notification/Indication.

Enumerator
HTPT_STOP_NTFIND | Stop notification/indication.
HTPT_START_NTF | Start notification.
HTPT_START_IND | Start indication.

◆ at_ble_htpt_ntf_ind_cfg

enum at_ble_htpt_ntf_ind_cfg

Health Thermometer Enable Notification/Indication for HTPT characteristics.

Enumerator
HTPT_CFG_STABLE_MEAS_IND | Stable measurement interval indication enabled.
HTPT_CFG_INTERM_MEAS_NTF | Intermediate measurement notification enabled.
HTPT_CFG_MEAS_INTV_IND | Measurement interval indication.


Atmel BLE API: GAP API

Functions
GAP API

Functions

at_ble_status_t | at_ble_init (void *args)
at_ble_status_t | at_ble_set_gap_deviceinfo (at_ble_gap_deviceinfo_t *gap_deviceinfo)
at_ble_status_t | at_ble_set_dev_config (at_ble_gap_role role)
at_ble_status_t | at_ble_device_name_set (uint8_t *dev_name, uint8_t len)
at_ble_status_t | at_ble_set_privacy_key (at_ble_gap_irk_t *irk, uint16_t interval)
at_ble_status_t | at_ble_addr_set (at_ble_addr_t *address)
at_ble_status_t | at_ble_addr_get (at_ble_addr_t *address)
at_ble_status_t | at_ble_event_get (at_ble_events_t *event, void *params, uint32_t timeout)
at_ble_status_t | at_ble_event_user_defined_post (void *params)
at_ble_status_t | at_ble_gap_set_param (at_ble_parameters_t param, uint8_t *value_buff, uint16_t value_len)
at_ble_status_t | at_ble_gap_get_param (at_ble_parameters_t param, uint8_t *value_buff, uint16_t value_len)
at_ble_status_t | at_ble_whitelist_add (at_ble_addr_t *address)
at_ble_status_t | at_ble_whitelist_remove (at_ble_addr_t *address)
at_ble_status_t | at_ble_whitelist_clear (void)
at_ble_status_t | at_ble_adv_data_set (uint8_t const *const adv_data, uint8_t adv_data_len, uint8_t const *const scan_resp_data, uint8_t scan_response_data_len)
at_ble_status_t | at_ble_adv_start (at_ble_adv_type_t type, at_ble_adv_mode_t mode, at_ble_addr_t *peer_addr, at_ble_filter_type_t filtered, uint16_t interval, uint16_t timeout, bool disable_randomness)
at_ble_status_t | at_ble_adv_stop (void)
at_ble_status_t | at_ble_adv_set_tx_power (int8_t power)
at_ble_status_t | at_ble_scan_start (uint16_t interval, uint16_t window, uint16_t timeout, at_ble_scan_type_t type, at_ble_scan_mode_t mode, bool filter_whitelist, bool filter_duplicates)
at_ble_status_t | at_ble_scan_stop (void)
at_ble_status_t | at_ble_connect (at_ble_addr_t peers[], uint8_t peer_count, uint16_t scan_interval, uint16_t scan_window, at_ble_connection_params_t *connection_params)
at_ble_status_t | at_ble_connect_cancel (void)
at_ble_status_t | at_ble_sec_info_set (at_ble_handle_t handle, at_ble_signature_info_t signature_info, at_ble_auth_t authen, at_ble_author_t author)
at_ble_status_t | at_ble_disconnect (at_ble_handle_t handle, at_ble_disconnect_reason_t reason)
at_ble_status_t | at_ble_connection_param_update (at_ble_handle_t handle, at_ble_connection_params_t *connection_params)
void | at_ble_conn_update_reply (at_ble_handle_t conn_handle, at_ble_connection_params_t *connection_params)
at_ble_status_t | at_ble_authenticate (at_ble_handle_t conn_handle, at_ble_pair_features_t *features, at_ble_LTK_t *ltk, at_ble_CSRK_t *csrk)
at_ble_status_t | at_ble_send_slave_sec_request (at_ble_handle_t conn_handle, bool mitm_protection, bool bond)
at_ble_status_t | at_ble_pair_key_reply (at_ble_handle_t conn_handle, at_ble_pair_key_type_t type, uint8_t *key)
at_ble_status_t | at_ble_encryption_start (at_ble_handle_t conn_handle, at_ble_LTK_t key, at_ble_auth_t auth)
at_ble_status_t | at_ble_encryption_request_reply (at_ble_handle_t conn_handle, uint8_t auth, bool key_found, at_ble_LTK_t key)
at_ble_status_t | at_ble_random_address_resolve (uint8_t nb_key, at_ble_addr_t *rand_addr, uint8_t *irk_key)
at_ble_status_t | at_ble_tx_power_set (at_ble_handle_t conn_handle, int8_t powerdBm)
int8_t | at_ble_tx_power_get (at_ble_handle_t conn_handle)
int8_t | at_ble_max_PA_gain_get (at_ble_handle_t conn_handle)
int8_t | at_ble_rx_power_get (at_ble_handle_t conn_handle)
at_ble_status_t | at_ble_rx_power_subscribe (at_ble_handle_t conn_handle, uint16_t range_max, uint16_t range_min)
at_ble_status_t | at_ble_rx_power_unsubscribe (at_ble_handle_t conn_handle)

Detailed Description

Function Documentation

◆ at_ble_init()

at_ble_status_t at_ble_init ( void * args )

Reset the link layer and the host.

Parameters
[in] args Pointer passed to platform_init() and interpreted by the platform.
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_PARAM Invalid parameter supplied
AT_BLE_FAILURE Generic error

◆ at_ble_set_gap_deviceinfo()

at_ble_status_t at_ble_set_gap_deviceinfo ( at_ble_gap_deviceinfo_t * gap_deviceinfo )

Set GAP attribute data base in BLE API (Appearance , slave preferred connection parameters , device name write permissions)

Parameters
[in] gap_deviceinfo gap device information
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_PARAM Invalid parameter supplied
AT_BLE_FAILURE Generic error

◆ at_ble_set_dev_config()

at_ble_status_t at_ble_set_dev_config ( at_ble_gap_role role )

Set GAP attribute data base into BLE chip.

Parameters
[in] role BLE role to set
Precondition
Must be called before at_ble_adv_start or at_ble_scan_start or at_ble_connect
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_PARAM Invalid parameter supplied
AT_BLE_FAILURE Generic error

◆ at_ble_device_name_set()

at_ble_status_t at_ble_device_name_set | ( | uint8_t * | dev_name,
 |  | uint8_t | len
 | ) |  |

Set device name.

Parameters
[in] | dev_name | the new device name
[in] | len | name length
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_PARAM Invalid parameter supplied
AT_BLE_FAILURE Generic error

◆ at_ble_set_privacy_key()

at_ble_status_t at_ble_set_privacy_key | ( | at_ble_gap_irk_t * | irk,
 |  | uint16_t | interval
 | ) |  |

Set device Identity Resolving Key.

Parameters
[in] | irk | device IRK used for resolvable random BD address generation
[in] | interval | duration before regenerate device address in 10 ms units
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_addr_set()

at_ble_status_t at_ble_addr_set ( at_ble_addr_t * address )

Set the local device BT Address.

Parameters
[in] address The new BT address
Precondition
In case of using resolvable random address, at_ble_set_privacy_key is used to set device IRK key otherwise default randomness IRK key values will be used.
Note
  • If address type is AT_BLE_ADDRESS_RANDOM_PRIVATE_RESOLVABLE or AT_BLE_ADDRESS_RANDOM_PRIVATE_NON_RESOLVABLE , the given address is ignored and address will be auto generated. If address type is AT_BLE_ADDRESS_RANDOM_STATIC and address value is NULL , address will be auto generated.
  • If address type is random , then AT_BLE_RAND_ADDR_CHANGED event is triggered after first air operation either advertising, connecting, or scanning to inform application about the used random address.
  • The default duration before regenerating device address is 10 minutes , to change renew address duration use at_ble_set_privacy_key.
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_PARAM Invalid parameter supplied
AT_BLE_FAILURE Generic error

◆ at_ble_addr_get()

at_ble_status_t at_ble_addr_get ( at_ble_addr_t * address )

Get device public BT Address.

Parameters
[out] address The current BT address
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_PARAM Invalid parameter supplied
AT_BLE_FAILURE Generic error

◆ at_ble_event_get()

at_ble_status_t at_ble_event_get | ( | at_ble_events_t * | event,
 |  | void * | params,
 |  | uint32_t | timeout
 | ) |  |

extracts the next event form the event queue

Parameters
[out] | event | The received event
[out] | params | Received event data
[in] | timeout | Time in millisecond this function will block waiting of an event (0xFFFFFFFF to block indefinitely) in this case, if the user wishes to unblock the function at_ble_event_user_defined_post can be used
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_event_user_defined_post()

at_ble_status_t at_ble_event_user_defined_post ( void * params )

Posts a user defined custom event into the event queue, allowing the user code to process other events in the same event handling loop. Events will be received with the as AT_BLE_CUSTOM_EVENT.

Parameters
[in] params Parameters sent to the custom event
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_gap_set_param()

at_ble_status_t at_ble_gap_set_param | ( | at_ble_parameters_t | param,
 |  | uint8_t * | value_buff,
 |  | uint16_t | value_len
 | ) |  |

Change the GAP related parameters.

Parameters
[in] | param | Parameter to set
[in] | value_buff | Buffer where value is stored
[in] | value_len | Value length
Warning
Not Supported
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_gap_get_param()

at_ble_status_t at_ble_gap_get_param | ( | at_ble_parameters_t | param,
 |  | uint8_t * | value_buff,
 |  | uint16_t | value_len
 | ) |  |

Fetch a GAP Parameter value.

Parameters
[in] | param | Parameter to get
[out] | value_buff | Buffer to store the value in
[out] | value_len | Value length
Warning
Not Supported
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_whitelist_add()

at_ble_status_t at_ble_whitelist_add ( at_ble_addr_t * address )

Adds a peer device address to the white-list.

Parameters
[in] address Peer device address
Note
To get scan results from only peers added to white list, make sure that "filter_whitelist" argument of at_ble_scan_start is true.
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_whitelist_remove()

at_ble_status_t at_ble_whitelist_remove ( at_ble_addr_t * address )

Removes a peer device address from the white-list.

Parameters
[in] address Peer device address
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_whitelist_clear()

at_ble_status_t at_ble_whitelist_clear ( void )

Clear the white-list.

Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_adv_data_set()

at_ble_status_t at_ble_adv_data_set | ( | uint8_t const *const | adv_data,
 |  | uint8_t | adv_data_len,
 |  | uint8_t const *const | scan_resp_data,
 |  | uint8_t | scan_response_data_len
 | ) |  |

Set, clear or update advertisement and scan response data.

Note
  • To clear the advertisement data and set it to a 0-length packet, simply provide a valid pointer (pAdvData/pSrData) with its corresponding length (dlen/srdlen) set to 0.
  • The call will fail if pAdvData and pSrData are both NULL since this would have no effect.
Parameters
[in] | adv_data | Raw data to be placed in advertisement packet. If NULL, no changes are made to the current advertisement packet data.
[in] | adv_data_len | Data length for adv_data.
[in] | scan_resp_data | Raw data to be placed in scan response packet. If NULL, no changes are made to the current scan response packet data.
[in] | scan_response_data_len | Data length for scan_resp_data
Returns
AT_BLE_SUCCESS Advertisement data successfully updated or cleared.
AT_BLE_INVALID_PARAM One of the length parameters is invalid.
AT_BLE_FAILURE Both pointer parameters are invalid.

◆ at_ble_adv_start()

at_ble_status_t at_ble_adv_start | ( | at_ble_adv_type_t | type,
 |  | at_ble_adv_mode_t | mode,
 |  | at_ble_addr_t * | peer_addr,
 |  | at_ble_filter_type_t | filtered,
 |  | uint16_t | interval,
 |  | uint16_t | timeout,
 |  | bool | disable_randomness
 | ) |  |

Start advertising (GAP Discoverable, Connectable modes, Broadcast Procedure).

Parameters
[in] | type | Advertising type, see at_ble_adv_type_t for more info
[in] | mode | either non-discoverable,General, Limited or Broadcaster , at_ble_adv_mode_t for more details
[in] | peer_addr | For AT_BLE_ADV_TYPE_DIRECTED mode only, known peer address
[in] | filtered | policy at_ble_filter_type_t for more details
[in] | interval | Advertising interval between 0x0020 and 0x4000 in 0.625 ms units (20ms to 10.24s). This parameter must be set to 0 if type equals AT_BLE_ADV_TYPE_DIRECTED
[in] | timeout | Advertising time-out between 0x0001 and 0x3FFF in seconds, 0x0000 disables time-out. This parameter must be set to 0 if type equals AT_BLE_ADV_TYPE_DIRECTED
[in] | disable_randomness | if True the device will advertise at the exact interval without adding the random 10msec
Precondition
If it is required to change BD address, at_ble_addr_set should be used otherwise default address will be used
Warning
Advertising time-out "timeout" and randomness "disable_randomness" features are not supported.
Returns
AT_BLE_SUCCESS The BLE stack has started advertising
AT_BLE_PRIVACY_CFG_PB Advertising type conflicts with local device address type
AT_BLE_INVALID_PARAM Invalid parameter supplied
AT_BLE_FAILURE Generic error

◆ at_ble_adv_stop()

at_ble_status_t at_ble_adv_stop ( void )

Stop advertising (GAP Discoverable, Connectable modes, Broadcast Procedure).

Returns
AT_BLE_SUCCESS The BLE stack has stopped advertising
AT_BLE_FAILURE Error to stop advertising (most probably not in advertising state)

◆ at_ble_adv_set_tx_power()

at_ble_status_t at_ble_adv_set_tx_power ( int8_t power )

Set the Advertising transmission power.

Parameters
[in] power New TX power in dB (attenuation 0..18 db in 3dB steps)
Returns
AT_BLE_SUCCESS TX value changed successfully
AT_BLE_INVALID_PARAM TX value is out of range
AT_BLE_FAILURE Other error
Warning
This function is NOT IMPLEMENTED and returns AT_BLE_FAILURE.

◆ at_ble_scan_start()

at_ble_status_t at_ble_scan_start | ( | uint16_t | interval,
 |  | uint16_t | window,
 |  | uint16_t | timeout,
 |  | at_ble_scan_type_t | type,
 |  | at_ble_scan_mode_t | mode,
 |  | bool | filter_whitelist,
 |  | bool | filter_duplicates
 | ) |  |

Start scan operation.

While the scan operation is ongoing, the application will always receive AT_BLE_SCAN_INFO event per found device.
In case of using AT_BLE_SCAN_GEN_DISCOVERY or AT_BLE_SCAN_LIM_DISCOVERY, also AT_BLE_SCAN_REPORT event will be received at the end of scan process.

Parameters
[in] | interval | Scan interval in 625us units
[in] | window | Scan window in 625us units
[in] | timeout | Scan time-out, 0x0000 disables time-out.
[in] | type | Controls the type of scan to perform either Passive or Active at_ble_scan_type_t for more details.
[in] | mode | Either General, Limited or Observer only, at_ble_scan_mode_t for more details
[in] | filter_whitelist | If true, get scan results only from white-listed devices added by at_ble_whitelist_add otherwise scan results will be got from any advertising device.
[in] | filter_duplicates | If true, scan event will be generated only once per device. If false, multiple events per device may be generated. Note that if more than 10 devices are found, filtering only applies to the first 10 found; multiple scan events may be generated for 11th and subsequent devices.
Warning
Scan time-out feature is not supported.
Returns
AT_BLE_SUCCESS Scan operation started successfully
AT_BLE_INVALID_PARAM Invalid parameter supplied
AT_BLE_FAILURE Generic error

◆ at_ble_scan_stop()

at_ble_status_t at_ble_scan_stop ( void )

Stops an ongoing scan operation.

Returns
AT_BLE_SUCCESS Scan operation stopped successfully
AT_BLE_FAILURE Generic error

◆ at_ble_connect()

at_ble_status_t at_ble_connect | ( | at_ble_addr_t | peers[],
 |  | uint8_t | peer_count,
 |  | uint16_t | scan_interval,
 |  | uint16_t | scan_window,
 |  | at_ble_connection_params_t * | connection_params
 | ) |  |

Connect to a peer device.

Connecting to a peer device, implicitly starting the necessary scan operation then connecting if a device in the peers list is found. This API returns immediately after the operation is programmed, actual connection establishment or failure is marked with AT_BLE_CONNECTED event

Parameters
[in] | peers | a list of peers that the device will connect to one of them
[in] | peer_count | number of elements in peers, 0 to connect to any peer device
[in] | scan_interval | scan interval in 625us units
[in] | scan_window | scan window in 625us units
[in] | connection_params | parameters of the established connection
Returns
AT_BLE_SUCCESS Operation programmed successfully
AT_BLE_INVALID_PARAM Invalid parameter supplied
AT_BLE_FAILURE Generic error

◆ at_ble_connect_cancel()

at_ble_status_t at_ble_connect_cancel ( void )

Cancels an ongoing connection attempt.

Returns
AT_BLE_SUCCESS Operation canceled successfully
AT_BLE_FAILURE Generic error

◆ at_ble_sec_info_set()

at_ble_status_t at_ble_sec_info_set | ( | at_ble_handle_t | handle,
 |  | at_ble_signature_info_t | signature_info,
 |  | at_ble_auth_t | authen,
 |  | at_ble_author_t | author
 | ) |  |

Set specific link security configuration and bonding data.

Parameters
[in] | handle | Handle of the connection to be terminated
[in] | signature_info | Signature_info, more info at at_ble_signature_info_t
[in] | authen | Authentication value, one of at_ble_auth_t
[in] | author | Authorization value, one of at_ble_author_t
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_disconnect()

at_ble_status_t at_ble_disconnect | ( | at_ble_handle_t | handle,
 |  | at_ble_disconnect_reason_t | reason
 | ) |  |

Disconnect a connected peer device.

Parameters
[in] | handle | Handle of the connection to be terminated
[in] | reason | Disconnection reason, more info at at_ble_disconnect_reason_t
Returns
AT_BLE_SUCCESS Operation programmed successfully
AT_BLE_INVALID_PARAM Invalid parameter supplied
AT_BLE_FAILURE Generic error

◆ at_ble_connection_param_update()

at_ble_status_t at_ble_connection_param_update | ( | at_ble_handle_t | handle,
 |  | at_ble_connection_params_t * | connection_params
 | ) |  |

Update the connection parameters of an ongoing connection.

This API returns after programming the new values but before they take effect; the actual effect of the parameters is marked by the event AT_BLE_CONN_PARAM_UPDATE_DONE

Parameters
[in] | handle | Handle of the connection to be updated
[in] | connection_params | New parameters to be used
Returns
AT_BLE_SUCCESS Operation programmed successfully
AT_BLE_INVALID_PARAM Invalid parameter supplied
AT_BLE_FAILURE Generic error

◆ at_ble_conn_update_reply()

void at_ble_conn_update_reply | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_connection_params_t * | connection_params
 | ) |  |

Reply to connection parameters update request AT_BLE_CONN_PARAM_UPDATE_REQUEST.

Parameters
[in] | conn_handle | Handle of the connection to be updated
[in] | connection_params | New parameters to be used
Returns
AT_BLE_SUCCESS Operation programmed successfully
AT_BLE_INVALID_PARAM Invalid parameter supplied
AT_BLE_FAILURE Generic error

◆ at_ble_authenticate()

at_ble_status_t at_ble_authenticate | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_pair_features_t * | features,
 |  | at_ble_LTK_t * | ltk,
 |  | at_ble_CSRK_t * | csrk
 | ) |  |

Starts Pairing procedure for a given connection.

This API will initiate the authentication procedure, given local device requirements and IO capabilities the authentication will proceed in a number of ways, progress is monitored and controlled via the events : AT_BLE_PAIR_KEY_REQUEST ,AT_BLE_PAIR_DONE

In the central role, this function will send an SMP Pairing Request, otherwise in the peripheral role, this function will reply to AT_BLE_PAIR_REQUEST.

Note
  • Bonding information(information exchanged during pairing)such as key , authentication level should be stored by application in order to be reused during another connection
  • According to IO capabilities or Out Of Band (OOB), if it is possible to perform a pairing using PIN code or OOB data then AT_BLE_PAIR_KEY_REQUEST event will be received by application.
Parameters
[in] | conn_handle | Handle of the ongoing connection
[in] | features | Local device requirements and IO capabilities
[in] | ltk | Local device Long Term Key, null if not available
[in] | csrk | Local device Connection Signature Resolution Key , null if not available
Returns
AT_BLE_SUCCESS Operation programmed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_send_slave_sec_request()

at_ble_status_t at_ble_send_slave_sec_request | ( | at_ble_handle_t | conn_handle,
 |  | bool | mitm_protection,
 |  | bool | bond
 | ) |  |

Send slave security request to master.

Parameters
[in] | conn_handle | Handle of the ongoing connection
[in] | mitm_protection | Boolean value for Man-In-The-Middle protection 0 -> Disable, 1 -> Enable
[in] | bond | Boolean value for bonding 0 -> Disable, 1 -> Enable
Returns
AT_BLE_SUCCESS Operation programmed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_pair_key_reply()

at_ble_status_t at_ble_pair_key_reply | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_pair_key_type_t | type,
 |  | uint8_t * | key
 | ) |  |

Provides a passkey or OOB data that was requested via AT_BLE_PAIR_KEY_REQUEST event, If key type is AT_BLE_PAIR_PASSKEY, then a 6-byte ASCII string (digit 0..9 only). If key type is AT_BLE_PAIR_OOB , then a 16-byte OOB key value in Little Endian format.

Parameters
[in] | conn_handle | Handle of the ongoing connection
[in] | type | Type of requested key, must match the one asked for in AT_BLE_PAIR_KEY_REQUEST
[in] | key | The key requested
Returns
AT_BLE_SUCCESS Operation programmed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_encryption_start()

at_ble_status_t at_ble_encryption_start | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_LTK_t | key,
 |  | at_ble_auth_t | auth
 | ) |  |

Starts encryption, once encryption starts AT_BLE_ENCRYPTION_STATUS_CHANGED event is delivered.

Parameters
[in] | conn_handle | Handle of the connection to be updated
[in] | key | LTK key used for encryption
[in] | auth | Authentication level , this information must be stored in device database after each pairing process at_ble_pair_done_t
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_encryption_request_reply()

at_ble_status_t at_ble_encryption_request_reply | ( | at_ble_handle_t | conn_handle,
 |  | uint8_t | auth,
 |  | bool | key_found,
 |  | at_ble_LTK_t | key
 | ) |  |

Responds to encryption start request from master device AT_BLE_ENCRYPTION_REQUEST , once encryption starts AT_BLE_ENCRYPTION_STATUS_CHANGED event is delivered.

Parameters
[in] | conn_handle | Handle of the connection to be updated
[in] | key_found | If true then a valid key is found in device database and will be used
[in] | auth | Authentication level
[in] | key | LTK key used for encryption
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_random_address_resolve()

at_ble_status_t at_ble_random_address_resolve | ( | uint8_t | nb_key,
 |  | at_ble_addr_t * | rand_addr,
 |  | uint8_t * | irk_key
 | ) |  |

Handles request of resolving a resolvable random address ,AT_BLE_RESOLV_RAND_ADDR_STATUS event is used to inform which key has been used to perform resolution.

Parameters
[in] | nb_key | Number of provided IRK
[in] | rand_addr | Pointer to the random address
[in] | irk_key | Array of IRK used for address resolution
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_PARAM Invalid parameter supplied
AT_BLE_FAILURE Generic error

◆ at_ble_tx_power_set()

at_ble_status_t at_ble_tx_power_set | ( | at_ble_handle_t | conn_handle,
 |  | int8_t | powerdBm
 | ) |  |

Sets TX gain, relative to maximum gain, for a given connection.

Parameters
[in] | conn_handle | Handle of the connection
[in] | powerdBm | Reduction of TX gain in dB (attenuation 0..18 dB in 3dB steps). Valid inputs are 0,3,6,...,18.
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_PARAM Invalid parameter supplied
1: Operation completed. In this case, the gain reduction requested is greater than the maximum gain for some channels; for those channels, the gain has been reduced to 0.

◆ at_ble_tx_power_get()

int8_t at_ble_tx_power_get ( at_ble_handle_t conn_handle )

Gets TX power of a given connection.

Parameters
[in] conn_handle handle of the connection
Returns
PA gain in dB

◆ at_ble_max_PA_gain_get()

int8_t at_ble_max_PA_gain_get ( at_ble_handle_t conn_handle )

Gets maximum allowed TX gain of a given connection.

Parameters
[in] conn_handle Handle of the connection
Returns
Maximum PA gain in dB

◆ at_ble_rx_power_get()

int8_t at_ble_rx_power_get ( at_ble_handle_t conn_handle )

Gets RX power of a given connection.

Parameters
[in] conn_handle Handle of the connection
Returns
RX power (RSSI) in dBm 0 or -1: Failed to get RX power

◆ at_ble_rx_power_subscribe()

at_ble_status_t at_ble_rx_power_subscribe | ( | at_ble_handle_t | conn_handle,
 |  | uint16_t | range_max,
 |  | uint16_t | range_min
 | ) |  |

Subscribes for RX power level notifications.

If RX power falls between range_min and range_max the event AT_BLE_RX_POWER_VALUE will be received.

Parameters
[in] | conn_handle | Handle of the connection
[in] | range_max | Notifications will be received if RX power falls under this value but over range_min
[in] | range_min | Notifications will be received if RX power falls over this value but under range_max
Warning
Not Supported
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_rx_power_unsubscribe()

at_ble_status_t at_ble_rx_power_unsubscribe ( at_ble_handle_t conn_handle )

Unsubscribe form RX power level notifications.

no more AT_BLE_RX_POWER_VALUE events will be received

Parameters
[in] conn_handle Handle of the connection
Warning
Not Supported
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error


Atmel BLE API: GATT client API

Functions
GATT client API

Functions

at_ble_status_t | at_ble_primary_service_discover_all (at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle)
at_ble_status_t | at_ble_primary_service_discover_by_uuid (at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle, at_ble_uuid_t *uuid)
at_ble_status_t | at_ble_included_service_discover_all (at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle)
at_ble_status_t | at_ble_characteristic_discover_all (at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle)
at_ble_status_t | at_ble_characteristic_discover_by_uuid (at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle, at_ble_uuid_t *uuid)
at_ble_status_t | at_ble_descriptor_discover_all (at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle)
at_ble_status_t | at_ble_characteristic_read_by_uuid (at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle, at_ble_uuid_t *uuid)
at_ble_status_t | at_ble_characteristic_read (at_ble_handle_t conn_handle, at_ble_handle_t char_handle, uint16_t offset, uint16_t length)
at_ble_status_t | at_ble_characteristic_read_multible (at_ble_handle_t conn_handle, at_ble_handle_t *char_handle_list, uint16_t *char_val_lenght, uint8_t char_handle_count)
at_ble_status_t | at_ble_characteristic_write (at_ble_handle_t conn_handle, at_ble_handle_t char_handle, uint16_t offset, uint16_t length, uint8_t *data, bool signed_write, bool with_response)
at_ble_status_t | at_ble_characteristic_reliable_write_prepare (at_ble_handle_t conn_handle, at_ble_handle_t char_handle, uint16_t offset, uint16_t length, uint8_t *data)
at_ble_status_t | at_ble_characteristic_reliable_write_execute (at_ble_handle_t conn_handle)
at_ble_status_t | at_ble_characteristic_reliable_write_cancel (at_ble_handle_t conn_handle)
at_ble_status_t | at_ble_exchange_mtu (at_ble_handle_t conn_handle)

Detailed Description

Function Documentation

◆ at_ble_primary_service_discover_all()

at_ble_status_t at_ble_primary_service_discover_all | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_handle_t | start_handle,
 |  | at_ble_handle_t | end_handle
 | ) |  |

Discover all Primary services declared in a connected device.

Search will go from start_handle to end_handle, whenever a service is found AT_BLE_PRIMARY_SERVICE_FOUND event is sent and AT_BLE_DISCOVERY_COMPLETE is sent at end of discover operation.

Parameters
[in] | conn_handle | Handle of the connection
[in] | start_handle | Start of the searched range
[in] | end_handle | End of the searched range
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_PARAM Invalid arguments
AT_BLE_FAILURE Generic error

◆ at_ble_primary_service_discover_by_uuid()

at_ble_status_t at_ble_primary_service_discover_by_uuid | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_handle_t | start_handle,
 |  | at_ble_handle_t | end_handle,
 |  | at_ble_uuid_t * | uuid
 | ) |  |

Discover all Primary services of a given UUID declared in a connected device.

Search will go from start_handle to end_handle, whenever a service of matching UUID is found AT_BLE_PRIMARY_SERVICE_FOUND event is sent and AT_BLE_DISCOVERY_COMPLETE is sent at end of discover operation.

Parameters
[in] | conn_handle | Handle of the connection
[in] | start_handle | Start of the searched range
[in] | end_handle | End of the searched range
[in] | uuid | UUID of the service to be found, with LSB byte First in UUID value member
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_PARAM Invalid arguments
AT_BLE_FAILURE Generic error

◆ at_ble_included_service_discover_all()

at_ble_status_t at_ble_included_service_discover_all | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_handle_t | start_handle,
 |  | at_ble_handle_t | end_handle
 | ) |  |

Discover all included services declared in a connected device.

Search will go from start_handle to end_handle, whenever a service is found AT_BLE_INCLUDED_SERVICE_FOUND event is sent and AT_BLE_DISCOVERY_COMPLETE is sent at end of discover operation.

Parameters
[in] | conn_handle | Handle of the connection
[in] | start_handle | Start of the searched range
[in] | end_handle | End of the searched range
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_PARAM Invalid arguments
AT_BLE_FAILURE Generic error

◆ at_ble_characteristic_discover_all()

at_ble_status_t at_ble_characteristic_discover_all | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_handle_t | start_handle,
 |  | at_ble_handle_t | end_handle
 | ) |  |

Discover all Characteristics declared in a connected device.

Search will go from start_handle to end_handle, whenever a characteristic is found AT_BLE_CHARACTERISTIC_FOUND event is sent and AT_BLE_DISCOVERY_COMPLETE is sent at end of discover operation.

Parameters
[in] | conn_handle | Handle of the connection
[in] | start_handle | Start of the searched range
[in] | end_handle | End of the searched range
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_PARAM Invalid arguments
AT_BLE_FAILURE Generic error

◆ at_ble_characteristic_discover_by_uuid()

at_ble_status_t at_ble_characteristic_discover_by_uuid | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_handle_t | start_handle,
 |  | at_ble_handle_t | end_handle,
 |  | at_ble_uuid_t * | uuid
 | ) |  |

Discover all Characteristics of a given UUID declared in a connected device.

Search will go from start_handle to end_handle, whenever a characteristic of matching UUID is found AT_BLE_CHARACTERISTIC_FOUND event is sent and AT_BLE_DISCOVERY_COMPLETE is sent at end of discover operation.

Parameters
[in] | conn_handle | Handle of the connection
[in] | start_handle | Start of the searched range
[in] | end_handle | End of the searched range
[in] | uuid | UUID of the characteristic to be found, with LSB byte First in UUID value member
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_PARAM Invalid arguments
AT_BLE_FAILURE Generic error

◆ at_ble_descriptor_discover_all()

at_ble_status_t at_ble_descriptor_discover_all | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_handle_t | start_handle,
 |  | at_ble_handle_t | end_handle
 | ) |  |

Discover all Descriptors declared in a connected device.

Search will go from start_handle to end_handle, whenever a descriptor is found AT_BLE_DESCRIPTOR_FOUND event is sent and AT_BLE_DISCOVERY_COMPLETE is sent at end of discover operation.

Parameters
[in] | conn_handle | Handle of the connection
[in] | start_handle | Start of the searched range
[in] | end_handle | End of the searched range
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_PARAM Invalid arguments
AT_BLE_FAILURE Generic error

◆ at_ble_characteristic_read_by_uuid()

at_ble_status_t at_ble_characteristic_read_by_uuid | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_handle_t | start_handle,
 |  | at_ble_handle_t | end_handle,
 |  | at_ble_uuid_t * | uuid
 | ) |  |

Read a characteristic given its UUID.

Search will go from start_handle to end_handle, whenever a descriptor with given UUID is found its value will be read and reported via AT_BLE_CHARACTERISTIC_READ_RESPONSE event.

Parameters
[in] | conn_handle | Handle of the connection
[in] | start_handle | Start of the searched range
[in] | end_handle | End of the searched range
[in] | uuid | UUID of the read characteristic, with LSB byte First in UUID value member
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_characteristic_read()

at_ble_status_t at_ble_characteristic_read | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_handle_t | char_handle,
 |  | uint16_t | offset,
 |  | uint16_t | length
 | ) |  |

Read a characteristic given its handle.

Read value will be reported via AT_BLE_CHARACTERISTIC_READ_RESPONSE event.

Parameters
[in] | conn_handle | Handle of the connection
[in] | char_handle | Handle of the characteristic
[in] | offset | Offset at where to start reading
[in] | length | Maximum length of data to read
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_PARAM Invalid arguments
AT_BLE_FAILURE Generic error

◆ at_ble_characteristic_read_multible()

at_ble_status_t at_ble_characteristic_read_multible | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_handle_t * | char_handle_list,
 |  | uint16_t * | char_val_lenght,
 |  | uint8_t | char_handle_count
 | ) |  |

Read a list of characteristics given their handles.

Read values will be reported via AT_BLE_CHARACTERISTIC_READ_MULTIBLE_RESPONSE event.

Parameters
[in] | conn_handle | Handle of the connection
[in] | char_handle_list | List of characteristic handles
[in] | char_val_lenght | Length of characteristic handle
[in] | char_handle_count | Number of characteristic handles
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_characteristic_write()

at_ble_status_t at_ble_characteristic_write | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_handle_t | char_handle,
 |  | uint16_t | offset,
 |  | uint16_t | length,
 |  | uint8_t * | data,
 |  | bool | signed_write,
 |  | bool | with_response
 | ) |  |

Write a characteristic.

If with_response is True, write completion will be reported via AT_BLE_CHARACTERISTIC_WRITE_RESPONSE event.

Parameters
[in] | conn_handle | Handle of the connection
[in] | char_handle | Handle of the characteristic
[in] | offset | Offset at where to start write
[in] | length | Length of data to write
[in] | data | A buffer where write data is stored
[in] | signed_write | If true, perform a signed write
[in] | with_response | If true, perform a write with response procedure, otherwise perform write with no response procedure
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_characteristic_reliable_write_prepare()

at_ble_status_t at_ble_characteristic_reliable_write_prepare | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_handle_t | char_handle,
 |  | uint16_t | offset,
 |  | uint16_t | length,
 |  | uint8_t * | data
 | ) |  |

Add a new prepared write request.

Adds a new request to a pending prepared write operation, or starts a new prepared write operation if none was started before.

Parameters
[in] | conn_handle | Handle of the connection
[in] | char_handle | Handle of the characteristic
[in] | offset | Offset at where to start write
[in] | length | Length of data to write
[in] | data | A buffer where write data is stored
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_characteristic_reliable_write_execute()

at_ble_status_t at_ble_characteristic_reliable_write_execute ( at_ble_handle_t conn_handle )

Executes a pending prepared write operation.

Executes a pending prepared write operation. Write completion will be reported via AT_BLE_CHARACTERISTIC_WRITE_RESPONSE event.

Parameters
[in] conn_handle Handle of the connection
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_characteristic_reliable_write_cancel()

at_ble_status_t at_ble_characteristic_reliable_write_cancel ( at_ble_handle_t conn_handle )

Cancels a pending prepared write operation.

Cancels a pending prepared write operation.

Parameters
[in] conn_handle Handle of the connection
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_exchange_mtu()

at_ble_status_t at_ble_exchange_mtu ( at_ble_handle_t conn_handle )

This message is used by the application to initiate the MTU exchange.

Parameters
[in] conn_handle Handle of the connection
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error


Atmel BLE API: GATT server API

Functions
GATT server API

Functions

at_ble_status_t | at_ble_primary_service_define (at_ble_uuid_t *uuid, at_ble_handle_t *service_handle, at_ble_included_service_t *included_service_list, uint16_t included_service_count, at_ble_characteristic_t *charactristic_list, uint16_t charactristic_count)
at_ble_status_t | at_ble_secondary_service_define (at_ble_uuid_t *uuid, at_ble_handle_t *service_handle, at_ble_included_service_t *included_service_list, uint16_t included_service_count, at_ble_characteristic_t *charactristic_list, uint16_t charactristic_count)
at_ble_status_t | at_ble_characteristic_value_set (at_ble_handle_t handle, uint8_t *value, uint16_t offset, uint16_t len)
at_ble_status_t | at_ble_characteristic_value_get (at_ble_handle_t handle, uint8_t *value, uint16_t offset, uint16_t len, uint16_t actual_read_len)
at_ble_status_t | at_ble_notification_send (at_ble_handle_t conn_handle, at_ble_handle_t attr_handle)
at_ble_status_t | at_ble_indication_send (at_ble_handle_t conn_handle, at_ble_handle_t attr_handle)
at_ble_status_t | at_ble_service_changed_notification_send (at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle)
at_ble_status_t | at_ble_read_authorize_reply (at_ble_handle_t conn_handle, at_ble_handle_t attr_handle, bool grant_authorization, bool update_value, uint8_t *value, uint16_t offset, uint16_t len)
at_ble_status_t | at_ble_write_authorize_reply (at_ble_handle_t conn_handle, at_ble_handle_t attr_handle, bool grant_authorization)

Detailed Description

Function Documentation

◆ at_ble_primary_service_define()

at_ble_status_t at_ble_primary_service_define | ( | at_ble_uuid_t * | uuid,
 |  | at_ble_handle_t * | service_handle,
 |  | at_ble_included_service_t * | included_service_list,
 |  | uint16_t | included_service_count,
 |  | at_ble_characteristic_t * | charactristic_list,
 |  | uint16_t | charactristic_count
 | ) |  |

Defines a new Primary service along with its included services and characteristics.

Parameters
[in] | uuid | The primary service UUID
[out] | service_handle | The Service handle will be returned here
[in] | included_service_list | An array of included service references
[in] | included_service_count | Number of elements in included_service_list
[in,out] | charactristic_list | An array of characteristics included in the service, this array is update with respective characteristics handles.
[in] | charactristic_count | Number of elements in charactristic_list
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INSUFF_RESOURCE Not enough memory to complete operation
AT_BLE_FAILURE Generic error

◆ at_ble_secondary_service_define()

at_ble_status_t at_ble_secondary_service_define | ( | at_ble_uuid_t * | uuid,
 |  | at_ble_handle_t * | service_handle,
 |  | at_ble_included_service_t * | included_service_list,
 |  | uint16_t | included_service_count,
 |  | at_ble_characteristic_t * | charactristic_list,
 |  | uint16_t | charactristic_count
 | ) |  |

Defines a new Secondary service along with its included services and characteristics.

Parameters
[in] | uuid | The secondary service UUID
[out] | service_handle | The Service handle will be returned here
[in] | included_service_list | An array of included service references
[in] | included_service_count | Number of elements in included_service_list
[in,out] | charactristic_list | An array of characteristics included in the service, this array is update with respective characteristics handles.
[in] | charactristic_count | Number of elements in charactristic_list
Note
  • Secondary Services are only relevant in the context of the entity that references them, It is therefore forbidden to add a secondary service declaration that is not referenced by another service later in the ATT table
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INSUFF_RESOURCE not enough memory to complete operation
AT_BLE_FAILURE Generic error

◆ at_ble_characteristic_value_set()

at_ble_status_t at_ble_characteristic_value_set | ( | at_ble_handle_t | handle,
 |  | uint8_t * | value,
 |  | uint16_t | offset,
 |  | uint16_t | len
 | ) |  |

Sets a characteristic value.

Parameters
[in] | handle | Characteristic value handle
[in] | value | New value
[in] | offset | Where the writing starts
[in] | len | Value length, in bytes
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_HANDLE Invalid handle
AT_BLE_FAILURE Generic error

◆ at_ble_characteristic_value_get()

at_ble_status_t at_ble_characteristic_value_get | ( | at_ble_handle_t | handle,
 |  | uint8_t * | value,
 |  | uint16_t | offset,
 |  | uint16_t | len,
 |  | uint16_t | actual_read_len
 | ) |  |

Reads a characteristic value.

Parameters
[in] | handle | Characteristic value handle
[out] | value | Read value will be returned here
[in] | offset | Where the reading starts
[in] | len | Desired read length, in bytes
[in] | actual_read_len | Actual read length, in bytes
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_HANDLE Invalid handle
AT_BLE_FAILURE Generic error

◆ at_ble_notification_send()

at_ble_status_t at_ble_notification_send | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_handle_t | attr_handle
 | ) |  |

Sends a Notification.

Parameters
[in] | conn_handle | Handle of the connection to be notified
[in] | attr_handle | Handle of the attribute originating the notification
Precondition
If the value has been updated, it is required to use at_ble_characteristic_value_set first
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_HANDLE Invalid handle
AT_BLE_FAILURE Generic error

◆ at_ble_indication_send()

at_ble_status_t at_ble_indication_send | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_handle_t | attr_handle
 | ) |  |

Sends an Indication.

Parameters
[in] | conn_handle | Handle of the connection to be notified
[in] | attr_handle | Handle of the attribute originating the indication
Precondition
If the value has been updated, it is required to use at_ble_characteristic_value_set first
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_INVALID_HANDLE Invalid handle
AT_BLE_FAILURE Generic error

◆ at_ble_service_changed_notification_send()

at_ble_status_t at_ble_service_changed_notification_send | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_handle_t | start_handle,
 |  | at_ble_handle_t | end_handle
 | ) |  |

Sends a Service changed Notification.

Parameters
[in] | conn_handle | Handle of the connection to which the notification will be sent
[in] | start_handle | Start of affected handle range
[in] | end_handle | End of affected handle range
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_read_authorize_reply()

at_ble_status_t at_ble_read_authorize_reply | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_handle_t | attr_handle,
 |  | bool | grant_authorization,
 |  | bool | update_value,
 |  | uint8_t * | value,
 |  | uint16_t | offset,
 |  | uint16_t | len
 | ) |  |

Replies to a read authorization request requested by by AT_BLE_READ_AUTHORIZE_REQUEST event.

Parameters
[in] | conn_handle | Handle of the connection
[in] | attr_handle | Handle of the attribute to read
[in] | grant_authorization | If True, Authorization is granted
[in] | update_value | If True, the value, offset, length of parameters will be used to update this attribute value
[in] | value | New value
[in] | offset | Where the writing starts
[in] | len | Value length, in bytes
Warning
Not Supported
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_write_authorize_reply()

at_ble_status_t at_ble_write_authorize_reply | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_handle_t | attr_handle,
 |  | bool | grant_authorization
 | ) |  |

Replies to a write authorization request requested by by AT_BLE_WRITE_AUTHORIZE_REQUEST event.

Parameters
[in] | conn_handle | Handle of the connection
[in] | attr_handle | Handle of the attribute to write
[in] | grant_authorization | If True, Authorization is granted
Warning
Not Supported
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error


Atmel BLE API: L2CAP API

Functions
L2CAP API

Functions

at_ble_status_t | at_ble_l2cap_cid_register (at_ble_handle_t conn_handle, uint16_t cid)
at_ble_status_t | at_ble_l2cap_cid_unregister (at_ble_handle_t conn_handle, uint16_t cid)
at_ble_status_t | at_ble_l2cap_tx (at_ble_handle_t conn_handle, uint16_t cid, uint8_t *data, uint16_t len)

Detailed Description

Function Documentation

◆ at_ble_l2cap_cid_register()

at_ble_status_t at_ble_l2cap_cid_register | ( | at_ble_handle_t | conn_handle,
 |  | uint16_t | cid
 | ) |  |

Registers a custom CID to received data from, when the L2CAP received data on the registered CID an AT_BLE_L2CAP_RX event will be reported.

Parameters
[in] | conn_handle | Handle of the connection
[in] | cid | L2CAP CID to register
Warning
Not Supported
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_l2cap_cid_unregister()

at_ble_status_t at_ble_l2cap_cid_unregister | ( | at_ble_handle_t | conn_handle,
 |  | uint16_t | cid
 | ) |  |

Unregister a previously registered custom CID.

Parameters
[in] | conn_handle | Handle of the connection
[in] | cid | L2CAP CID to unregister
Warning
Not Supported
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error

◆ at_ble_l2cap_tx()

at_ble_status_t at_ble_l2cap_tx | ( | at_ble_handle_t | conn_handle,
 |  | uint16_t | cid,
 |  | uint8_t * | data,
 |  | uint16_t | len
 | ) |  |

Sends a custom L2CAP message using the given CID.

Parameters
[in] | conn_handle | Handle of the connection
[in] | cid | L2CAP CID to use when sending the data
[in] | data | Data to send
[in] | len | Length of data, in bytes
Warning
Not Supported
Returns
AT_BLE_SUCCESS Operation completed successfully
AT_BLE_FAILURE Generic error


Atmel BLE API: HTPT API

Functions
HTPT API

Functions

at_ble_status_t | at_ble_htpt_create_db (at_ble_htpt_db_config_flag features, at_ble_htpt_temp_type temp_type, uint16_t valid_range_min, uint16_t valid_range_max, uint16_t meas_intv, at_ble_htpt_sec_level sec_lvl)
at_ble_status_t | at_ble_htpt_enable (at_ble_handle_t conn_handle, at_ble_htpt_ntf_ind_cfg ntf_ind_cfg)
at_ble_status_t | at_ble_htpt_temp_send (uint32_t temp, at_ble_prf_date_time_t *time_stamp, at_ble_htpt_temp_flags flags, at_ble_htpt_temp_type type, bool flag_stable_meas)
at_ble_status_t | at_ble_htpt_meas_intv_update (uint16_t meas_intv)

Detailed Description

Function Documentation

◆ at_ble_htpt_create_db()

at_ble_status_t at_ble_htpt_create_db | ( | at_ble_htpt_db_config_flag | features,
 |  | at_ble_htpt_temp_type | temp_type,
 |  | uint16_t | valid_range_min,
 |  | uint16_t | valid_range_max,
 |  | uint16_t | meas_intv,
 |  | at_ble_htpt_sec_level | sec_lvl
 | ) |  |

This API message shall be used to add an instance of the Health Thermometer service into the database. This should be done during the initialization phase of the device , after the function is called you should wait for AT_BLE_HTPT_CREATE_DB_CFM event.

Parameters
[in] | features | Indicate if optional features are supported or not, see at_ble_htpt_db_config_flag
[in] | temp_type | type of temperature as defined in org.bluetooth.characteristic.temperature_type
[in] | valid_range_min | Minimal measurement interval value
[in] | valid_range_max | Maximal measurement interval value
[in] | meas_intv | Latest known value for measurement interval ()
[in] | sec_lvl | can be : Disable(0) , Enable(1), Unauth(2), Auth(3) see at_ble_htpt_sec_level
Returns
AT_BLE_SUCCESS operation completed successfully
AT_BLE_FAILURE Generic error.

◆ at_ble_htpt_enable()

at_ble_status_t at_ble_htpt_enable | ( | at_ble_handle_t | conn_handle,
 |  | at_ble_htpt_ntf_ind_cfg | ntf_ind_cfg
 | ) |  |

This API message is used for enabling the Thermometer role of the Health Thermometer profile. This should be called after the database creation.

Parameters
[in] | conn_handle | handle of the connection
[in] | ntf_ind_cfg | Enable notifications or indications for profile characteristics see at_ble_htpt_ntf_ind_cfg
Returns
AT_BLE_SUCCESS operation completed successfully
AT_BLE_FAILURE Generic error.

◆ at_ble_htpt_temp_send()

at_ble_status_t at_ble_htpt_temp_send | ( | uint32_t | temp,
 |  | at_ble_prf_date_time_t * | time_stamp,
 |  | at_ble_htpt_temp_flags | flags,
 |  | at_ble_htpt_temp_type | type,
 |  | bool | flag_stable_meas
 | ) |  |

This message is used by the application (which handles the temperature device driver and measurements) to send a temperature measurement through the Thermometer role.

Parameters
[in] | temp | temperature value
[in] | time_stamp | The time of reading according to the format defined in at_ble_prf_date_time_t
[in] | flags | temp flag see at_ble_htpt_temp_flags
[in] | type | temp type see at_ble_htpt_temp_type
[in] | flag_stable_meas | Stable or intermediary type of temperature (True stable meas, else false)
Returns
AT_BLE_SUCCESS operation completed successfully
AT_BLE_FAILURE Generic error.

◆ at_ble_htpt_meas_intv_update()

at_ble_status_t at_ble_htpt_meas_intv_update ( uint16_t meas_intv )

This message is used by the application to order the HTPT profile to generate an indication (if enabled) of the Measurement Interval Char. This can be done as the application desires, at each connection, or if the measurement interval value has been modified locally (interface for this is not provided since a normal thermometer would have very few configurable UI elements and configuration should be done through Collector)

Parameters
[in] meas_intv Measurement Interval value
Returns
AT_BLE_SUCCESS operation completed successfully
AT_BLE_FAILURE Generic error.


Atmel BLE API: Platform API

Functions
Platform API

Functions

at_ble_status_t | platform_init (void *platform_params)
void | platform_interface_send (uint8_t *data, uint32_t len)
void | platform_receive (uint8_t *data, uint32_t len)
void | platform_interface_callback (uint8_t *data, uint32_t len)
void | platform_cmd_cmpl_signal (void)
void | platform_cmd_cmpl_wait (bool *timeout)
void | platform_event_signal (void)
uint8_t | platform_event_wait (uint32_t timeout)
void | fw_led (bool tempo)

Detailed Description

Function Documentation

◆ platform_init()

at_ble_status_t platform_init ( void * platform_params )

implements platform-specific initialization

Parameters
[in] platform_params platform specific params, this pointer is passed from the at_ble_init function and interpreted by the platform
Returns
AT_BLE_SUCCESS operation completed successfully
AT_BLE_FAILURE Generic error.

◆ platform_interface_send()

void platform_interface_send | ( | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

sends a message over the platform-specific bus

Sends a message over the platform-specific bus that might be UART, SPI or other if the BTLC1000 external wakeup signal is used, it is up to this function implementation to assert/deassert it appropriately

Parameters
[in] | data | data to send over the interface
[in] | len | length of data

◆ platform_receive()

void platform_receive | ( | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

◆ platform_interface_callback()

void platform_interface_callback | ( | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

the callback to upper layers to process received packets

This function is implemented by the upper layers (the event loop) and it is up to the platform implementation to call it whenever data are received from the interface

Parameters
[in] | data | data received from the interface
[in] | len | length of data

◆ platform_cmd_cmpl_signal()

void platform_cmd_cmpl_signal ( void )

fires the command-complete signal

Note
more details at the platform porting guide

◆ platform_cmd_cmpl_wait()

void platform_cmd_cmpl_wait ( bool * timeout )

blocks until the command-complete signal is fired

Note
more details at the platform porting guide
Parameters
[out] timeout a flag that indicates if waiting timed out

◆ platform_event_signal()

void platform_event_signal ( void )

fires the event signal

Note
more details at the platform porting guide

◆ platform_event_wait()

uint8_t platform_event_wait ( uint32_t timeout )

blocks until the event signal is fired

Note
more details at the platform porting guide
Parameters
[in] timeout timeout in ms passed by user

◆ fw_led()

void fw_led ( bool tempo )


Atmel BLE API: Data Structures

Data Structures
Here are the data structures with brief descriptions:
C _plf_params |
C _scanitem |
C at_ble_addr_t | Blue-tooth Low Energy address Type
C at_ble_char_presentation_t | Characteristic presentation format
C at_ble_characteristic_changed_t |
C at_ble_characteristic_found_t |
C at_ble_characteristic_read_response_t |
C at_ble_characteristic_t | Characteristic structure
C at_ble_characteristic_write_response_t |
C at_ble_conn_param_update_done_t |
C at_ble_conn_param_update_request_t |
C at_ble_connected_t | AT_BLE_CONNECTED message format. This message is sent to the APP when the link request is complete
C at_ble_connection_params_t | Connection parameters
C at_ble_CSRK_t | Connection Signature Resolution Key
C at_ble_descriptor_found_t |
C at_ble_disconnected_t |
C at_ble_discovery_complete_t |
C at_ble_encryption_request_t |
C at_ble_encryption_status_changed_t |
C at_ble_event_parameter_t |
C at_ble_gap_deviceinfo_t |
C at_ble_gap_irk_t | Identity Resolving Key
C at_ble_gap_whitelist_t | White-list structure
C at_ble_htpt_cfg_indntf_ind_t | Parameters of the AT_BLE_HTPT_CFG_INDNTF_IND message
C at_ble_htpt_create_db_cfm_t | Parameters of the AT_BLE_HTPT_CREATE_DB_CFM message
C at_ble_htpt_disable_ind_t | Parameters of the AT_BLE_HTPT_DISABLE_IND message
C at_ble_htpt_meas_intv_chg_ind_t | Parameters of the AT_BLE_HTPT_MEAS_INTV_CHG_IND message
C at_ble_htpt_temp_send_cfm_t | Parameters of the AT_BLE_HTPT_TEMP_SEND_CFM message
C at_ble_included_service_found_t |
C at_ble_included_service_t | Service Definition
C at_ble_indication_confirmed_t |
C at_ble_indication_recieved_t |
C at_ble_IRK_t |
C at_ble_l2cap_rx_t |
C at_ble_LTK_t | Long Term Key
C at_ble_max_PA_gain_value_t |
C at_ble_notification_recieved_t |
C at_ble_pair_done_t | Pairing done message
C at_ble_pair_features_t | Pairing Features
C at_ble_pair_key_request_t |
C at_ble_pair_request_t |
C at_ble_prf_date_time_t | Time profile information
C at_ble_prf_server_error_ind_t | Message structure used to inform APP that an error has occurred in the profile server role task
C at_ble_primary_service_found_t |
C at_ble_rand_addr_changed_t |
C at_ble_read_authorize_request_t |
C at_ble_resolv_rand_addr_status_t |
C at_ble_rx_power_value_t |
C at_ble_scan_info_t |
C at_ble_scan_report_t |
C at_ble_service_changed_notification_confirmed_t |
C at_ble_signature_info_t |
C at_ble_slave_sec_request_t |
C at_ble_spcp_t | Slave preferred connection parameters
C at_ble_tx_power_set_t |
C at_ble_tx_power_value_t |
C at_ble_uuid_t | UUID type
C at_ble_wifiprov_complete_ind |
C at_ble_wifiprov_scan_mode_change_ind_t |
C at_ble_write_authorize_request_t |
C wifiprov_scanlist_ind |
C wr_apis |


Atmel BLE API: _plf_params Struct Reference

Data Fields
_plf_params Struct Reference

Data Fields

ble_api_callback_t | ble_write_cb
plf_wait_callback_t | plf_wait_cb

Field Documentation

◆ ble_write_cb

ble_api_callback_t ble_write_cb

◆ plf_wait_cb

plf_wait_callback_t plf_wait_cb


Atmel BLE API: _scanitem Struct Reference

Data Fields
_scanitem Struct Reference

Data Fields

uint8_t | sec_type
uint8_t | rssi
uint8_t | ssid [MAX_WIPROVTASK_SSID_LENGTH]

Field Documentation

◆ sec_type

uint8_t sec_type

◆ rssi

uint8_t rssi

◆ ssid

uint8_t ssid[MAX_WIPROVTASK_SSID_LENGTH]


Atmel BLE API: at_ble_addr_t Struct Reference

Data Fields
at_ble_addr_t Struct Reference

Data Fields

at_ble_addr_type_t type
uint8_t addr [AT_BLE_ADDR_LEN]

Detailed Description

Blue-tooth Low Energy address Type.

Field Documentation

◆ type

at_ble_addr_type_t type

◆ addr

uint8_t addr[AT_BLE_ADDR_LEN]

48-bit address, LSB format.


Atmel BLE API: at_ble_char_presentation_t Struct Reference

Data Fields
at_ble_char_presentation_t Struct Reference

Data Fields

at_ble_char_pres_format_t format
int8_t | exponent
uint16_t | unit
uint8_t | name_space
uint16_t | description

Detailed Description

Characteristic presentation format.

Field Documentation

◆ format

at_ble_char_pres_format_t format

Value format

◆ exponent

int8_t exponent

Value Exponent

◆ unit

uint16_t unit

as defined in GATT spec Part G, Section 3.3.3.5.4

◆ name_space

uint8_t name_space

as defined in GATT spec Part G, Section 3.3.3.5.5

◆ description

uint16_t description

as defined in GATT spec Part G, Section 3.3.3.5.6


Atmel BLE API: at_ble_characteristic_changed_t Struct Reference

Data Fields
at_ble_characteristic_changed_t Struct Reference

Data Fields

at_ble_handle_t conn_handle
at_ble_handle_t char_handle
uint8_t | char_new_value [AT_BLE_MAX_ATT_LEN]
uint16_t | char_len
uint16_t | char_offset
at_ble_status_t status

Field Documentation

◆ conn_handle

at_ble_handle_t conn_handle

◆ char_handle

at_ble_handle_t char_handle

◆ char_new_value

uint8_t char_new_value[AT_BLE_MAX_ATT_LEN]

◆ char_len

uint16_t char_len

◆ char_offset

uint16_t char_offset

◆ status

at_ble_status_t status


Atmel BLE API: at_ble_characteristic_found_t Struct Reference

Data Fields
at_ble_characteristic_found_t Struct Reference

Data Fields

at_ble_handle_t conn_handle
at_ble_handle_t char_handle
at_ble_handle_t value_handle
uint8_t properties
at_ble_uuid_t char_uuid

Field Documentation

◆ conn_handle

at_ble_handle_t conn_handle

◆ char_handle

at_ble_handle_t char_handle

◆ value_handle

at_ble_handle_t value_handle

◆ properties

uint8_t properties

◆ char_uuid

at_ble_uuid_t char_uuid


Atmel BLE API: at_ble_characteristic_read_response_t Struct Reference

Data Fields
at_ble_characteristic_read_response_t Struct Reference

Data Fields

at_ble_handle_t conn_handle
at_ble_handle_t char_handle
uint16_t | char_len
uint16_t | char_offset
uint8_t | char_value [AT_BLE_MAX_ATT_LEN]

Field Documentation

◆ conn_handle

at_ble_handle_t conn_handle

◆ char_handle

at_ble_handle_t char_handle

◆ char_len

uint16_t char_len

◆ char_offset

uint16_t char_offset

◆ char_value

uint8_t char_value[AT_BLE_MAX_ATT_LEN]


Atmel BLE API: at_ble_characteristic_t Struct Reference

Data Fields
at_ble_characteristic_t Struct Reference

Data Fields

at_ble_handle_t char_val_handle
at_ble_uuid_t uuid
at_ble_char_properties_t properties
uint8_t * | init_value
uint16_t | value_init_len
uint16_t | value_max_len
at_ble_attr_permissions_t value_permissions
uint8_t * | user_desc
uint16_t | user_desc_len
uint16_t | user_desc_max_len
at_ble_attr_permissions_t user_desc_permissions
at_ble_attr_permissions_t client_config_permissions
at_ble_attr_permissions_t server_config_permissions
at_ble_handle_t user_desc_handle
at_ble_handle_t client_config_handle
at_ble_handle_t server_config_handle
at_ble_char_presentation_t * presentation_format

Detailed Description

Characteristic structure.

Field Documentation

◆ char_val_handle

at_ble_handle_t char_val_handle

Here the stack will store the char. value handle for future use

◆ uuid

at_ble_uuid_t uuid

Characteristic UUID

◆ properties

at_ble_char_properties_t properties

Characteristic properties, values for Client Characteristic Configuration Descriptor and Server Characteristic Configuration Descriptor will be decided from this value

◆ init_value

uint8_t* init_value

initial value of this characteristic

◆ value_init_len

uint16_t value_init_len

initial value length

◆ value_max_len

uint16_t value_max_len

maximum possible length of the char. value

◆ value_permissions

at_ble_attr_permissions_t value_permissions

Value permissions

◆ user_desc

uint8_t* user_desc

a user friendly description, this value will be stored in the relevant descriptor, if no user description is desired set to NULL

◆ user_desc_len

uint16_t user_desc_len

the user friendly description length, this value will be stored in the relevant descriptor, if no user description is desired set to 0

◆ user_desc_max_len

uint16_t user_desc_max_len

Maximum possible length for the user friendly description, this value will be stored in the relevant descriptor, if no user description is desired set to 0

◆ user_desc_permissions

at_ble_attr_permissions_t user_desc_permissions

◆ client_config_permissions

at_ble_attr_permissions_t client_config_permissions

◆ server_config_permissions

at_ble_attr_permissions_t server_config_permissions

◆ user_desc_handle

at_ble_handle_t user_desc_handle

◆ client_config_handle

at_ble_handle_t client_config_handle

◆ server_config_handle

at_ble_handle_t server_config_handle

◆ presentation_format

at_ble_char_presentation_t* presentation_format

Characteristic presentation format, this value will be stored in the relevant descriptor, if no presentation format is necessary set to NULL


Atmel BLE API: at_ble_characteristic_write_response_t Struct Reference

Data Fields
at_ble_characteristic_write_response_t Struct Reference

Data Fields

at_ble_handle_t conn_handle
at_ble_handle_t char_handle
at_ble_status_t status

Field Documentation

◆ conn_handle

at_ble_handle_t conn_handle

◆ char_handle

at_ble_handle_t char_handle

◆ status

at_ble_status_t status


Atmel BLE API: at_ble_conn_param_update_done_t Struct Reference

Data Fields
at_ble_conn_param_update_done_t Struct Reference

Data Fields

at_ble_handle_t handle
at_ble_status_t status
uint16_t | con_intv
uint16_t | con_latency
uint16_t | superv_to

Field Documentation

◆ handle

at_ble_handle_t handle

◆ status

at_ble_status_t status

◆ con_intv

uint16_t con_intv

◆ con_latency

uint16_t con_latency

◆ superv_to

uint16_t superv_to


Atmel BLE API: at_ble_conn_param_update_request_t Struct Reference

Data Fields
at_ble_conn_param_update_request_t Struct Reference

Data Fields

at_ble_handle_t handle
at_ble_connection_params_t params

Field Documentation

◆ handle

at_ble_handle_t handle

◆ params

at_ble_connection_params_t params


Atmel BLE API: at_ble_connected_t Struct Reference

Data Fields
at_ble_connected_t Struct Reference

Data Fields

at_ble_addr_t peer_addr
at_ble_handle_t handle
at_ble_status_t conn_status

Detailed Description

AT_BLE_CONNECTED message format. This message is sent to the APP when the link request is complete.

Field Documentation

◆ peer_addr

at_ble_addr_t peer_addr

◆ handle

at_ble_handle_t handle

◆ conn_status

at_ble_status_t conn_status


Atmel BLE API: at_ble_connection_params_t Struct Reference

Data Fields
at_ble_connection_params_t Struct Reference

Data Fields

uint16_t | con_intv_min
uint16_t | con_intv_max
uint16_t | con_latency
uint16_t | superv_to
uint16_t | ce_len_min
uint16_t | ce_len_max

Detailed Description

Connection parameters.

Field Documentation

◆ con_intv_min

uint16_t con_intv_min

Minimum of connection interval.

◆ con_intv_max

uint16_t con_intv_max

Maximum of connection interval.

◆ con_latency

uint16_t con_latency

Connection latency.

◆ superv_to

uint16_t superv_to

Link supervision time-out.

◆ ce_len_min

uint16_t ce_len_min

Minimum CE length.

◆ ce_len_max

uint16_t ce_len_max

Maximum CE length.


Atmel BLE API: at_ble_CSRK_t Struct Reference

Data Fields
at_ble_CSRK_t Struct Reference

Data Fields

uint8_t key [AT_BLE_MAX_KEY_LEN]

Detailed Description

Connection Signature Resolution Key.

Field Documentation

◆ key

uint8_t key[AT_BLE_MAX_KEY_LEN]


Atmel BLE API: at_ble_descriptor_found_t Struct Reference

Data Fields
at_ble_descriptor_found_t Struct Reference

Data Fields

at_ble_handle_t conn_handle
at_ble_handle_t desc_handle
at_ble_uuid_t desc_uuid

Field Documentation

◆ conn_handle

at_ble_handle_t conn_handle

◆ desc_handle

at_ble_handle_t desc_handle

◆ desc_uuid

at_ble_uuid_t desc_uuid


Atmel BLE API: at_ble_disconnected_t Struct Reference

Data Fields
at_ble_disconnected_t Struct Reference

Data Fields

at_ble_handle_t handle
uint8_t reason

Field Documentation

◆ handle

at_ble_handle_t handle

◆ reason

uint8_t reason


Atmel BLE API: at_ble_discovery_complete_t Struct Reference

Data Fields
at_ble_discovery_complete_t Struct Reference

Data Fields

at_ble_gattc_discovery_complete_status_t status

Field Documentation

◆ status

at_ble_gattc_discovery_complete_status_t status


Atmel BLE API: at_ble_encryption_request_t Struct Reference

Data Fields
at_ble_encryption_request_t Struct Reference

Data Fields

at_ble_handle_t handle
uint16_t | ediv
uint8_t | nb [8]

Field Documentation

◆ handle

at_ble_handle_t handle

◆ ediv

uint16_t ediv

Encryption Diversifier.

◆ nb

uint8_t nb[8]

Random Number (64 bit)


Atmel BLE API: at_ble_encryption_status_changed_t Struct Reference

Data Fields
at_ble_encryption_status_changed_t Struct Reference

Data Fields

at_ble_handle_t handle
at_ble_status_t status

Field Documentation

◆ handle

at_ble_handle_t handle

◆ status

at_ble_status_t status


Atmel BLE API: at_ble_event_parameter_t Union Reference

Data Fields
at_ble_event_parameter_t Union Reference

Data Fields

at_ble_addr_t at_ble_addr_t
at_ble_gap_irk_t at_ble_gap_irk_t
at_ble_spcp_t at_ble_spcp_t
at_ble_gap_deviceinfo_t at_ble_gap_deviceinfo_t
at_ble_gap_whitelist_t at_ble_gap_whitelist_t
at_ble_connection_params_t at_ble_connection_params_t
at_ble_uuid_t at_ble_uuid_t
at_ble_char_presentation_t at_ble_char_presentation_t
at_ble_characteristic_t at_ble_characteristic_t
at_ble_included_service_t at_ble_included_service_t
at_ble_pair_features_t at_ble_pair_features_t
at_ble_LTK_t at_ble_LTK_t
at_ble_CSRK_t at_ble_CSRK_t
at_ble_IRK_t at_ble_IRK_t
at_ble_signature_info_t at_ble_signature_info_t
at_ble_scan_info_t at_ble_scan_info_t
at_ble_scan_report_t at_ble_scan_report_t
at_ble_connected_t at_ble_connected_t
at_ble_rand_addr_changed_t at_ble_rand_addr_changed_t
at_ble_disconnected_t at_ble_disconnected_t
at_ble_conn_param_update_done_t at_ble_conn_param_update_done_t
at_ble_conn_param_update_request_t at_ble_conn_param_update_request_t
at_ble_rx_power_value_t at_ble_rx_power_value_t
at_ble_max_PA_gain_value_t at_ble_max_PA_gain_value_t
at_ble_tx_power_value_t at_ble_tx_power_value_t
at_ble_tx_power_set_t at_ble_tx_power_set_t
at_ble_pair_done_t at_ble_pair_done_t
at_ble_pair_request_t at_ble_pair_request_t
at_ble_pair_key_request_t at_ble_pair_key_request_t
at_ble_slave_sec_request_t at_ble_slave_sec_request_t
at_ble_encryption_request_t at_ble_encryption_request_t
at_ble_encryption_status_changed_t at_ble_encryption_status_changed_t
at_ble_resolv_rand_addr_status_t at_ble_resolv_rand_addr_status_t
at_ble_discovery_complete_t at_ble_discovery_complete_t
at_ble_primary_service_found_t at_ble_primary_service_found_t
at_ble_included_service_found_t at_ble_included_service_found_t
at_ble_characteristic_found_t at_ble_characteristic_found_t
at_ble_descriptor_found_t at_ble_descriptor_found_t
at_ble_characteristic_read_response_t at_ble_characteristic_read_response_t
at_ble_characteristic_write_response_t at_ble_characteristic_write_response_t
at_ble_notification_recieved_t at_ble_notification_recieved_t
at_ble_indication_recieved_t at_ble_indication_recieved_t
at_ble_indication_confirmed_t at_ble_indication_confirmed_t
at_ble_characteristic_changed_t at_ble_characteristic_changed_t
at_ble_service_changed_notification_confirmed_t at_ble_service_changed_notification_confirmed_t
at_ble_write_authorize_request_t at_ble_write_authorize_request_t
at_ble_read_authorize_request_t at_ble_read_authorize_request_t
at_ble_l2cap_rx_t at_ble_l2cap_rx_t
at_ble_prf_server_error_ind_t at_ble_prf_server_error_ind_t
at_ble_prf_date_time_t at_ble_prf_date_time_t
at_ble_htpt_create_db_cfm_t at_ble_htpt_create_db_cfm_t
at_ble_htpt_disable_ind_t at_ble_htpt_disable_ind_t
at_ble_htpt_temp_send_cfm_t at_ble_htpt_temp_send_cfm_t
at_ble_htpt_meas_intv_chg_ind_t at_ble_htpt_meas_intv_chg_ind_t
at_ble_htpt_cfg_indntf_ind_t at_ble_htpt_cfg_indntf_ind_t

Field Documentation

◆ at_ble_addr_t

at_ble_addr_t at_ble_addr_t

◆ at_ble_gap_irk_t

at_ble_gap_irk_t at_ble_gap_irk_t

◆ at_ble_spcp_t

at_ble_spcp_t at_ble_spcp_t

◆ at_ble_gap_deviceinfo_t

at_ble_gap_deviceinfo_t at_ble_gap_deviceinfo_t

◆ at_ble_gap_whitelist_t

at_ble_gap_whitelist_t at_ble_gap_whitelist_t

◆ at_ble_connection_params_t

at_ble_connection_params_t at_ble_connection_params_t

◆ at_ble_uuid_t

at_ble_uuid_t at_ble_uuid_t

◆ at_ble_char_presentation_t

at_ble_char_presentation_t at_ble_char_presentation_t

◆ at_ble_characteristic_t

at_ble_characteristic_t at_ble_characteristic_t

◆ at_ble_included_service_t

at_ble_included_service_t at_ble_included_service_t

◆ at_ble_pair_features_t

at_ble_pair_features_t at_ble_pair_features_t

◆ at_ble_LTK_t

at_ble_LTK_t at_ble_LTK_t

◆ at_ble_CSRK_t

at_ble_CSRK_t at_ble_CSRK_t

◆ at_ble_IRK_t

at_ble_IRK_t at_ble_IRK_t

◆ at_ble_signature_info_t

at_ble_signature_info_t at_ble_signature_info_t

◆ at_ble_scan_info_t

at_ble_scan_info_t at_ble_scan_info_t

◆ at_ble_scan_report_t

at_ble_scan_report_t at_ble_scan_report_t

◆ at_ble_connected_t

at_ble_connected_t at_ble_connected_t

◆ at_ble_rand_addr_changed_t

at_ble_rand_addr_changed_t at_ble_rand_addr_changed_t

◆ at_ble_disconnected_t

at_ble_disconnected_t at_ble_disconnected_t

◆ at_ble_conn_param_update_done_t

at_ble_conn_param_update_done_t at_ble_conn_param_update_done_t

◆ at_ble_conn_param_update_request_t

at_ble_conn_param_update_request_t at_ble_conn_param_update_request_t

◆ at_ble_rx_power_value_t

at_ble_rx_power_value_t at_ble_rx_power_value_t

◆ at_ble_max_PA_gain_value_t

at_ble_max_PA_gain_value_t at_ble_max_PA_gain_value_t

◆ at_ble_tx_power_value_t

at_ble_tx_power_value_t at_ble_tx_power_value_t

◆ at_ble_tx_power_set_t

at_ble_tx_power_set_t at_ble_tx_power_set_t

◆ at_ble_pair_done_t

at_ble_pair_done_t at_ble_pair_done_t

◆ at_ble_pair_request_t

at_ble_pair_request_t at_ble_pair_request_t

◆ at_ble_pair_key_request_t

at_ble_pair_key_request_t at_ble_pair_key_request_t

◆ at_ble_slave_sec_request_t

at_ble_slave_sec_request_t at_ble_slave_sec_request_t

◆ at_ble_encryption_request_t

at_ble_encryption_request_t at_ble_encryption_request_t

◆ at_ble_encryption_status_changed_t

at_ble_encryption_status_changed_t at_ble_encryption_status_changed_t

◆ at_ble_resolv_rand_addr_status_t

at_ble_resolv_rand_addr_status_t at_ble_resolv_rand_addr_status_t

◆ at_ble_discovery_complete_t

at_ble_discovery_complete_t at_ble_discovery_complete_t

◆ at_ble_primary_service_found_t

at_ble_primary_service_found_t at_ble_primary_service_found_t

◆ at_ble_included_service_found_t

at_ble_included_service_found_t at_ble_included_service_found_t

◆ at_ble_characteristic_found_t

at_ble_characteristic_found_t at_ble_characteristic_found_t

◆ at_ble_descriptor_found_t

at_ble_descriptor_found_t at_ble_descriptor_found_t

◆ at_ble_characteristic_read_response_t

at_ble_characteristic_read_response_t at_ble_characteristic_read_response_t

◆ at_ble_characteristic_write_response_t

at_ble_characteristic_write_response_t at_ble_characteristic_write_response_t

◆ at_ble_notification_recieved_t

at_ble_notification_recieved_t at_ble_notification_recieved_t

◆ at_ble_indication_recieved_t

at_ble_indication_recieved_t at_ble_indication_recieved_t

◆ at_ble_indication_confirmed_t

at_ble_indication_confirmed_t at_ble_indication_confirmed_t

◆ at_ble_characteristic_changed_t

at_ble_characteristic_changed_t at_ble_characteristic_changed_t

◆ at_ble_service_changed_notification_confirmed_t

at_ble_service_changed_notification_confirmed_t at_ble_service_changed_notification_confirmed_t

◆ at_ble_write_authorize_request_t

at_ble_write_authorize_request_t at_ble_write_authorize_request_t

◆ at_ble_read_authorize_request_t

at_ble_read_authorize_request_t at_ble_read_authorize_request_t

◆ at_ble_l2cap_rx_t

at_ble_l2cap_rx_t at_ble_l2cap_rx_t

◆ at_ble_prf_server_error_ind_t

at_ble_prf_server_error_ind_t at_ble_prf_server_error_ind_t

◆ at_ble_prf_date_time_t

at_ble_prf_date_time_t at_ble_prf_date_time_t

◆ at_ble_htpt_create_db_cfm_t

at_ble_htpt_create_db_cfm_t at_ble_htpt_create_db_cfm_t

◆ at_ble_htpt_disable_ind_t

at_ble_htpt_disable_ind_t at_ble_htpt_disable_ind_t

◆ at_ble_htpt_temp_send_cfm_t

at_ble_htpt_temp_send_cfm_t at_ble_htpt_temp_send_cfm_t

◆ at_ble_htpt_meas_intv_chg_ind_t

at_ble_htpt_meas_intv_chg_ind_t at_ble_htpt_meas_intv_chg_ind_t

◆ at_ble_htpt_cfg_indntf_ind_t

at_ble_htpt_cfg_indntf_ind_t at_ble_htpt_cfg_indntf_ind_t


Atmel BLE API: at_ble_gap_deviceinfo_t Struct Reference

Data Fields
at_ble_gap_deviceinfo_t Struct Reference

Data Fields

at_ble_spcp_t spcp_param
uint16_t appearance
at_ble_att_write_perm_t dev_name_perm

Field Documentation

◆ spcp_param

at_ble_spcp_t spcp_param

Slave preferred connection parameters.

◆ appearance

uint16_t appearance

Appearance configuration.

◆ dev_name_perm

at_ble_att_write_perm_t dev_name_perm

Device name write permission for peer device.


Atmel BLE API: at_ble_gap_irk_t Struct Reference

Data Fields
at_ble_gap_irk_t Struct Reference

Data Fields

uint8_t irk [AT_BLE_MAX_KEY_LEN]

Detailed Description

Identity Resolving Key.

Field Documentation

◆ irk

uint8_t irk[AT_BLE_MAX_KEY_LEN]

Array containing IRK with length AT_BLE_MAX_KEY_LEN


Atmel BLE API: at_ble_gap_whitelist_t Struct Reference

Data Fields
at_ble_gap_whitelist_t Struct Reference

Data Fields

at_ble_addr_t ** ppAddrs
uint8_t | addrCount
at_ble_gap_irk_t ** ppIrks
uint8_t | irkCount

Detailed Description

White-list structure.

Field Documentation

◆ ppAddrs

at_ble_addr_t** ppAddrs

Pointer to array of device address pointers, pointing to addresses to be used in white-list. NULL if none are given.

◆ addrCount

uint8_t addrCount

Count of device addresses in array, up to AT_BLE_GAP_WHITELIST_ADDR_MAX_COUNT.

◆ ppIrks

at_ble_gap_irk_t** ppIrks

Pointer to array of Identity Resolving Key (IRK) pointers, each pointing to an IRK in the white-list. NULL if none are given.

◆ irkCount

uint8_t irkCount

Count of IRKs in array, up to AT_BLE_GAP_WHITELIST_IRK_MAX_COUNT.


Atmel BLE API: at_ble_htpt_cfg_indntf_ind_t Struct Reference

Data Fields
at_ble_htpt_cfg_indntf_ind_t Struct Reference

Data Fields

uint16_t | conhdl
uint16_t | cfg_val
at_ble_htpt_attr_index char_code

Detailed Description

Parameters of the AT_BLE_HTPT_CFG_INDNTF_IND message.

Field Documentation

◆ conhdl

uint16_t conhdl

Connection handle.

◆ cfg_val

uint16_t cfg_val

Stop/notify/indicate value to configure into the peer characteristic.

◆ char_code

at_ble_htpt_attr_index char_code

Own code for differentiating between Temperature Measurement, Intermediate Temperature and Measurement Interval chars.


Atmel BLE API: at_ble_htpt_create_db_cfm_t Struct Reference

Data Fields
at_ble_htpt_create_db_cfm_t Struct Reference

Data Fields

uint8_t status

Detailed Description

Parameters of the AT_BLE_HTPT_CREATE_DB_CFM message.

Field Documentation

◆ status

uint8_t status

Status.


Atmel BLE API: at_ble_htpt_disable_ind_t Struct Reference

Data Fields
at_ble_htpt_disable_ind_t Struct Reference

Data Fields

uint16_t | conhdl
uint16_t | temp_meas_ind_en
uint16_t | interm_temp_ntf_en
uint16_t | meas_intv_ind_en
uint16_t | meas_intv

Detailed Description

Parameters of the AT_BLE_HTPT_DISABLE_IND message.

Field Documentation

◆ conhdl

uint16_t conhdl

Connection handle.

◆ temp_meas_ind_en

uint16_t temp_meas_ind_en

Temperature measurement indication configuration.

◆ interm_temp_ntf_en

uint16_t interm_temp_ntf_en

Intermediate temperature notification configuration.

◆ meas_intv_ind_en

uint16_t meas_intv_ind_en

Measurement interval indication configuration.

◆ meas_intv

uint16_t meas_intv

Measurement interval.


Atmel BLE API: at_ble_htpt_meas_intv_chg_ind_t Struct Reference

Data Fields
at_ble_htpt_meas_intv_chg_ind_t Struct Reference

Data Fields

uint16_t intv

Detailed Description

Parameters of the AT_BLE_HTPT_MEAS_INTV_CHG_IND message.

Field Documentation

◆ intv

uint16_t intv


Atmel BLE API: at_ble_htpt_temp_send_cfm_t Struct Reference

Data Fields
at_ble_htpt_temp_send_cfm_t Struct Reference

Data Fields

uint16_t | conhdl
uint8_t | status
uint8_t | cfm_type

Detailed Description

Parameters of the AT_BLE_HTPT_TEMP_SEND_CFM message.

Field Documentation

◆ conhdl

uint16_t conhdl

Connection handle.

◆ status

uint8_t status

Status.

◆ cfm_type

uint8_t cfm_type

Confirmation Type.


Atmel BLE API: at_ble_included_service_found_t Struct Reference

Data Fields
at_ble_included_service_found_t Struct Reference

Data Fields

at_ble_handle_t conn_handle
at_ble_handle_t attr_handle
at_ble_handle_t start_handle
at_ble_handle_t end_handle
at_ble_uuid_t service_uuid

Field Documentation

◆ conn_handle

at_ble_handle_t conn_handle

◆ attr_handle

at_ble_handle_t attr_handle

◆ start_handle

at_ble_handle_t start_handle

◆ end_handle

at_ble_handle_t end_handle

◆ service_uuid

at_ble_uuid_t service_uuid


Atmel BLE API: at_ble_included_service_t Struct Reference

Data Fields
at_ble_included_service_t Struct Reference

Data Fields

at_ble_uuid_t uuid
at_ble_handle_t service_handle
at_ble_handle_t end_group_handle

Detailed Description

Service Definition.

Field Documentation

◆ uuid

at_ble_uuid_t uuid

UUID of the included Service, only 16 bit UUID are allowed

◆ service_handle

at_ble_handle_t service_handle

The included service handle

◆ end_group_handle

at_ble_handle_t end_group_handle

End group handle


Atmel BLE API: at_ble_indication_confirmed_t Struct Reference

Data Fields
at_ble_indication_confirmed_t Struct Reference

Data Fields

at_ble_handle_t conn_handle
at_ble_handle_t char_handle
at_ble_status_t status

Field Documentation

◆ conn_handle

at_ble_handle_t conn_handle

◆ char_handle

at_ble_handle_t char_handle

◆ status

at_ble_status_t status


Atmel BLE API: at_ble_indication_recieved_t Struct Reference

Data Fields
at_ble_indication_recieved_t Struct Reference

Data Fields

at_ble_handle_t conn_handle
at_ble_handle_t char_handle
uint8_t | char_value [AT_BLE_MAX_ATT_LEN]
uint16_t | char_len

Field Documentation

◆ conn_handle

at_ble_handle_t conn_handle

◆ char_handle

at_ble_handle_t char_handle

◆ char_value

uint8_t char_value[AT_BLE_MAX_ATT_LEN]

◆ char_len

uint16_t char_len


Atmel BLE API: at_ble_IRK_t Struct Reference

Data Fields
at_ble_IRK_t Struct Reference

Data Fields

uint8_t key [AT_BLE_MAX_KEY_LEN]
at_ble_addr_t addr

Field Documentation

◆ key

uint8_t key[AT_BLE_MAX_KEY_LEN]

Identity Resolving Key.

◆ addr

at_ble_addr_t addr

Device BD Address.


Atmel BLE API: at_ble_l2cap_rx_t Struct Reference

Data Fields
at_ble_l2cap_rx_t Struct Reference

Data Fields

at_ble_handle_t conn_handle
uint16_t | cid
uint16_t | len
uint8_t * | data

Field Documentation

◆ conn_handle

at_ble_handle_t conn_handle

◆ cid

uint16_t cid

◆ len

uint16_t len

◆ data

uint8_t* data


Atmel BLE API: at_ble_LTK_t Struct Reference

Data Fields
at_ble_LTK_t Struct Reference

Data Fields

uint8_t | key [AT_BLE_MAX_KEY_LEN]
uint16_t | ediv
uint8_t | nb [8]
uint8_t | key_size

Detailed Description

Long Term Key.

Field Documentation

◆ key

uint8_t key[AT_BLE_MAX_KEY_LEN]

Long Term Key.

◆ ediv

uint16_t ediv

Encryption Diversifier.

◆ nb

uint8_t nb[8]

Random Number (64 bit)

◆ key_size

uint8_t key_size

Encryption key size (7 to 16)


Atmel BLE API: at_ble_max_PA_gain_value_t Struct Reference

Data Fields
at_ble_max_PA_gain_value_t Struct Reference

Data Fields

at_ble_handle_t handle
uint16_t max_PA_gain_value

Field Documentation

◆ handle

at_ble_handle_t handle

◆ max_PA_gain_value

uint16_t max_PA_gain_value


Atmel BLE API: at_ble_notification_recieved_t Struct Reference

Data Fields
at_ble_notification_recieved_t Struct Reference

Data Fields

at_ble_handle_t conn_handle
at_ble_handle_t char_handle
uint8_t | char_value [AT_BLE_MAX_ATT_LEN]
uint16_t | char_len

Field Documentation

◆ conn_handle

at_ble_handle_t conn_handle

◆ char_handle

at_ble_handle_t char_handle

◆ char_value

uint8_t char_value[AT_BLE_MAX_ATT_LEN]

◆ char_len

uint16_t char_len


Atmel BLE API: at_ble_pair_done_t Struct Reference

Data Fields
at_ble_pair_done_t Struct Reference

Data Fields

at_ble_auth_t auth
at_ble_handle_t handle
at_ble_status_t status
at_ble_LTK_t peer_ltk
at_ble_CSRK_t peer_csrk
at_ble_IRK_t peer_irk

Detailed Description

Pairing done message.

Field Documentation

◆ auth

at_ble_auth_t auth

◆ handle

at_ble_handle_t handle

◆ status

at_ble_status_t status

◆ peer_ltk

at_ble_LTK_t peer_ltk

◆ peer_csrk

at_ble_CSRK_t peer_csrk

◆ peer_irk

at_ble_IRK_t peer_irk


Atmel BLE API: at_ble_pair_features_t Struct Reference

Data Fields
at_ble_pair_features_t Struct Reference

Data Fields

at_ble_iocab_t io_cababilities
bool | mitm_protection
bool | bond
bool | oob_avaiable
uint8_t | min_key_size
uint8_t | max_key_size
at_ble_key_dis_t initiator_keys
at_ble_key_dis_t responder_keys
at_ble_auth_levels_t desired_auth

Detailed Description

Pairing Features.

Field Documentation

◆ io_cababilities

at_ble_iocab_t io_cababilities

IO capabilities of this device, value of at_ble_iocab_t

◆ mitm_protection

bool mitm_protection

If true then Man-In-The-Middle protection must be provided

◆ bond

bool bond

If True then bonding is requested

◆ oob_avaiable

bool oob_avaiable

If true then out-of-band data is available

◆ min_key_size

uint8_t min_key_size

Minimum key size accepted

◆ max_key_size

uint8_t max_key_size

Maximum key size accepted

◆ initiator_keys

at_ble_key_dis_t initiator_keys

Security keys offered to peer device, value of at_ble_key_dis_t

◆ responder_keys

at_ble_key_dis_t responder_keys

Security keys needed from peer device, value of at_ble_key_dis_t

◆ desired_auth

at_ble_auth_levels_t desired_auth

The desired authentication level to be reached, value of at_ble_auth_levels_t


Atmel BLE API: at_ble_pair_key_request_t Struct Reference

Data Fields
at_ble_pair_key_request_t Struct Reference

Data Fields

at_ble_handle_t handle
at_ble_pair_key_type_t type
at_ble_passkey_type_t passkey_type

Field Documentation

◆ handle

at_ble_handle_t handle

◆ type

at_ble_pair_key_type_t type

◆ passkey_type

at_ble_passkey_type_t passkey_type


Atmel BLE API: at_ble_pair_request_t Struct Reference

Data Fields
at_ble_pair_request_t Struct Reference

Data Fields

at_ble_handle_t handle
at_ble_pair_features_t peer_features

Field Documentation

◆ handle

at_ble_handle_t handle

◆ peer_features

at_ble_pair_features_t peer_features


Atmel BLE API: at_ble_prf_date_time_t Struct Reference

Data Fields
at_ble_prf_date_time_t Struct Reference

Data Fields

uint16_t | year
uint8_t | month
uint8_t | day
uint8_t | hour
uint8_t | min
uint8_t | sec

Detailed Description

Time profile information.

Field Documentation

◆ year

uint16_t year

year time element

◆ month

uint8_t month

month time element

◆ day

uint8_t day

day time element

◆ hour

uint8_t hour

hour time element

◆ min

uint8_t min

minute time element

◆ sec

uint8_t sec

second time element


Atmel BLE API: at_ble_prf_server_error_ind_t Struct Reference

Data Fields
at_ble_prf_server_error_ind_t Struct Reference

Data Fields

uint16_t | conhdl
uint16_t | msg_id
uint8_t | status

Detailed Description

Message structure used to inform APP that an error has occurred in the profile server role task.

Field Documentation

◆ conhdl

uint16_t conhdl

Connection Handle.

◆ msg_id

uint16_t msg_id

Message ID.

◆ status

uint8_t status

Status.


Atmel BLE API: at_ble_primary_service_found_t Struct Reference

Data Fields
at_ble_primary_service_found_t Struct Reference

Data Fields

at_ble_handle_t conn_handle
at_ble_handle_t start_handle
at_ble_handle_t end_handle
at_ble_uuid_t service_uuid

Field Documentation

◆ conn_handle

at_ble_handle_t conn_handle

◆ start_handle

at_ble_handle_t start_handle

◆ end_handle

at_ble_handle_t end_handle

◆ service_uuid

at_ble_uuid_t service_uuid


Atmel BLE API: at_ble_rand_addr_changed_t Struct Reference

Data Fields
at_ble_rand_addr_changed_t Struct Reference

Data Fields

uint8_t addr [AT_BLE_ADDR_LEN]

Field Documentation

◆ addr

uint8_t addr[AT_BLE_ADDR_LEN]

48-bit address, LSB format.


Atmel BLE API: at_ble_read_authorize_request_t Struct Reference

Data Fields
at_ble_read_authorize_request_t Struct Reference

Data Fields

at_ble_handle_t conn_handle
at_ble_handle_t char_handle
at_ble_status_t status

Field Documentation

◆ conn_handle

at_ble_handle_t conn_handle

◆ char_handle

at_ble_handle_t char_handle

◆ status

at_ble_status_t status


Atmel BLE API: at_ble_resolv_rand_addr_status_t Struct Reference

Data Fields
at_ble_resolv_rand_addr_status_t Struct Reference

Data Fields

at_ble_status_t status
uint8_t irk [AT_BLE_MAX_KEY_LEN]

Field Documentation

◆ status

at_ble_status_t status

◆ irk

uint8_t irk[AT_BLE_MAX_KEY_LEN]

IRK that correctly solved the random address.


Atmel BLE API: at_ble_rx_power_value_t Struct Reference

Data Fields
at_ble_rx_power_value_t Struct Reference

Data Fields

at_ble_handle_t handle
uint16_t rx_value

Field Documentation

◆ handle

at_ble_handle_t handle

◆ rx_value

uint16_t rx_value


Atmel BLE API: at_ble_scan_info_t Struct Reference

Data Fields
at_ble_scan_info_t Struct Reference

Data Fields

at_ble_adv_type_t type
at_ble_addr_t dev_addr
uint8_t | adv_data [AT_BLE_ADV_MAX_SIZE]
uint8_t | adv_data_len

Field Documentation

◆ type

at_ble_adv_type_t type

◆ dev_addr

at_ble_addr_t dev_addr

◆ adv_data

uint8_t adv_data[AT_BLE_ADV_MAX_SIZE]

◆ adv_data_len

uint8_t adv_data_len


Atmel BLE API: at_ble_scan_report_t Struct Reference

Data Fields
at_ble_scan_report_t Struct Reference

Data Fields

at_ble_status_t status

Field Documentation

◆ status

at_ble_status_t status


Atmel BLE API: at_ble_service_changed_notification_confirmed_t Struct Reference

Data Fields
at_ble_service_changed_notification_confirmed_t Struct Reference

Data Fields

at_ble_handle_t conn_handle

Field Documentation

◆ conn_handle

at_ble_handle_t conn_handle


Atmel BLE API: at_ble_signature_info_t Struct Reference

Data Fields
at_ble_signature_info_t Struct Reference

Data Fields

at_ble_CSRK_t peer_csrk
at_ble_CSRK_t local_csrk
uint32_t | lsign_counter
uint32_t | peer_sign_counter

Field Documentation

◆ peer_csrk

at_ble_CSRK_t peer_csrk

Remote CSRK value.

◆ local_csrk

at_ble_CSRK_t local_csrk

Local CSRK value.

◆ lsign_counter

uint32_t lsign_counter

Local signature counter value.

◆ peer_sign_counter

uint32_t peer_sign_counter

Remote signature counter value.


Atmel BLE API: at_ble_slave_sec_request_t Struct Reference

Data Fields
at_ble_slave_sec_request_t Struct Reference

Data Fields

at_ble_handle_t handle
bool | bond
bool | mitm_protection

Field Documentation

◆ handle

at_ble_handle_t handle

◆ bond

bool bond

◆ mitm_protection

bool mitm_protection


Atmel BLE API: at_ble_spcp_t Struct Reference

Data Fields
at_ble_spcp_t Struct Reference

Data Fields

uint16_t | con_intv_min
uint16_t | con_intv_max
uint16_t | con_latency
uint16_t | superv_to

Detailed Description

Slave preferred connection parameters.

Field Documentation

◆ con_intv_min

uint16_t con_intv_min

Slave preferred minimum connection interval.

◆ con_intv_max

uint16_t con_intv_max

Slave preferred maximum connection interval.

◆ con_latency

uint16_t con_latency

Slave preferred Connection latency.

◆ superv_to

uint16_t superv_to

Slave preferred Link supervision time-out.


Atmel BLE API: at_ble_tx_power_set_t Struct Reference

Data Fields
at_ble_tx_power_set_t Struct Reference

Data Fields

at_ble_handle_t handle
uint8_t tx_set_status

Field Documentation

◆ handle

at_ble_handle_t handle

◆ tx_set_status

uint8_t tx_set_status


Atmel BLE API: at_ble_tx_power_value_t Struct Reference

Data Fields
at_ble_tx_power_value_t Struct Reference

Data Fields

at_ble_handle_t handle
uint16_t tx_value

Field Documentation

◆ handle

at_ble_handle_t handle

◆ tx_value

uint16_t tx_value


Atmel BLE API: at_ble_uuid_t Struct Reference

Data Fields
at_ble_uuid_t Struct Reference

Data Fields

at_ble_uuid_type_t type
uint8_t uuid [AT_BLE_UUID_128_LEN]

Detailed Description

UUID type.

Field Documentation

◆ type

at_ble_uuid_type_t type

either a 16-Bit UUID or a 128-Bit UUID

◆ uuid

uint8_t uuid[AT_BLE_UUID_128_LEN]

If type is 16-Bit, only bytes [0] and [1] are used, otherwise all bytes are used in case of type 128-Bit.
LSB format.


Atmel BLE API: at_ble_wifiprov_complete_ind Struct Reference

Data Fields
at_ble_wifiprov_complete_ind Struct Reference

Data Fields

uint8_t | status
uint8_t | sec_type
uint8_t | ssid_length
uint8_t | ssid [MAX_WIPROVTASK_SSID_LENGTH]
uint8_t | passphrase_length
uint8_t | passphrase [MAX_WIPROVTASK_PASS_LENGTH]

Field Documentation

◆ status

uint8_t status

◆ sec_type

uint8_t sec_type

◆ ssid_length

uint8_t ssid_length

◆ ssid

uint8_t ssid[MAX_WIPROVTASK_SSID_LENGTH]

◆ passphrase_length

uint8_t passphrase_length

◆ passphrase

uint8_t passphrase[MAX_WIPROVTASK_PASS_LENGTH]


Atmel BLE API: at_ble_wifiprov_scan_mode_change_ind_t Struct Reference

Data Fields
at_ble_wifiprov_scan_mode_change_ind_t Struct Reference

Data Fields

uint8_t scanmode

Field Documentation

◆ scanmode

uint8_t scanmode

Scan Mode.


Atmel BLE API: at_ble_write_authorize_request_t Struct Reference

Data Fields
at_ble_write_authorize_request_t Struct Reference

Data Fields

at_ble_handle_t conn_handle
at_ble_handle_t char_handle
at_ble_status_t status

Field Documentation

◆ conn_handle

at_ble_handle_t conn_handle

◆ char_handle

at_ble_handle_t char_handle

◆ status

at_ble_status_t status


Atmel BLE API: wifiprov_scanlist_ind Struct Reference

Data Fields
wifiprov_scanlist_ind Struct Reference

Data Fields

uint8_t | num_valid
scanitem | scandetails [MAX_WIPROVTASK_AP_NUM]

Field Documentation

◆ num_valid

uint8_t num_valid

◆ scandetails

scanitem scandetails[MAX_WIPROVTASK_AP_NUM]


Atmel BLE API: wr_apis Struct Reference

Data Fields
wr_apis Struct Reference

Data Fields

uint8_t(* | wr_api32 )(uint32_t memAddr, uint32_t *data, uint8_t size)
uint8_t(* | wr_api32_reset )(uint32_t memAddr, uint32_t *data, uint8_t size)

Detailed Description

Confidential Information

Copyright (c) 2016, Atmel Corporation. All rights reserved. Licensed under Atmel's Limited License Agreement.

THIS SOFTWARE IS PROVIDED BY ATMEL "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT ARE EXPRESSLY AND SPECIFICALLY DISCLAIMED. IN NO EVENT SHALL ATMEL BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Atmel Corporation: http://www.atmel.com

Field Documentation

◆ wr_api32

uint8_t(* wr_api32) (uint32_t memAddr, uint32_t *data, uint8_t size)

◆ wr_api32_reset

uint8_t(* wr_api32_reset) (uint32_t memAddr, uint32_t *data, uint8_t size)


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- a -

  • addr : at_ble_addr_t , at_ble_IRK_t , at_ble_rand_addr_changed_t
  • addrCount : at_ble_gap_whitelist_t
  • adv_data : at_ble_scan_info_t
  • adv_data_len : at_ble_scan_info_t
  • appearance : at_ble_gap_deviceinfo_t
  • at_ble_addr_t : at_ble_event_parameter_t
  • at_ble_char_presentation_t : at_ble_event_parameter_t
  • at_ble_characteristic_changed_t : at_ble_event_parameter_t
  • at_ble_characteristic_found_t : at_ble_event_parameter_t
  • at_ble_characteristic_read_response_t : at_ble_event_parameter_t
  • at_ble_characteristic_t : at_ble_event_parameter_t
  • at_ble_characteristic_write_response_t : at_ble_event_parameter_t
  • at_ble_conn_param_update_done_t : at_ble_event_parameter_t
  • at_ble_conn_param_update_request_t : at_ble_event_parameter_t
  • at_ble_connected_t : at_ble_event_parameter_t
  • at_ble_connection_params_t : at_ble_event_parameter_t
  • at_ble_CSRK_t : at_ble_event_parameter_t
  • at_ble_descriptor_found_t : at_ble_event_parameter_t
  • at_ble_disconnected_t : at_ble_event_parameter_t
  • at_ble_discovery_complete_t : at_ble_event_parameter_t
  • at_ble_encryption_request_t : at_ble_event_parameter_t
  • at_ble_encryption_status_changed_t : at_ble_event_parameter_t
  • at_ble_gap_deviceinfo_t : at_ble_event_parameter_t
  • at_ble_gap_irk_t : at_ble_event_parameter_t
  • at_ble_gap_whitelist_t : at_ble_event_parameter_t
  • at_ble_htpt_cfg_indntf_ind_t : at_ble_event_parameter_t
  • at_ble_htpt_create_db_cfm_t : at_ble_event_parameter_t
  • at_ble_htpt_disable_ind_t : at_ble_event_parameter_t
  • at_ble_htpt_meas_intv_chg_ind_t : at_ble_event_parameter_t
  • at_ble_htpt_temp_send_cfm_t : at_ble_event_parameter_t
  • at_ble_included_service_found_t : at_ble_event_parameter_t
  • at_ble_included_service_t : at_ble_event_parameter_t
  • at_ble_indication_confirmed_t : at_ble_event_parameter_t
  • at_ble_indication_recieved_t : at_ble_event_parameter_t
  • at_ble_IRK_t : at_ble_event_parameter_t
  • at_ble_l2cap_rx_t : at_ble_event_parameter_t
  • at_ble_LTK_t : at_ble_event_parameter_t
  • at_ble_max_PA_gain_value_t : at_ble_event_parameter_t
  • at_ble_notification_recieved_t : at_ble_event_parameter_t
  • at_ble_pair_done_t : at_ble_event_parameter_t
  • at_ble_pair_features_t : at_ble_event_parameter_t
  • at_ble_pair_key_request_t : at_ble_event_parameter_t
  • at_ble_pair_request_t : at_ble_event_parameter_t
  • at_ble_prf_date_time_t : at_ble_event_parameter_t
  • at_ble_prf_server_error_ind_t : at_ble_event_parameter_t
  • at_ble_primary_service_found_t : at_ble_event_parameter_t
  • at_ble_rand_addr_changed_t : at_ble_event_parameter_t
  • at_ble_read_authorize_request_t : at_ble_event_parameter_t
  • at_ble_resolv_rand_addr_status_t : at_ble_event_parameter_t
  • at_ble_rx_power_value_t : at_ble_event_parameter_t
  • at_ble_scan_info_t : at_ble_event_parameter_t
  • at_ble_scan_report_t : at_ble_event_parameter_t
  • at_ble_service_changed_notification_confirmed_t : at_ble_event_parameter_t
  • at_ble_signature_info_t : at_ble_event_parameter_t
  • at_ble_slave_sec_request_t : at_ble_event_parameter_t
  • at_ble_spcp_t : at_ble_event_parameter_t
  • at_ble_tx_power_set_t : at_ble_event_parameter_t
  • at_ble_tx_power_value_t : at_ble_event_parameter_t
  • at_ble_uuid_t : at_ble_event_parameter_t
  • at_ble_write_authorize_request_t : at_ble_event_parameter_t
  • attr_handle : at_ble_included_service_found_t
  • auth : at_ble_pair_done_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- b -

  • ble_write_cb : _plf_params
  • bond : at_ble_pair_features_t , at_ble_slave_sec_request_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- c -

  • ce_len_max : at_ble_connection_params_t
  • ce_len_min : at_ble_connection_params_t
  • cfg_val : at_ble_htpt_cfg_indntf_ind_t
  • cfm_type : at_ble_htpt_temp_send_cfm_t
  • char_code : at_ble_htpt_cfg_indntf_ind_t
  • char_handle : at_ble_characteristic_changed_t , at_ble_characteristic_found_t , at_ble_characteristic_read_response_t , at_ble_characteristic_write_response_t , at_ble_indication_confirmed_t , at_ble_indication_recieved_t , at_ble_notification_recieved_t , at_ble_read_authorize_request_t , at_ble_write_authorize_request_t
  • char_len : at_ble_characteristic_changed_t , at_ble_characteristic_read_response_t , at_ble_indication_recieved_t , at_ble_notification_recieved_t
  • char_new_value : at_ble_characteristic_changed_t
  • char_offset : at_ble_characteristic_changed_t , at_ble_characteristic_read_response_t
  • char_uuid : at_ble_characteristic_found_t
  • char_val_handle : at_ble_characteristic_t
  • char_value : at_ble_characteristic_read_response_t , at_ble_indication_recieved_t , at_ble_notification_recieved_t
  • cid : at_ble_l2cap_rx_t
  • client_config_handle : at_ble_characteristic_t
  • client_config_permissions : at_ble_characteristic_t
  • con_intv : at_ble_conn_param_update_done_t
  • con_intv_max : at_ble_connection_params_t , at_ble_spcp_t
  • con_intv_min : at_ble_connection_params_t , at_ble_spcp_t
  • con_latency : at_ble_conn_param_update_done_t , at_ble_connection_params_t , at_ble_spcp_t
  • conhdl : at_ble_htpt_cfg_indntf_ind_t , at_ble_htpt_disable_ind_t , at_ble_htpt_temp_send_cfm_t , at_ble_prf_server_error_ind_t
  • conn_handle : at_ble_characteristic_changed_t , at_ble_characteristic_found_t , at_ble_characteristic_read_response_t , at_ble_characteristic_write_response_t , at_ble_descriptor_found_t , at_ble_included_service_found_t , at_ble_indication_confirmed_t , at_ble_indication_recieved_t , at_ble_l2cap_rx_t , at_ble_notification_recieved_t , at_ble_primary_service_found_t , at_ble_read_authorize_request_t , at_ble_service_changed_notification_confirmed_t , at_ble_write_authorize_request_t
  • conn_status : at_ble_connected_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- d -

  • data : at_ble_l2cap_rx_t
  • day : at_ble_prf_date_time_t
  • desc_handle : at_ble_descriptor_found_t
  • desc_uuid : at_ble_descriptor_found_t
  • description : at_ble_char_presentation_t
  • desired_auth : at_ble_pair_features_t
  • dev_addr : at_ble_scan_info_t
  • dev_name_perm : at_ble_gap_deviceinfo_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- e -

  • ediv : at_ble_encryption_request_t , at_ble_LTK_t
  • end_group_handle : at_ble_included_service_t
  • end_handle : at_ble_included_service_found_t , at_ble_primary_service_found_t
  • exponent : at_ble_char_presentation_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- f -

  • format : at_ble_char_presentation_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- h -

  • handle : at_ble_conn_param_update_done_t , at_ble_conn_param_update_request_t , at_ble_connected_t , at_ble_disconnected_t , at_ble_encryption_request_t , at_ble_encryption_status_changed_t , at_ble_max_PA_gain_value_t , at_ble_pair_done_t , at_ble_pair_key_request_t , at_ble_pair_request_t , at_ble_rx_power_value_t , at_ble_slave_sec_request_t , at_ble_tx_power_set_t , at_ble_tx_power_value_t
  • hour : at_ble_prf_date_time_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- i -

  • init_value : at_ble_characteristic_t
  • initiator_keys : at_ble_pair_features_t
  • interm_temp_ntf_en : at_ble_htpt_disable_ind_t
  • intv : at_ble_htpt_meas_intv_chg_ind_t
  • io_cababilities : at_ble_pair_features_t
  • irk : at_ble_gap_irk_t , at_ble_resolv_rand_addr_status_t
  • irkCount : at_ble_gap_whitelist_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- k -

  • key : at_ble_CSRK_t , at_ble_IRK_t , at_ble_LTK_t
  • key_size : at_ble_LTK_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- l -

  • len : at_ble_l2cap_rx_t
  • local_csrk : at_ble_signature_info_t
  • lsign_counter : at_ble_signature_info_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- m -

  • max_key_size : at_ble_pair_features_t
  • max_PA_gain_value : at_ble_max_PA_gain_value_t
  • meas_intv : at_ble_htpt_disable_ind_t
  • meas_intv_ind_en : at_ble_htpt_disable_ind_t
  • min : at_ble_prf_date_time_t
  • min_key_size : at_ble_pair_features_t
  • mitm_protection : at_ble_pair_features_t , at_ble_slave_sec_request_t
  • month : at_ble_prf_date_time_t
  • msg_id : at_ble_prf_server_error_ind_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- n -

  • name_space : at_ble_char_presentation_t
  • nb : at_ble_encryption_request_t , at_ble_LTK_t
  • num_valid : wifiprov_scanlist_ind


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- o -

  • oob_avaiable : at_ble_pair_features_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- p -

  • params : at_ble_conn_param_update_request_t
  • passkey_type : at_ble_pair_key_request_t
  • passphrase : at_ble_wifiprov_complete_ind
  • passphrase_length : at_ble_wifiprov_complete_ind
  • peer_addr : at_ble_connected_t
  • peer_csrk : at_ble_pair_done_t , at_ble_signature_info_t
  • peer_features : at_ble_pair_request_t
  • peer_irk : at_ble_pair_done_t
  • peer_ltk : at_ble_pair_done_t
  • peer_sign_counter : at_ble_signature_info_t
  • plf_wait_cb : _plf_params
  • ppAddrs : at_ble_gap_whitelist_t
  • ppIrks : at_ble_gap_whitelist_t
  • presentation_format : at_ble_characteristic_t
  • properties : at_ble_characteristic_found_t , at_ble_characteristic_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- r -

  • reason : at_ble_disconnected_t
  • responder_keys : at_ble_pair_features_t
  • rssi : _scanitem
  • rx_value : at_ble_rx_power_value_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- s -

  • scandetails : wifiprov_scanlist_ind
  • scanmode : at_ble_wifiprov_scan_mode_change_ind_t
  • sec : at_ble_prf_date_time_t
  • sec_type : _scanitem , at_ble_wifiprov_complete_ind
  • server_config_handle : at_ble_characteristic_t
  • server_config_permissions : at_ble_characteristic_t
  • service_handle : at_ble_included_service_t
  • service_uuid : at_ble_included_service_found_t , at_ble_primary_service_found_t
  • spcp_param : at_ble_gap_deviceinfo_t
  • ssid : _scanitem , at_ble_wifiprov_complete_ind
  • ssid_length : at_ble_wifiprov_complete_ind
  • start_handle : at_ble_included_service_found_t , at_ble_primary_service_found_t
  • status : at_ble_characteristic_changed_t , at_ble_characteristic_write_response_t , at_ble_conn_param_update_done_t , at_ble_discovery_complete_t , at_ble_encryption_status_changed_t , at_ble_htpt_create_db_cfm_t , at_ble_htpt_temp_send_cfm_t , at_ble_indication_confirmed_t , at_ble_pair_done_t , at_ble_prf_server_error_ind_t , at_ble_read_authorize_request_t , at_ble_resolv_rand_addr_status_t , at_ble_scan_report_t , at_ble_wifiprov_complete_ind , at_ble_write_authorize_request_t
  • superv_to : at_ble_conn_param_update_done_t , at_ble_connection_params_t , at_ble_spcp_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- t -

  • temp_meas_ind_en : at_ble_htpt_disable_ind_t
  • tx_set_status : at_ble_tx_power_set_t
  • tx_value : at_ble_tx_power_value_t
  • type : at_ble_addr_t , at_ble_pair_key_request_t , at_ble_scan_info_t , at_ble_uuid_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- u -

  • unit : at_ble_char_presentation_t
  • user_desc : at_ble_characteristic_t
  • user_desc_handle : at_ble_characteristic_t
  • user_desc_len : at_ble_characteristic_t
  • user_desc_max_len : at_ble_characteristic_t
  • user_desc_permissions : at_ble_characteristic_t
  • uuid : at_ble_characteristic_t , at_ble_included_service_t , at_ble_uuid_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- v -

  • value_handle : at_ble_characteristic_found_t
  • value_init_len : at_ble_characteristic_t
  • value_max_len : at_ble_characteristic_t
  • value_permissions : at_ble_characteristic_t


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- w -

  • wr_api32 : wr_apis
  • wr_api32_reset : wr_apis


Atmel BLE API: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- y -

  • year : at_ble_prf_date_time_t


Atmel BLE API: Data Fields - Variables

- a -

  • addr : at_ble_addr_t , at_ble_IRK_t , at_ble_rand_addr_changed_t
  • addrCount : at_ble_gap_whitelist_t
  • adv_data : at_ble_scan_info_t
  • adv_data_len : at_ble_scan_info_t
  • appearance : at_ble_gap_deviceinfo_t
  • at_ble_addr_t : at_ble_event_parameter_t
  • at_ble_char_presentation_t : at_ble_event_parameter_t
  • at_ble_characteristic_changed_t : at_ble_event_parameter_t
  • at_ble_characteristic_found_t : at_ble_event_parameter_t
  • at_ble_characteristic_read_response_t : at_ble_event_parameter_t
  • at_ble_characteristic_t : at_ble_event_parameter_t
  • at_ble_characteristic_write_response_t : at_ble_event_parameter_t
  • at_ble_conn_param_update_done_t : at_ble_event_parameter_t
  • at_ble_conn_param_update_request_t : at_ble_event_parameter_t
  • at_ble_connected_t : at_ble_event_parameter_t
  • at_ble_connection_params_t : at_ble_event_parameter_t
  • at_ble_CSRK_t : at_ble_event_parameter_t
  • at_ble_descriptor_found_t : at_ble_event_parameter_t
  • at_ble_disconnected_t : at_ble_event_parameter_t
  • at_ble_discovery_complete_t : at_ble_event_parameter_t
  • at_ble_encryption_request_t : at_ble_event_parameter_t
  • at_ble_encryption_status_changed_t : at_ble_event_parameter_t
  • at_ble_gap_deviceinfo_t : at_ble_event_parameter_t
  • at_ble_gap_irk_t : at_ble_event_parameter_t
  • at_ble_gap_whitelist_t : at_ble_event_parameter_t
  • at_ble_htpt_cfg_indntf_ind_t : at_ble_event_parameter_t
  • at_ble_htpt_create_db_cfm_t : at_ble_event_parameter_t
  • at_ble_htpt_disable_ind_t : at_ble_event_parameter_t
  • at_ble_htpt_meas_intv_chg_ind_t : at_ble_event_parameter_t
  • at_ble_htpt_temp_send_cfm_t : at_ble_event_parameter_t
  • at_ble_included_service_found_t : at_ble_event_parameter_t
  • at_ble_included_service_t : at_ble_event_parameter_t
  • at_ble_indication_confirmed_t : at_ble_event_parameter_t
  • at_ble_indication_recieved_t : at_ble_event_parameter_t
  • at_ble_IRK_t : at_ble_event_parameter_t
  • at_ble_l2cap_rx_t : at_ble_event_parameter_t
  • at_ble_LTK_t : at_ble_event_parameter_t
  • at_ble_max_PA_gain_value_t : at_ble_event_parameter_t
  • at_ble_notification_recieved_t : at_ble_event_parameter_t
  • at_ble_pair_done_t : at_ble_event_parameter_t
  • at_ble_pair_features_t : at_ble_event_parameter_t
  • at_ble_pair_key_request_t : at_ble_event_parameter_t
  • at_ble_pair_request_t : at_ble_event_parameter_t
  • at_ble_prf_date_time_t : at_ble_event_parameter_t
  • at_ble_prf_server_error_ind_t : at_ble_event_parameter_t
  • at_ble_primary_service_found_t : at_ble_event_parameter_t
  • at_ble_rand_addr_changed_t : at_ble_event_parameter_t
  • at_ble_read_authorize_request_t : at_ble_event_parameter_t
  • at_ble_resolv_rand_addr_status_t : at_ble_event_parameter_t
  • at_ble_rx_power_value_t : at_ble_event_parameter_t
  • at_ble_scan_info_t : at_ble_event_parameter_t
  • at_ble_scan_report_t : at_ble_event_parameter_t
  • at_ble_service_changed_notification_confirmed_t : at_ble_event_parameter_t
  • at_ble_signature_info_t : at_ble_event_parameter_t
  • at_ble_slave_sec_request_t : at_ble_event_parameter_t
  • at_ble_spcp_t : at_ble_event_parameter_t
  • at_ble_tx_power_set_t : at_ble_event_parameter_t
  • at_ble_tx_power_value_t : at_ble_event_parameter_t
  • at_ble_uuid_t : at_ble_event_parameter_t
  • at_ble_write_authorize_request_t : at_ble_event_parameter_t
  • attr_handle : at_ble_included_service_found_t
  • auth : at_ble_pair_done_t


Atmel BLE API: Data Fields - Variables

- b -

  • ble_write_cb : _plf_params
  • bond : at_ble_pair_features_t , at_ble_slave_sec_request_t


Atmel BLE API: Data Fields - Variables

- c -

  • ce_len_max : at_ble_connection_params_t
  • ce_len_min : at_ble_connection_params_t
  • cfg_val : at_ble_htpt_cfg_indntf_ind_t
  • cfm_type : at_ble_htpt_temp_send_cfm_t
  • char_code : at_ble_htpt_cfg_indntf_ind_t
  • char_handle : at_ble_characteristic_changed_t , at_ble_characteristic_found_t , at_ble_characteristic_read_response_t , at_ble_characteristic_write_response_t , at_ble_indication_confirmed_t , at_ble_indication_recieved_t , at_ble_notification_recieved_t , at_ble_read_authorize_request_t , at_ble_write_authorize_request_t
  • char_len : at_ble_characteristic_changed_t , at_ble_characteristic_read_response_t , at_ble_indication_recieved_t , at_ble_notification_recieved_t
  • char_new_value : at_ble_characteristic_changed_t
  • char_offset : at_ble_characteristic_changed_t , at_ble_characteristic_read_response_t
  • char_uuid : at_ble_characteristic_found_t
  • char_val_handle : at_ble_characteristic_t
  • char_value : at_ble_characteristic_read_response_t , at_ble_indication_recieved_t , at_ble_notification_recieved_t
  • cid : at_ble_l2cap_rx_t
  • client_config_handle : at_ble_characteristic_t
  • client_config_permissions : at_ble_characteristic_t
  • con_intv : at_ble_conn_param_update_done_t
  • con_intv_max : at_ble_connection_params_t , at_ble_spcp_t
  • con_intv_min : at_ble_connection_params_t , at_ble_spcp_t
  • con_latency : at_ble_conn_param_update_done_t , at_ble_connection_params_t , at_ble_spcp_t
  • conhdl : at_ble_htpt_cfg_indntf_ind_t , at_ble_htpt_disable_ind_t , at_ble_htpt_temp_send_cfm_t , at_ble_prf_server_error_ind_t
  • conn_handle : at_ble_characteristic_changed_t , at_ble_characteristic_found_t , at_ble_characteristic_read_response_t , at_ble_characteristic_write_response_t , at_ble_descriptor_found_t , at_ble_included_service_found_t , at_ble_indication_confirmed_t , at_ble_indication_recieved_t , at_ble_l2cap_rx_t , at_ble_notification_recieved_t , at_ble_primary_service_found_t , at_ble_read_authorize_request_t , at_ble_service_changed_notification_confirmed_t , at_ble_write_authorize_request_t
  • conn_status : at_ble_connected_t


Atmel BLE API: Data Fields - Variables

- d -

  • data : at_ble_l2cap_rx_t
  • day : at_ble_prf_date_time_t
  • desc_handle : at_ble_descriptor_found_t
  • desc_uuid : at_ble_descriptor_found_t
  • description : at_ble_char_presentation_t
  • desired_auth : at_ble_pair_features_t
  • dev_addr : at_ble_scan_info_t
  • dev_name_perm : at_ble_gap_deviceinfo_t


Atmel BLE API: Data Fields - Variables

- e -

  • ediv : at_ble_encryption_request_t , at_ble_LTK_t
  • end_group_handle : at_ble_included_service_t
  • end_handle : at_ble_included_service_found_t , at_ble_primary_service_found_t
  • exponent : at_ble_char_presentation_t


Atmel BLE API: Data Fields - Variables

- f -

  • format : at_ble_char_presentation_t


Atmel BLE API: Data Fields - Variables

- h -

  • handle : at_ble_conn_param_update_done_t , at_ble_conn_param_update_request_t , at_ble_connected_t , at_ble_disconnected_t , at_ble_encryption_request_t , at_ble_encryption_status_changed_t , at_ble_max_PA_gain_value_t , at_ble_pair_done_t , at_ble_pair_key_request_t , at_ble_pair_request_t , at_ble_rx_power_value_t , at_ble_slave_sec_request_t , at_ble_tx_power_set_t , at_ble_tx_power_value_t
  • hour : at_ble_prf_date_time_t


Atmel BLE API: Data Fields - Variables

- i -

  • init_value : at_ble_characteristic_t
  • initiator_keys : at_ble_pair_features_t
  • interm_temp_ntf_en : at_ble_htpt_disable_ind_t
  • intv : at_ble_htpt_meas_intv_chg_ind_t
  • io_cababilities : at_ble_pair_features_t
  • irk : at_ble_gap_irk_t , at_ble_resolv_rand_addr_status_t
  • irkCount : at_ble_gap_whitelist_t


Atmel BLE API: Data Fields - Variables

- k -

  • key : at_ble_CSRK_t , at_ble_IRK_t , at_ble_LTK_t
  • key_size : at_ble_LTK_t


Atmel BLE API: Data Fields - Variables

- l -

  • len : at_ble_l2cap_rx_t
  • local_csrk : at_ble_signature_info_t
  • lsign_counter : at_ble_signature_info_t


Atmel BLE API: Data Fields - Variables

- m -

  • max_key_size : at_ble_pair_features_t
  • max_PA_gain_value : at_ble_max_PA_gain_value_t
  • meas_intv : at_ble_htpt_disable_ind_t
  • meas_intv_ind_en : at_ble_htpt_disable_ind_t
  • min : at_ble_prf_date_time_t
  • min_key_size : at_ble_pair_features_t
  • mitm_protection : at_ble_pair_features_t , at_ble_slave_sec_request_t
  • month : at_ble_prf_date_time_t
  • msg_id : at_ble_prf_server_error_ind_t


Atmel BLE API: Data Fields - Variables

- n -

  • name_space : at_ble_char_presentation_t
  • nb : at_ble_encryption_request_t , at_ble_LTK_t
  • num_valid : wifiprov_scanlist_ind


Atmel BLE API: Data Fields - Variables

- o -

  • oob_avaiable : at_ble_pair_features_t


Atmel BLE API: Data Fields - Variables

- p -

  • params : at_ble_conn_param_update_request_t
  • passkey_type : at_ble_pair_key_request_t
  • passphrase : at_ble_wifiprov_complete_ind
  • passphrase_length : at_ble_wifiprov_complete_ind
  • peer_addr : at_ble_connected_t
  • peer_csrk : at_ble_pair_done_t , at_ble_signature_info_t
  • peer_features : at_ble_pair_request_t
  • peer_irk : at_ble_pair_done_t
  • peer_ltk : at_ble_pair_done_t
  • peer_sign_counter : at_ble_signature_info_t
  • plf_wait_cb : _plf_params
  • ppAddrs : at_ble_gap_whitelist_t
  • ppIrks : at_ble_gap_whitelist_t
  • presentation_format : at_ble_characteristic_t
  • properties : at_ble_characteristic_found_t , at_ble_characteristic_t


Atmel BLE API: Data Fields - Variables

- r -

  • reason : at_ble_disconnected_t
  • responder_keys : at_ble_pair_features_t
  • rssi : _scanitem
  • rx_value : at_ble_rx_power_value_t


Atmel BLE API: Data Fields - Variables

- s -

  • scandetails : wifiprov_scanlist_ind
  • scanmode : at_ble_wifiprov_scan_mode_change_ind_t
  • sec : at_ble_prf_date_time_t
  • sec_type : _scanitem , at_ble_wifiprov_complete_ind
  • server_config_handle : at_ble_characteristic_t
  • server_config_permissions : at_ble_characteristic_t
  • service_handle : at_ble_included_service_t
  • service_uuid : at_ble_included_service_found_t , at_ble_primary_service_found_t
  • spcp_param : at_ble_gap_deviceinfo_t
  • ssid : _scanitem , at_ble_wifiprov_complete_ind
  • ssid_length : at_ble_wifiprov_complete_ind
  • start_handle : at_ble_included_service_found_t , at_ble_primary_service_found_t
  • status : at_ble_characteristic_changed_t , at_ble_characteristic_write_response_t , at_ble_conn_param_update_done_t , at_ble_discovery_complete_t , at_ble_encryption_status_changed_t , at_ble_htpt_create_db_cfm_t , at_ble_htpt_temp_send_cfm_t , at_ble_indication_confirmed_t , at_ble_pair_done_t , at_ble_prf_server_error_ind_t , at_ble_read_authorize_request_t , at_ble_resolv_rand_addr_status_t , at_ble_scan_report_t , at_ble_wifiprov_complete_ind , at_ble_write_authorize_request_t
  • superv_to : at_ble_conn_param_update_done_t , at_ble_connection_params_t , at_ble_spcp_t


Atmel BLE API: Data Fields - Variables

- t -

  • temp_meas_ind_en : at_ble_htpt_disable_ind_t
  • tx_set_status : at_ble_tx_power_set_t
  • tx_value : at_ble_tx_power_value_t
  • type : at_ble_addr_t , at_ble_pair_key_request_t , at_ble_scan_info_t , at_ble_uuid_t


Atmel BLE API: Data Fields - Variables

- u -

  • unit : at_ble_char_presentation_t
  • user_desc : at_ble_characteristic_t
  • user_desc_handle : at_ble_characteristic_t
  • user_desc_len : at_ble_characteristic_t
  • user_desc_max_len : at_ble_characteristic_t
  • user_desc_permissions : at_ble_characteristic_t
  • uuid : at_ble_characteristic_t , at_ble_included_service_t , at_ble_uuid_t


Atmel BLE API: Data Fields - Variables

- v -

  • value_handle : at_ble_characteristic_found_t
  • value_init_len : at_ble_characteristic_t
  • value_max_len : at_ble_characteristic_t
  • value_permissions : at_ble_characteristic_t


Atmel BLE API: Data Fields - Variables

- w -

  • wr_api32 : wr_apis
  • wr_api32_reset : wr_apis


Atmel BLE API: Data Fields - Variables

- y -

  • year : at_ble_prf_date_time_t


Atmel BLE API: at_ble_api.h Source File

  • ble
  • atmel_ble_api
  • include
at_ble_api.h
1
39 #ifndef __AT_BLE_API_H__
40 #define __AT_BLE_API_H__
41
42 #include <stdint.h>
43 #include <stdbool.h>
44
50 /****************************************************************************************
51 * Macros *
52 ****************************************************************************************/
53
55 #define AT_BLE_ADDR_LEN 6
56
58 #define AT_BLE_MAX_KEY_LEN (16)
59
61 #define AT_BLE_PASSKEY_LEN (6)
62
64 #define AT_BLE_GAP_WHITELIST_ADDR_MAX_COUNT (8)
65
69 #define AT_BLE_GAP_WHITELIST_IRK_MAX_COUNT (8)
70
72 #define AT_BLE_ADV_MAX_SIZE 31
73
75 #define AT_BLE_UUID_16_LEN (2)
76
78 #define AT_BLE_UUID_32_LEN (4)
79
81 #define AT_BLE_UUID_128_LEN (16)
82
83 #define AT_BLE_ADV_INTERVAL_MIN 0x0020
84 #define AT_BLE_ADV_NONCON_INTERVAL_MIN 0x00A0
85 #define AT_BLE_ADV_INTERVAL_MAX 0x4000
87 #define AT_BLE_SCAN_INTERVAL_MIN 0x0004
88 #define AT_BLE_SCAN_INTERVAL_MAX 0x4000
90 #define AT_BLE_SCAN_WINDOW_MIN 0x0004
91 #define AT_BLE_SCAN_WINDOW_MAX 0x4000
93 #define AT_CNX_INTERVAL_MIN 6
94 #define AT_CNX_INTERVAL_MAX 3200
96 #define AT_CNX_LATENCY_MIN 0
97 #define AT_CNX_LATENCY_MAX 499
99 #define AT_CNX_SUP_TO_MIN 10
100 #define AT_CNX_SUP_TO_MAX 3200
103 #define AT_BLE_MAX_ATT_LEN 512
104
106 #define AT_DEFAULT_MTU 0x0017
107
108 /****************************************************************************************
109 * Basic types *
110 ****************************************************************************************/
114 typedef uint16_t at_ble_handle_t;
115
116 /****************************************************************************************
117 * Enumerations *
118 ****************************************************************************************/
119
121 typedef enum
122 {
124 AT_BLE_SUCCESS =0,
126 AT_BLE_FAILURE,
128 AT_BLE_INVALID_PARAM,
130 AT_BLE_PRIVACY_CFG_PB,
132 AT_BLE_COMMAND_DISALLOWED,
134 AT_BLE_INVALID_STATE,
136 AT_BLE_INVALID_HANDLE,
138 AT_BLE_INSUFF_RESOURCE,
140 AT_BLE_INVALID_ATTRIBUTE_VAL_LEN,
142 AT_BLE_TIMEOUT
143 }at_ble_status_t;
144
145
147 typedef enum
148 {
149 // Timer related
150 AT_BLE_GAP_GEN_DISC_ADV_MIN =0,
151 AT_BLE_GAP_LIM_ADV_TIMEOUT,
152 AT_BLE_GAP_GEN_DISC_SCAN,
153 AT_BLE_GAP_LIM_DISC_SCAN,
154 AT_BLE_GAP_CONN_EST_ADV_TIMEOUT,
155 AT_BLE_GAP_CONN_PARAM_TIMEOUT,
156
157 // Constants
158 AT_BLE_GAP_LIM_DISC_ADV_INT_MIN,
159 AT_BLE_GAP_LIM_DISC_ADV_INT_MAX,
160 AT_BLE_GAP_GEN_DISC_ADV_INT_MIN,
161 AT_BLE_GAP_GEN_DISC_ADV_INT_MAX,
162 AT_BLE_GAP_CONN_ADV_INT_MIN,
163 AT_BLE_GAP_CONN_ADV_INT_MAX,
164 AT_BLE_GAP_CONN_SCAN_INT,
165 AT_BLE_GAP_CONN_SCAN_WIND,
166 AT_BLE_GAP_CONN_HIGH_SCAN_INT,
167 AT_BLE_GAP_CONN_HIGH_SCAN_WIND,
168 AT_BLE_GAP_GEN_DISC_SCAN_INT,
169 AT_BLE_GAP_GEN_DISC_SCAN_WIND,
170 AT_BLE_GAP_LIM_DISC_SCAN_INT,
171 AT_BLE_GAP_LIM_DISC_SCAN_WIND,
172 AT_BLE_GAP_CONN_EST_ADV,
173 AT_BLE_GAP_CONN_EST_INT_MIN,
174 AT_BLE_GAP_CONN_EST_INT_MAX,
175 AT_BLE_GAP_CONN_EST_SCAN_INT,
176 AT_BLE_GAP_CONN_EST_SCAN_WIND,
177 AT_BLE_GAP_CONN_EST_SUPERV_TIMEOUT,
178 AT_BLE_GAP_CONN_EST_LATENCY,
179 AT_BLE_GAP_CONN_EST_MIN_CE_LEN,
180 AT_BLE_GAP_CONN_EST_MAX_CE_LEN,
181 AT_BLE_GAP_PRIVATE_ADDR_INT,
182 AT_BLE_GAP_CONN_PAUSE_CENTRAL,
183 AT_BLE_GAP_CONN_PAUSE_PERIPHERAL
184 }at_ble_parameters_t;
185
187 typedef enum
188 {
190 AT_BLE_GAP_NO_ROLE = 0x00,
191
193 AT_BLE_GAP_OBSERVER_SCA = 0x01,
194
196 AT_BLE_GAP_BROADCASTER_ADV = 0x02,
197
199 AT_BLE_GAP_CENTRAL_MST = (0x04 | AT_BLE_GAP_OBSERVER_SCA),
200
202 AT_BLE_GAP_PERIPHERAL_SLV = (0x08 | AT_BLE_GAP_BROADCASTER_ADV)
203 } at_ble_gap_role;
204
206 typedef enum{
207 AT_BLE_ADV_TYPE_UNDIRECTED = 0x00,
208 AT_BLE_ADV_TYPE_DIRECTED,
209 AT_BLE_ADV_TYPE_SCANNABLE_UNDIRECTED,
210 AT_BLE_ADV_TYPE_NONCONN_UNDIRECTED,
211 AT_BLE_ADV_TYPE_SCAN_RESPONSE
212 }at_ble_adv_type_t;
213
214
217 typedef enum{
218 /* GAP events */
220 AT_BLE_UNDEFINED_EVENT,
224 AT_BLE_SCAN_INFO,
228 AT_BLE_SCAN_REPORT,
232 AT_BLE_RAND_ADDR_CHANGED,
236 AT_BLE_CONNECTED,
240 AT_BLE_DISCONNECTED,
244 AT_BLE_CONN_PARAM_UPDATE_DONE,
248 AT_BLE_CONN_PARAM_UPDATE_REQUEST,
252 AT_BLE_RX_POWER_VALUE,
256 AT_BLE_PAIR_DONE,
260 AT_BLE_PAIR_REQUEST,
264 AT_BLE_SLAVE_SEC_REQUEST,
268 AT_BLE_PAIR_KEY_REQUEST,
272 AT_BLE_ENCRYPTION_REQUEST,
276 AT_BLE_ENCRYPTION_STATUS_CHANGED,
280 AT_BLE_RESOLV_RAND_ADDR_STATUS,
281
282 /* GATT Client events */
286 AT_BLE_PRIMARY_SERVICE_FOUND,
290 AT_BLE_INCLUDED_SERVICE_FOUND,
294 AT_BLE_CHARACTERISTIC_FOUND,
298 AT_BLE_DESCRIPTOR_FOUND,
302 AT_BLE_DISCOVERY_COMPLETE,
306 AT_BLE_CHARACTERISTIC_READ_RESPONSE,
310 AT_BLE_CHARACTERISTIC_READ_MULTIBLE_RESPONSE,
314 AT_BLE_CHARACTERISTIC_WRITE_RESPONSE,
318 AT_BLE_NOTIFICATION_RECIEVED,
322 AT_BLE_INDICATION_RECIEVED,
323
324 /* GATT Server events */
328 AT_BLE_INDICATION_CONFIRMED,
332 AT_BLE_CHARACTERISTIC_CHANGED,
336 AT_BLE_SERVICE_CHANGED_NOTIFICATION_CONFIRMED,
340 AT_BLE_WRITE_AUTHORIZE_REQUEST,
344 AT_BLE_READ_AUTHORIZE_REQUEST,
345 /* L2CAP events */
349 AT_BLE_L2CAP_RX,
350
351 /* HTPT Health Thermometer Profile events */
355 AT_BLE_HTPT_CREATE_DB_CFM,
359 AT_BLE_HTPT_ERROR_IND,
363 AT_BLE_HTPT_DISABLE_IND,
367 AT_BLE_HTPT_TEMP_SEND_CFM,
371 AT_BLE_HTPT_MEAS_INTV_CHG_IND,
375 AT_BLE_HTPT_CFG_INDNTF_IND,
376
377 /* WiFi Prov events */
381 AT_BLE_WIFIPROV_SCAN_MODE_CHANGE_IND,
385 AT_BLE_WIFIPROV_COMPLETE_IND,
386
387 /* Custom user defined events */
389 AT_BLE_CUSTOM_EVENT,
390
394 AT_BLE_TX_POWER_VALUE,
398 AT_BLE_TX_POWER_SET,
402 AT_BLE_MAX_PA_GAIN_VALUE,
403
405 AT_BLE_MTU_CHANGED_CMD_COMPLETE,
406
408 AT_BLE_CHARACTERISTIC_WRITE_CMD_CMP,
409
411 AT_BLE_NOTIFICATION_CONFIRMED
412
413 }at_ble_events_t;
414
415
418 typedef enum{
420 AT_BLE_ADDRESS_PUBLIC,
422 AT_BLE_ADDRESS_RANDOM_STATIC,
424 AT_BLE_ADDRESS_RANDOM_PRIVATE_RESOLVABLE,
426 AT_BLE_ADDRESS_RANDOM_PRIVATE_NON_RESOLVABLE ,
428 AT_BLE_ADDRESS_INVALID,
429
430 }at_ble_addr_type_t;
431
432
435 typedef enum{
436 AT_BLE_TERMINATED_BY_USER,
437 AT_BLE_UNACCEPTABLE_INTERVAL,
438 }at_ble_disconnect_reason_t;
439
442 typedef enum{
444 AT_BLE_IO_CAP_DISPLAY_ONLY,
446 AT_BLE_IO_CAP_DISPLAY_YES_NO,
448 AT_BLE_IO_CAP_KB_ONLY,
450 AT_BLE_IO_CAP_NO_INPUT_NO_OUTPUT,
452 AT_BLE_IO_CAP_KB_DISPLAY,
453
454 }at_ble_iocab_t;
455
458 typedef enum{
460 AT_BLE_KEY_DIST_NONE = 0x00,
462 AT_BLE_KEY_DIST_ENC = (1 << 0),
464 AT_BLE_KEY_DIST_ID = (1 << 1),
466 AT_BLE_KEY_DIST_SIGN = (1 << 2),
468 AT_BLE_KEY_DIS_ALL = AT_BLE_KEY_DIST_ENC
469 | AT_BLE_KEY_DIST_ID
470 | AT_BLE_KEY_DIST_SIGN,
471
472 }at_ble_key_dis_t;
473
476 typedef enum{
478 AT_BLE_NO_SEC = 0x00,
480 AT_BLE_MODE1_L1_NOAUTH_PAIR_ENC,
482 AT_BLE_MODE1_L2_AUTH_PAIR_ENC,
484 AT_BLE_MODE2_L1_NOAUTH_DATA_SGN,
486 AT_BLE_MODE2_L2_AUTH_DATA_SGN,
487
488 }at_ble_auth_levels_t;
489
492 typedef enum{
494 AT_BLE_UUID_16,
496 AT_BLE_UUID_32,
498 AT_BLE_UUID_128,
500 AT_BLE_UUID_INVALID,
501 }at_ble_uuid_type_t;
502
505 typedef enum{
506 AT_BLE_CHAR_BROADCST = (1 << 0),
507 AT_BLE_CHAR_READ = (1 << 1),
508 AT_BLE_CHAR_WRITE_WITHOUT_RESPONSE = (1 << 2),
509 AT_BLE_CHAR_WRITE = (1 << 3),
510 AT_BLE_CHAR_NOTIFY = (1 << 4),
511 AT_BLE_CHAR_INDICATE = (1 << 5),
512 AT_BLE_CHAR_SIGNED_WRITE = (1 << 6),
513 AT_BLE_CHAR_RELIABLE_WRITE = (1 << 7),
514 AT_BLE_CHAR_WRITEABLE_AUX = (1 << 8),
515 }at_ble_char_properties_t;
516
519 typedef enum{
521 AT_BLE_ADV_FP_ANY,
523 AT_BLE_ADV_FP_FILTER_SCANREQ,
525 AT_BLE_ADV_FP_FILTER_CONNREQ,
527 AT_BLE_ADV_FP_FILTER_BOTH
528 }at_ble_filter_type_t;
529
532 typedef enum{
534 AT_BLE_ADV_NON_DISCOVERABLE,
536 AT_BLE_ADV_GEN_DISCOVERABLE,
538 AT_BLE_ADV_LIM_DISCOVERABLE,
540 AT_BLE_ADV_BROADCASTER_MODE
541 }at_ble_adv_mode_t;
542
545 typedef enum{
547 AT_BLE_SCAN_GEN_DISCOVERY,
549 AT_BLE_SCAN_LIM_DISCOVERY,
551 AT_BLE_SCAN_OBSERVER_MODE
552 }at_ble_scan_mode_t;
553
556 typedef enum{
558 AT_BLE_SCAN_PASSIVE,
560 AT_BLE_SCAN_ACTIVE
561 }at_ble_scan_type_t;
562
565 typedef enum{
566 AT_BLE_ATTR_NO_PERMISSIONS = 0x00,
567
568 AT_BLE_ATTR_READABLE_NO_AUTHN_NO_AUTHR = 0x01,
569 AT_BLE_ATTR_READABLE_REQ_AUTHN_NO_AUTHR = 0x02,
570 AT_BLE_ATTR_READABLE_NO_AUTHN_REQ_AUTHR = 0x03,
571 AT_BLE_ATTR_READABLE_REQ_AUTHN_REQ_AUTHR = 0x04,
572
573 AT_BLE_ATTR_WRITABLE_NO_AUTHN_NO_AUTHR = 0x10,
574 AT_BLE_ATTR_WRITABLE_REQ_AUTHN_NO_AUTHR = 0x20,
575 AT_BLE_ATTR_WRITABLE_NO_AUTHN_REQ_AUTHR = 0x30,
576 AT_BLE_ATTR_WRITABLE_REQ_AUTHN_REQ_AUTHR = 0x40,
577
578 }at_ble_attr_permissions_t;
579
582 typedef enum{
583 AT_BLE_PRES_FORMAT_BOOLEAN = 0X01,
584 AT_BLE_PRES_FORMAT_2BIT = 0X02,
585 AT_BLE_PRES_FORMAT_NIBBLE = 0X03,
586 AT_BLE_PRES_FORMAT_UINT8 = 0X04,
587 AT_BLE_PRES_FORMAT_UINT12 = 0X05,
588 AT_BLE_PRES_FORMAT_UINT16 = 0X06,
589 AT_BLE_PRES_FORMAT_UINT24 = 0X07,
590 AT_BLE_PRES_FORMAT_UINT32 = 0X08,
591 AT_BLE_PRES_FORMAT_UINT48 = 0X09,
592 AT_BLE_PRES_FORMAT_UINT64 = 0X0A,
593 AT_BLE_PRES_FORMAT_UINT128 = 0X0B,
594 AT_BLE_PRES_FORMAT_SINT8 = 0X0C,
595 AT_BLE_PRES_FORMAT_SINT12 = 0X0D,
596 AT_BLE_PRES_FORMAT_SINT16 = 0X0E,
597 AT_BLE_PRES_FORMAT_SINT24 = 0X0F,
598 AT_BLE_PRES_FORMAT_SINT32 = 0X10,
599 AT_BLE_PRES_FORMAT_SINT48 = 0X11,
600 AT_BLE_PRES_FORMAT_SINT64 = 0X12,
601 AT_BLE_PRES_FORMAT_SINT128 = 0X13,
602 AT_BLE_PRES_FORMAT_FLOAT32 = 0X14,
603 AT_BLE_PRES_FORMAT_FLOAT64 = 0X15,
604 AT_BLE_PRES_FORMAT_SFLOAT = 0X16,
605 AT_BLE_PRES_FORMAT_FLOAT = 0X17,
606 AT_BLE_PRES_FORMAT_DUINT16 = 0X18,
607 AT_BLE_PRES_FORMAT_UTF8S = 0X19,
608 AT_BLE_PRES_FORMAT_UTF16S = 0X1A,
609 AT_BLE_PRES_FORMAT_STRUCT = 0X1B,
610 }at_ble_char_pres_format_t;
611
614 typedef enum
615 {
616 AT_BLE_PAIR_PASSKEY,
618 AT_BLE_PAIR_OOB
619 }at_ble_pair_key_type_t;
620
623 typedef enum
624 {
626 AT_BLE_PAIR_PASSKEY_ENTRY,
628 AT_BLE_PAIR_PASSKEY_DISPLAY
629 }at_ble_passkey_type_t;
630
633 typedef enum
634 {
636 AT_BLE_AUTH_NO_MITM_NO_BOND,
638 AT_BLE_AUTH_NO_MITM_BOND = 0x01,
640 AT_BLE_AUTH_MITM_NO_BOND = 0x04,
642 AT_BLE_AUTH_MITM_BOND = 0x05
643 }at_ble_auth_t;
644
646 typedef enum
647 {
649 GAP_AUTHZ_NOT_SET = 0x00,
651 GAP_AUTHZ_ACCEPT = 0x01,
653 GAP_AUTHZ_REJECT = 0x02
654 }at_ble_author_t;
655
658 typedef enum
659 {
661 AT_BLE_WRITE_DISABLE,
663 AT_BLE_WRITE_ENABLE,
665 AT_BLE_WRITE_UNAUTH,
667 AT_BLE_WRITE_AUTH
668 }at_ble_att_write_perm_t;
669
671 typedef enum
672 {
674 PRF_CON_DISCOVERY = 0x00,
676 PRF_CON_NORMAL = 0x01
677 }at_ble_prf_con_type_t;
678
680 typedef enum
681 {
683 AT_BLE_DISCOVERY_SUCCESS=0x00,
685 AT_BLE_DISCOVERY_FAILURE
686 }at_ble_gattc_discovery_complete_status_t;
687
690 typedef enum
691 {
693 HTPT_TEMP_TYPE_CHAR_SUP = 0x01,
695 HTPT_INTERM_TEMP_CHAR_SUP = 0x02,
697 HTPT_MEAS_INTV_CHAR_SUP = 0x04,
699 HTPT_MEAS_INTV_IND_SUP = 0x08,
701 HTPT_MEAS_INTV_WR_SUP = 0x10,
702
704 HTPT_ALL_FEAT_SUP = 0x1F,
705 }at_ble_htpt_db_config_flag;
706
710 typedef enum
711 {
713 HTPT_DISABLE = 0x00,
715 HTPT_ENABLE = 0x01,
717 HTPT_UNAUTH = 0x02,
719 HTPT_AUTH = 0x03
720 }at_ble_htpt_sec_level;
721
724 typedef enum
725 {
726 HTPT_TEMP_MEAS_CHAR,
727 HTPT_TEMP_TYPE_CHAR,
728 HTPT_INTERM_TEMP_CHAR,
729 HTPT_MEAS_INTV_CHAR,
730
731 HTPT_CHAR_MAX
732 }at_ble_htpt_attr_index;
733
736 typedef enum
737 {
739 HTPT_FLAG_CELSIUS = 0x00,
741 HTPT_FLAG_FAHRENHEIT,
743 HTPT_FLAG_TIME,
745 HTPT_FLAG_TYPE = 0x04
746 }at_ble_htpt_temp_flags;
747
748
751 typedef enum
752 {
754 HTP_TYPE_ARMPIT = 0x01,
756 HTP_TYPE_BODY = 0x02,
758 HTP_TYPE_EAR = 0x03,
760 HTP_TYPE_FINGER = 0x04,
762 HTP_TYPE_GASTRO_INTESTINAL_TRACT = 0x05,
764 HTP_TYPE_MOUTH = 0x06,
766 HTP_TYPE_RECTUM = 0x07,
768 HTP_TYPE_TOE = 0x08,
770 HTP_TYPE_TYMPANUM = 0x09
771 }at_ble_htpt_temp_type;
772
775 typedef enum
776 {
777 HTPT_CONFIG_CONN= 0,
778 HTPT_NORMAL_CONN=1
779 }at_ble_htpt_conn_type;
780
783 typedef enum
784 {
786 HTPT_STOP_NTFIND = 0x0000,
788 HTPT_START_NTF,
790 HTPT_START_IND,
791 }at_ble_htpt_ntfind;
792
793
796 typedef enum
797 {
799 HTPT_CFG_STABLE_MEAS_IND = (1 << 0),
801 HTPT_CFG_INTERM_MEAS_NTF = (1 << 1),
803 HTPT_CFG_MEAS_INTV_IND = (1 << 2),
804 }at_ble_htpt_ntf_ind_cfg;
805
810 /****************************************************************************************
811 * Structures *
812 ****************************************************************************************/
813
815 typedef struct
816 {
817 at_ble_addr_type_t type;
818 uint8_t addr[AT_BLE_ADDR_LEN];
819 } at_ble_addr_t;
820
821
822
824 typedef struct
825 {
826 uint8_t irk[AT_BLE_MAX_KEY_LEN];
827 } at_ble_gap_irk_t;
828
831 typedef struct
832 {
834 uint16_t con_intv_min;
836 uint16_t con_intv_max;
838 uint16_t con_latency;
840 uint16_t superv_to;
841 }at_ble_spcp_t;
842
843 typedef struct
844 {
846 at_ble_spcp_t spcp_param ;
848 uint16_t appearance;
850 at_ble_att_write_perm_t dev_name_perm;
851 }at_ble_gap_deviceinfo_t;
852
854 typedef struct
855 {
856 at_ble_addr_t ** ppAddrs;
857 uint8_t addrCount;
858 at_ble_gap_irk_t ** ppIrks;
859 uint8_t irkCount;
860 } at_ble_gap_whitelist_t;
861
862
865 typedef struct
866 {
868 uint16_t con_intv_min;
870 uint16_t con_intv_max;
872 uint16_t con_latency;
874 uint16_t superv_to;
876 uint16_t ce_len_min;
878 uint16_t ce_len_max;
879
880 }at_ble_connection_params_t;
881
884 typedef struct
885 {
886 at_ble_uuid_type_t type;
890 uint8_t uuid[AT_BLE_UUID_128_LEN];
895 }at_ble_uuid_t;
896
899 typedef struct
900 {
901 at_ble_char_pres_format_t format;
902 int8_t exponent;
903 uint16_t unit;
904 uint8_t name_space;
905 uint16_t description;
907 }at_ble_char_presentation_t;
908
911 typedef struct
912 {
913 at_ble_handle_t char_val_handle;
914 at_ble_uuid_t uuid;
915 at_ble_char_properties_t properties;
917 uint8_t* init_value;
918 uint16_t value_init_len;
919 uint16_t value_max_len;
920 at_ble_attr_permissions_t value_permissions; //TODO: can this value be deduced from properties field ?
921
922 uint8_t* user_desc;
923 uint16_t user_desc_len;
924 uint16_t user_desc_max_len;
925 at_ble_attr_permissions_t user_desc_permissions;
926 at_ble_attr_permissions_t client_config_permissions;
927 at_ble_attr_permissions_t server_config_permissions;
928 at_ble_handle_t user_desc_handle;
929 at_ble_handle_t client_config_handle;
930 at_ble_handle_t server_config_handle;
931
932 at_ble_char_presentation_t* presentation_format;
934 }at_ble_characteristic_t;
935
938 typedef struct
939 {
940 at_ble_uuid_t uuid;
941 at_ble_handle_t service_handle;
942 at_ble_handle_t end_group_handle;
944 }at_ble_included_service_t;
945
948 typedef struct
949 {
950 at_ble_iocab_t io_cababilities;
951 bool mitm_protection;
952 bool bond;
953 bool oob_avaiable;
954 uint8_t min_key_size;
955 uint8_t max_key_size;
956 at_ble_key_dis_t initiator_keys;
957 at_ble_key_dis_t responder_keys;
958 at_ble_auth_levels_t desired_auth;
959 }at_ble_pair_features_t;
960
963 typedef struct
964 {
966 uint8_t key[AT_BLE_MAX_KEY_LEN];
968 uint16_t ediv;
970 uint8_t nb[8];
972 uint8_t key_size;
973
974 }at_ble_LTK_t;
975
978 typedef struct
979 {
980 uint8_t key[AT_BLE_MAX_KEY_LEN];
981 }at_ble_CSRK_t;
982
983 typedef struct
984 {
986 uint8_t key[AT_BLE_MAX_KEY_LEN];
988 at_ble_addr_t addr;
989
990 }at_ble_IRK_t;
991 typedef struct
992 {
994 at_ble_CSRK_t peer_csrk;
996 at_ble_CSRK_t local_csrk;
998 uint32_t lsign_counter;
1000 uint32_t peer_sign_counter;
1001
1002 }at_ble_signature_info_t;
1003
1004 typedef struct
1005 {
1006 at_ble_adv_type_t type;
1007 at_ble_addr_t dev_addr;
1008 uint8_t adv_data[AT_BLE_ADV_MAX_SIZE];
1009 uint8_t adv_data_len;
1010
1011 }at_ble_scan_info_t;
1012
1013
1014 typedef struct
1015 {
1016 at_ble_status_t status;
1017 }at_ble_scan_report_t;
1018
1021 typedef struct
1022 {
1023 at_ble_addr_t peer_addr;
1024 at_ble_handle_t handle;
1025 at_ble_status_t conn_status;
1026
1027 }at_ble_connected_t;
1028
1029 typedef struct
1030 {
1031 uint8_t addr[AT_BLE_ADDR_LEN];
1032 }
1033 at_ble_rand_addr_changed_t;
1034
1035 typedef struct
1036 {
1037 at_ble_handle_t handle;
1038 uint8_t reason;
1039
1040 }at_ble_disconnected_t;
1041
1042 typedef struct
1043 {
1044 at_ble_handle_t handle;
1045 at_ble_status_t status;
1046 uint16_t con_intv;
1047 uint16_t con_latency;
1048 uint16_t superv_to;
1049
1050 }at_ble_conn_param_update_done_t;
1051
1052 typedef struct
1053 {
1054 at_ble_handle_t handle;
1055 at_ble_connection_params_t params;
1056
1057 }at_ble_conn_param_update_request_t;
1058
1059 typedef struct
1060 {
1061 at_ble_handle_t handle;
1062 uint16_t rx_value;
1063
1064 }at_ble_rx_power_value_t;
1065
1066 typedef struct
1067 {
1068 at_ble_handle_t handle;
1069 uint16_t max_PA_gain_value;
1070 }at_ble_max_PA_gain_value_t;
1071
1072 typedef struct
1073 {
1074 at_ble_handle_t handle;
1075 uint16_t tx_value;
1076 }at_ble_tx_power_value_t;
1077
1078 typedef struct
1079 {
1080 at_ble_handle_t handle;
1081 uint8_t tx_set_status;
1082 }at_ble_tx_power_set_t;
1083
1086 typedef struct
1087 {
1088 at_ble_auth_t auth;
1089 at_ble_handle_t handle;
1090 at_ble_status_t status;
1091 at_ble_LTK_t peer_ltk;
1092 at_ble_CSRK_t peer_csrk;
1093 at_ble_IRK_t peer_irk;
1094
1095 }at_ble_pair_done_t;
1096
1097 typedef struct
1098 {
1099 at_ble_handle_t handle;
1100 at_ble_pair_features_t peer_features;
1101
1102 }at_ble_pair_request_t;
1103
1104 typedef struct
1105 {
1106 at_ble_handle_t handle;
1107 at_ble_pair_key_type_t type;
1108 at_ble_passkey_type_t passkey_type;
1109
1110 }at_ble_pair_key_request_t;
1111
1112 typedef struct
1113 {
1114 at_ble_handle_t handle;
1115 bool bond;
1116 bool mitm_protection;
1117
1118 }at_ble_slave_sec_request_t;
1119
1120 typedef struct
1121 {
1122 at_ble_handle_t handle;
1124 uint16_t ediv;
1126 uint8_t nb[8];
1127
1128 }at_ble_encryption_request_t;
1129
1130 typedef struct
1131 {
1132 at_ble_handle_t handle;
1133 at_ble_status_t status;
1134
1135 }at_ble_encryption_status_changed_t;
1136
1137 typedef struct
1138 {
1139 at_ble_status_t status;
1141 uint8_t irk[AT_BLE_MAX_KEY_LEN];
1142
1143 }at_ble_resolv_rand_addr_status_t;
1144
1145
1146 typedef struct
1147 {
1148 at_ble_gattc_discovery_complete_status_t status;
1149 }at_ble_discovery_complete_t;
1150
1151 typedef struct
1152 {
1153 at_ble_handle_t conn_handle;
1154 at_ble_handle_t start_handle;
1155 at_ble_handle_t end_handle;
1156 at_ble_uuid_t service_uuid;
1157
1158 }at_ble_primary_service_found_t;
1159
1160 typedef struct
1161 {
1162 at_ble_handle_t conn_handle;
1163 at_ble_handle_t attr_handle;
1164 at_ble_handle_t start_handle;
1165 at_ble_handle_t end_handle;
1166 at_ble_uuid_t service_uuid;
1167
1168 }at_ble_included_service_found_t;
1169
1170 typedef struct
1171 {
1172 at_ble_handle_t conn_handle;
1173 at_ble_handle_t char_handle;
1174 at_ble_handle_t value_handle;
1175 uint8_t properties;
1176 at_ble_uuid_t char_uuid;
1177
1178 }at_ble_characteristic_found_t;
1179
1180 typedef struct
1181 {
1182 at_ble_handle_t conn_handle;
1183 at_ble_handle_t desc_handle;
1184 at_ble_uuid_t desc_uuid;
1185
1186 }at_ble_descriptor_found_t;
1187
1188
1189 typedef struct
1190 {
1191 at_ble_handle_t conn_handle;
1192 at_ble_handle_t char_handle;
1193 uint16_t char_len;
1194 uint16_t char_offset;
1195 uint8_t char_value[AT_BLE_MAX_ATT_LEN];
1196 }at_ble_characteristic_read_response_t;
1197
1198 typedef struct
1199 {
1200 at_ble_handle_t conn_handle;
1201 at_ble_handle_t char_handle;
1202 at_ble_status_t status;
1203
1204 }at_ble_characteristic_write_response_t;
1205
1206 typedef struct
1207 {
1208 at_ble_handle_t conn_handle;
1209 at_ble_handle_t char_handle;
1210 uint8_t char_value[AT_BLE_MAX_ATT_LEN];
1211 uint16_t char_len;
1212 }at_ble_notification_recieved_t;
1213
1214 typedef struct
1215 {
1216 at_ble_handle_t conn_handle;
1217 at_ble_handle_t char_handle;
1218 uint8_t char_value[AT_BLE_MAX_ATT_LEN];
1219 uint16_t char_len;
1220 }at_ble_indication_recieved_t;
1221
1222 typedef struct
1223 {
1224 at_ble_handle_t conn_handle;
1225 at_ble_handle_t char_handle;
1226 at_ble_status_t status;
1227
1228 }at_ble_indication_confirmed_t;
1229
1230 typedef struct
1231 {
1232 at_ble_handle_t conn_handle;
1233 at_ble_handle_t char_handle;
1234 uint8_t char_new_value[AT_BLE_MAX_ATT_LEN];
1235 uint16_t char_len;
1236 uint16_t char_offset;
1237 at_ble_status_t status;
1238
1239 }at_ble_characteristic_changed_t;
1240
1241 typedef struct
1242 {
1243 at_ble_handle_t conn_handle;
1244
1245 }at_ble_service_changed_notification_confirmed_t;
1246
1247 typedef struct
1248 {
1249 at_ble_handle_t conn_handle;
1250 at_ble_handle_t char_handle;
1251 at_ble_status_t status;
1252
1253 }at_ble_write_authorize_request_t;
1254
1255 typedef struct
1256 {
1257 at_ble_handle_t conn_handle;
1258 at_ble_handle_t char_handle;
1259 at_ble_status_t status;
1260
1261 }at_ble_read_authorize_request_t;
1262
1263 typedef struct
1264 {
1265 at_ble_handle_t conn_handle;
1266 uint16_t cid;
1267 uint16_t len;
1268 uint8_t* data;
1269
1270 }at_ble_l2cap_rx_t;
1271
1272
1274 typedef struct
1275 {
1277 uint16_t conhdl;
1279 uint16_t msg_id;
1281 uint8_t status;
1282 }at_ble_prf_server_error_ind_t;
1284 typedef struct
1285 {
1287 uint16_t year;
1289 uint8_t month;
1291 uint8_t day;
1293 uint8_t hour;
1295 uint8_t min;
1297 uint8_t sec;
1298 }at_ble_prf_date_time_t;
1299
1300
1303 typedef struct
1304 {
1306 uint8_t status;
1307 }at_ble_htpt_create_db_cfm_t;
1308
1311 typedef struct
1312 {
1314 uint16_t conhdl;
1315
1317 uint16_t temp_meas_ind_en;
1319 uint16_t interm_temp_ntf_en;
1321 uint16_t meas_intv_ind_en;
1323 uint16_t meas_intv;
1324 }at_ble_htpt_disable_ind_t;
1325
1328 typedef struct
1329 {
1331 uint16_t conhdl;
1333 uint8_t status;
1335 uint8_t cfm_type;
1336 }at_ble_htpt_temp_send_cfm_t;
1337
1340 typedef struct
1341 {
1342 uint16_t intv;
1343 }at_ble_htpt_meas_intv_chg_ind_t;
1344
1347 typedef struct
1348 {
1350 uint16_t conhdl;
1352 uint16_t cfg_val;
1354 at_ble_htpt_attr_index char_code;
1355 }at_ble_htpt_cfg_indntf_ind_t;
1356
1357
1358
1359
1360
1361 typedef union
1362 {
1363 at_ble_addr_t at_ble_addr_t;
1364 at_ble_gap_irk_t at_ble_gap_irk_t;
1365 at_ble_spcp_t at_ble_spcp_t;
1366 at_ble_gap_deviceinfo_t at_ble_gap_deviceinfo_t;
1367 at_ble_gap_whitelist_t at_ble_gap_whitelist_t;
1368 at_ble_connection_params_t at_ble_connection_params_t;
1369 at_ble_uuid_t at_ble_uuid_t;
1370 at_ble_char_presentation_t at_ble_char_presentation_t;
1371 at_ble_characteristic_t at_ble_characteristic_t;
1372 at_ble_included_service_t at_ble_included_service_t;
1373 at_ble_pair_features_t at_ble_pair_features_t;
1374 at_ble_LTK_t at_ble_LTK_t;
1375 at_ble_CSRK_t at_ble_CSRK_t;
1376 at_ble_IRK_t at_ble_IRK_t;
1377 at_ble_signature_info_t at_ble_signature_info_t;
1378 at_ble_scan_info_t at_ble_scan_info_t;
1379 at_ble_scan_report_t at_ble_scan_report_t;
1380 at_ble_connected_t at_ble_connected_t;
1381 at_ble_rand_addr_changed_t at_ble_rand_addr_changed_t;
1382 at_ble_disconnected_t at_ble_disconnected_t;
1383 at_ble_conn_param_update_done_t at_ble_conn_param_update_done_t;
1384 at_ble_conn_param_update_request_t at_ble_conn_param_update_request_t;
1385 at_ble_rx_power_value_t at_ble_rx_power_value_t;
1386 at_ble_max_PA_gain_value_t at_ble_max_PA_gain_value_t;
1387 at_ble_tx_power_value_t at_ble_tx_power_value_t;
1388 at_ble_tx_power_set_t at_ble_tx_power_set_t;
1389 at_ble_pair_done_t at_ble_pair_done_t;
1390 at_ble_pair_request_t at_ble_pair_request_t;
1391 at_ble_pair_key_request_t at_ble_pair_key_request_t;
1392 at_ble_slave_sec_request_t at_ble_slave_sec_request_t;
1393 at_ble_encryption_request_t at_ble_encryption_request_t;
1394 at_ble_encryption_status_changed_t at_ble_encryption_status_changed_t;
1395 at_ble_resolv_rand_addr_status_t at_ble_resolv_rand_addr_status_t;
1396 at_ble_discovery_complete_t at_ble_discovery_complete_t;
1397 at_ble_primary_service_found_t at_ble_primary_service_found_t;
1398 at_ble_included_service_found_t at_ble_included_service_found_t;
1399 at_ble_characteristic_found_t at_ble_characteristic_found_t;
1400 at_ble_descriptor_found_t at_ble_descriptor_found_t;
1401 at_ble_characteristic_read_response_t at_ble_characteristic_read_response_t;
1402 at_ble_characteristic_write_response_t at_ble_characteristic_write_response_t;
1403 at_ble_notification_recieved_t at_ble_notification_recieved_t;
1404 at_ble_indication_recieved_t at_ble_indication_recieved_t;
1405 at_ble_indication_confirmed_t at_ble_indication_confirmed_t;
1406 at_ble_characteristic_changed_t at_ble_characteristic_changed_t;
1407 at_ble_service_changed_notification_confirmed_t at_ble_service_changed_notification_confirmed_t;
1408 at_ble_write_authorize_request_t at_ble_write_authorize_request_t;
1409 at_ble_read_authorize_request_t at_ble_read_authorize_request_t;
1410 at_ble_l2cap_rx_t at_ble_l2cap_rx_t;
1411 at_ble_prf_server_error_ind_t at_ble_prf_server_error_ind_t;
1412 at_ble_prf_date_time_t at_ble_prf_date_time_t;
1413 at_ble_htpt_create_db_cfm_t at_ble_htpt_create_db_cfm_t;
1414 at_ble_htpt_disable_ind_t at_ble_htpt_disable_ind_t;
1415 at_ble_htpt_temp_send_cfm_t at_ble_htpt_temp_send_cfm_t;
1416 at_ble_htpt_meas_intv_chg_ind_t at_ble_htpt_meas_intv_chg_ind_t;
1417 at_ble_htpt_cfg_indntf_ind_t at_ble_htpt_cfg_indntf_ind_t;
1418 } at_ble_event_parameter_t;
1419
1420 /****************************************************************************************
1421 * Functions *
1422 ****************************************************************************************/
1423
1424 //void prepare_apis(wr_apis);
1425
1440 at_ble_status_t at_ble_init(void* args);
1441
1451 at_ble_status_t at_ble_set_gap_deviceinfo(at_ble_gap_deviceinfo_t* gap_deviceinfo);
1452
1463 at_ble_status_t at_ble_set_dev_config(at_ble_gap_role role);
1464
1474 at_ble_status_t at_ble_device_name_set(uint8_t* dev_name, uint8_t len);
1475
1484 at_ble_status_t at_ble_set_privacy_key(at_ble_gap_irk_t* irk , uint16_t interval);
1485
1503 at_ble_status_t at_ble_addr_set(at_ble_addr_t* address);
1504
1513 at_ble_status_t at_ble_addr_get(at_ble_addr_t* address);
1514
1525 at_ble_status_t at_ble_event_get(at_ble_events_t* event, void* params,
1526 uint32_t timeout);
1527
1537 at_ble_status_t at_ble_event_user_defined_post(void* params);
1538
1539
1552 at_ble_status_t at_ble_gap_set_param(at_ble_parameters_t param,
1553 uint8_t* value_buff, uint16_t value_len);
1554
1555
1568 at_ble_status_t at_ble_gap_get_param(at_ble_parameters_t param,
1569 uint8_t* value_buff, uint16_t value_len);
1570
1582 at_ble_status_t at_ble_whitelist_add(at_ble_addr_t* address);
1583
1592 at_ble_status_t at_ble_whitelist_remove(at_ble_addr_t* address);
1593
1601 at_ble_status_t at_ble_whitelist_clear(void);
1602
1621 at_ble_status_t at_ble_adv_data_set( uint8_t const *const adv_data,
1622 uint8_t adv_data_len,
1623 uint8_t const *const scan_resp_data,
1624 uint8_t scan_response_data_len
1625 );
1626
1627
1648 at_ble_status_t at_ble_adv_start(at_ble_adv_type_t type,at_ble_adv_mode_t mode ,
1649 at_ble_addr_t* peer_addr, at_ble_filter_type_t filtered,
1650 uint16_t interval, uint16_t timeout, bool disable_randomness);
1651
1652
1653
1659 at_ble_status_t at_ble_adv_stop(void);
1660
1671 at_ble_status_t at_ble_adv_set_tx_power(int8_t power);
1672
1697 at_ble_status_t at_ble_scan_start(uint16_t interval, uint16_t window,
1698 uint16_t timeout, at_ble_scan_type_t type ,at_ble_scan_mode_t mode,
1699 bool filter_whitelist, bool filter_duplicates);
1700
1706 at_ble_status_t at_ble_scan_stop(void);
1707
1725 at_ble_status_t at_ble_connect(at_ble_addr_t peers[], uint8_t peer_count,
1726 uint16_t scan_interval, uint16_t scan_window, at_ble_connection_params_t* connection_params);
1727
1733 at_ble_status_t at_ble_connect_cancel(void);
1734
1745 at_ble_status_t at_ble_sec_info_set(at_ble_handle_t handle, at_ble_signature_info_t signature_info, at_ble_auth_t authen, at_ble_author_t author);
1746
1757 at_ble_status_t at_ble_disconnect(at_ble_handle_t handle, at_ble_disconnect_reason_t reason);
1758
1759
1772 at_ble_status_t at_ble_connection_param_update(at_ble_handle_t handle,
1773 at_ble_connection_params_t* connection_params);
1774
1784 void at_ble_conn_update_reply(at_ble_handle_t conn_handle ,
1785 at_ble_connection_params_t* connection_params);
1786
1811 at_ble_status_t at_ble_authenticate(at_ble_handle_t conn_handle, at_ble_pair_features_t* features,
1812 at_ble_LTK_t* ltk, at_ble_CSRK_t* csrk);
1813
1823 at_ble_status_t at_ble_send_slave_sec_request(at_ble_handle_t conn_handle,bool mitm_protection,bool bond);
1824
1836 at_ble_status_t at_ble_pair_key_reply(at_ble_handle_t conn_handle, at_ble_pair_key_type_t type, uint8_t* key);
1837
1848 at_ble_status_t at_ble_encryption_start(at_ble_handle_t conn_handle, at_ble_LTK_t key ,at_ble_auth_t auth);
1849
1860 at_ble_status_t at_ble_encryption_request_reply(at_ble_handle_t conn_handle,uint8_t auth, bool key_found, at_ble_LTK_t key);
1861
1873 at_ble_status_t at_ble_random_address_resolve(uint8_t nb_key ,at_ble_addr_t* rand_addr ,uint8_t* irk_key);
1874
1885 at_ble_status_t at_ble_tx_power_set(at_ble_handle_t conn_handle, int8_t powerdBm);
1886
1893 int8_t at_ble_tx_power_get(at_ble_handle_t conn_handle);
1894
1901 int8_t at_ble_max_PA_gain_get(at_ble_handle_t conn_handle);
1902
1910 int8_t at_ble_rx_power_get(at_ble_handle_t conn_handle);
1911
1924 at_ble_status_t at_ble_rx_power_subscribe(at_ble_handle_t conn_handle, uint16_t range_max, uint16_t range_min);
1925
1926
1938 at_ble_status_t at_ble_rx_power_unsubscribe(at_ble_handle_t conn_handle);
1939
1961 at_ble_status_t at_ble_primary_service_discover_all(at_ble_handle_t conn_handle,
1962 at_ble_handle_t start_handle, at_ble_handle_t end_handle);
1963
1978 at_ble_status_t at_ble_primary_service_discover_by_uuid(at_ble_handle_t conn_handle,
1979 at_ble_handle_t start_handle, at_ble_handle_t end_handle, at_ble_uuid_t* uuid);
1980
1994 at_ble_status_t at_ble_included_service_discover_all(at_ble_handle_t conn_handle,
1995 at_ble_handle_t start_handle, at_ble_handle_t end_handle);
1996
2010 at_ble_status_t at_ble_characteristic_discover_all(at_ble_handle_t conn_handle,
2011 at_ble_handle_t start_handle, at_ble_handle_t end_handle);
2012
2027 at_ble_status_t at_ble_characteristic_discover_by_uuid(at_ble_handle_t conn_handle,
2028 at_ble_handle_t start_handle, at_ble_handle_t end_handle, at_ble_uuid_t* uuid);
2029
2043 at_ble_status_t at_ble_descriptor_discover_all(at_ble_handle_t conn_handle,
2044 at_ble_handle_t start_handle, at_ble_handle_t end_handle);
2045
2059 at_ble_status_t at_ble_characteristic_read_by_uuid(at_ble_handle_t conn_handle,
2060 at_ble_handle_t start_handle, at_ble_handle_t end_handle, at_ble_uuid_t* uuid);
2061
2075 at_ble_status_t at_ble_characteristic_read(at_ble_handle_t conn_handle, at_ble_handle_t char_handle, uint16_t offset, uint16_t length);
2076
2089 at_ble_status_t at_ble_characteristic_read_multible(at_ble_handle_t conn_handle, at_ble_handle_t* char_handle_list, uint16_t* char_val_lenght, uint8_t char_handle_count);
2090
2091
2107 at_ble_status_t at_ble_characteristic_write(at_ble_handle_t conn_handle, at_ble_handle_t char_handle, uint16_t offset, uint16_t length, uint8_t* data,
2108 bool signed_write, bool with_response );
2109
2110
2125 at_ble_status_t at_ble_characteristic_reliable_write_prepare(at_ble_handle_t conn_handle, at_ble_handle_t char_handle, uint16_t offset, uint16_t length, uint8_t* data);
2126
2127
2138 at_ble_status_t at_ble_characteristic_reliable_write_execute(at_ble_handle_t conn_handle);
2139
2140
2150 at_ble_status_t at_ble_characteristic_reliable_write_cancel(at_ble_handle_t conn_handle);
2151
2152
2160 at_ble_status_t at_ble_exchange_mtu(at_ble_handle_t conn_handle);
2161
2183 at_ble_status_t at_ble_primary_service_define(at_ble_uuid_t* uuid, at_ble_handle_t* service_handle,
2184 at_ble_included_service_t* included_service_list, uint16_t included_service_count,
2185 at_ble_characteristic_t* charactristic_list, uint16_t charactristic_count);
2186
2204 at_ble_status_t at_ble_secondary_service_define(at_ble_uuid_t* uuid, at_ble_handle_t* service_handle,
2205 at_ble_included_service_t* included_service_list, uint16_t included_service_count,
2206 at_ble_characteristic_t* charactristic_list, uint16_t charactristic_count);
2207
2219 at_ble_status_t at_ble_characteristic_value_set(at_ble_handle_t handle, uint8_t* value, uint16_t offset, uint16_t len);
2220
2233 at_ble_status_t at_ble_characteristic_value_get(at_ble_handle_t handle, uint8_t* value, uint16_t offset, uint16_t len, uint16_t actual_read_len);
2234
2246 at_ble_status_t at_ble_notification_send(at_ble_handle_t conn_handle, at_ble_handle_t attr_handle);
2247
2259 at_ble_status_t at_ble_indication_send(at_ble_handle_t conn_handle, at_ble_handle_t attr_handle);
2260
2270 at_ble_status_t at_ble_service_changed_notification_send(at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle);
2271
2287 at_ble_status_t at_ble_read_authorize_reply(at_ble_handle_t conn_handle,
2288 at_ble_handle_t attr_handle, bool grant_authorization,
2289 bool update_value ,uint8_t* value, uint16_t offset, uint16_t len);
2290
2302 at_ble_status_t at_ble_write_authorize_reply(at_ble_handle_t conn_handle,
2303 at_ble_handle_t attr_handle, bool grant_authorization);
2304
2323 at_ble_status_t at_ble_l2cap_cid_register(at_ble_handle_t conn_handle, uint16_t cid);
2324
2335 at_ble_status_t at_ble_l2cap_cid_unregister(at_ble_handle_t conn_handle, uint16_t cid);
2336
2349 at_ble_status_t at_ble_l2cap_tx(at_ble_handle_t conn_handle, uint16_t cid, uint8_t* data, uint16_t len);
2350
2374 at_ble_status_t at_ble_htpt_create_db(at_ble_htpt_db_config_flag features,
2375 at_ble_htpt_temp_type temp_type,
2376 uint16_t valid_range_min,
2377 uint16_t valid_range_max,
2378 uint16_t meas_intv,
2379 at_ble_htpt_sec_level sec_lvl
2380 );
2381
2382
2392 at_ble_status_t at_ble_htpt_enable( at_ble_handle_t conn_handle,
2393 at_ble_htpt_ntf_ind_cfg ntf_ind_cfg
2394 );
2395
2396
2409 at_ble_status_t at_ble_htpt_temp_send( uint32_t temp,
2410 at_ble_prf_date_time_t* time_stamp,
2411 at_ble_htpt_temp_flags flags,
2412 at_ble_htpt_temp_type type,
2413 bool flag_stable_meas);
2414
2415
2426 at_ble_status_t at_ble_htpt_meas_intv_update(uint16_t meas_intv);
2427
2430 /* utility functions, might be removed later*/
2431 static uint8_t at_ble_uuid_type2len(at_ble_uuid_type_t type)
2432 {
2433 switch(type)
2434 {
2435 case AT_BLE_UUID_16 :
2436 return AT_BLE_UUID_16_LEN;
2437
2438 case AT_BLE_UUID_32 :
2439 return AT_BLE_UUID_32_LEN;
2440
2441 default:
2442 case AT_BLE_UUID_128 :
2443 return AT_BLE_UUID_128_LEN;
2444 }
2445 }
2446
2447 static at_ble_uuid_type_t at_ble_uuid_len2type(uint8_t len)
2448 {
2449 switch(len)
2450 {
2451 case AT_BLE_UUID_16_LEN:
2452 return AT_BLE_UUID_16;
2453
2454 case AT_BLE_UUID_32_LEN :
2455 return AT_BLE_UUID_32;
2456
2457 default:
2458 case AT_BLE_UUID_128_LEN :
2459 return AT_BLE_UUID_128;
2460 }
2461 }
2462
2463 #endif //__AT_BLE_API_H__
AT_BLE_GAP_CONN_ADV_INT_MAX
Maximum advertising interval, when in Connectable mode (n * 0.625 mSec)
Definition: at_ble_api.h:163
AT_BLE_HTPT_TEMP_SEND_CFM
Definition: at_ble_api.h:367
at_ble_pair_features_t::io_cababilities
at_ble_iocab_t io_cababilities
Definition: at_ble_api.h:950
at_ble_conn_param_update_done_t::superv_to
uint16_t superv_to
Definition: at_ble_api.h:1048
at_ble_gap_whitelist_t::irkCount
uint8_t irkCount
Definition: at_ble_api.h:859
AT_BLE_KEY_DIST_ENC
Definition: at_ble_api.h:462
at_ble_included_service_t
Service Definition.
Definition: at_ble_api.h:938
at_ble_char_presentation_t::name_space
uint8_t name_space
Definition: at_ble_api.h:904
AT_BLE_GAP_CONN_HIGH_SCAN_INT
Scan interval used during Link Layer Initiating state, when in Connectable mode, high duty scan cycle...
Definition: at_ble_api.h:166
at_ble_resolv_rand_addr_status_t
Definition: at_ble_api.h:1137
AT_BLE_ATTR_WRITABLE_REQ_AUTHN_NO_AUTHR
Definition: at_ble_api.h:574
at_ble_pair_done_t::status
at_ble_status_t status
Definition: at_ble_api.h:1090
AT_BLE_ADV_MAX_SIZE
#define AT_BLE_ADV_MAX_SIZE
Maximum size of advertising data in octets.
Definition: at_ble_api.h:72
AT_BLE_UUID_32_LEN
#define AT_BLE_UUID_32_LEN
UUID 32 size in bytes.
Definition: at_ble_api.h:78
at_ble_htpt_cfg_indntf_ind_t::cfg_val
uint16_t cfg_val
Stop/notify/indicate value to configure into the peer characteristic.
Definition: at_ble_api.h:1352
at_ble_init
at_ble_status_t at_ble_init(void *args)
Reset the link layer and the host.
at_ble_event_get
at_ble_status_t at_ble_event_get(at_ble_events_t *event, void *params, uint32_t timeout)
extracts the next event form the event queue
at_ble_event_parameter_t::at_ble_tx_power_set_t
at_ble_tx_power_set_t at_ble_tx_power_set_t
Definition: at_ble_api.h:1388
at_ble_passkey_type_t
at_ble_passkey_type_t
Passkey Types.
Definition: at_ble_api.h:623
HTPT_MEAS_INTV_CHAR
Definition: at_ble_api.h:729
AT_BLE_MODE1_L1_NOAUTH_PAIR_ENC
Definition: at_ble_api.h:480
AT_BLE_ADDR_LEN
#define AT_BLE_ADDR_LEN
BLE address length.
Definition: at_ble_api.h:55
AT_BLE_PAIR_PASSKEY_ENTRY
Definition: at_ble_api.h:626
at_ble_htpt_meas_intv_chg_ind_t
Parameters of the AT_BLE_HTPT_MEAS_INTV_CHG_IND message.
Definition: at_ble_api.h:1340
at_ble_event_parameter_t::at_ble_pair_done_t
at_ble_pair_done_t at_ble_pair_done_t
Definition: at_ble_api.h:1389
at_ble_scan_type_t
at_ble_scan_type_t
Scan types used at at_ble_scan_start.
Definition: at_ble_api.h:556
at_ble_max_PA_gain_value_t::handle
at_ble_handle_t handle
Definition: at_ble_api.h:1068
at_ble_included_service_found_t::end_handle
at_ble_handle_t end_handle
Definition: at_ble_api.h:1165
HTP_TYPE_EAR
Ear (usually ear lobe)
Definition: at_ble_api.h:758
AT_BLE_CONNECTED
Definition: at_ble_api.h:236
AT_BLE_PAIR_OOB
Definition: at_ble_api.h:618
AT_BLE_PRES_FORMAT_SINT16
Definition: at_ble_api.h:596
AT_BLE_GAP_GEN_DISC_ADV_INT_MIN
Minimum advertising interval, when in General discoverable mode (n * 0.625 mSec)
Definition: at_ble_api.h:160
at_ble_slave_sec_request_t::handle
at_ble_handle_t handle
Definition: at_ble_api.h:1114
at_ble_scan_report_t::status
at_ble_status_t status
Definition: at_ble_api.h:1016
at_ble_primary_service_define
at_ble_status_t at_ble_primary_service_define(at_ble_uuid_t *uuid, at_ble_handle_t *service_handle, at_ble_included_service_t *included_service_list, uint16_t included_service_count, at_ble_characteristic_t *charactristic_list, uint16_t charactristic_count)
Defines a new Primary service along with its included services and characteristics.
AT_BLE_IO_CAP_KB_ONLY
Definition: at_ble_api.h:448
AT_BLE_ATTR_WRITABLE_REQ_AUTHN_REQ_AUTHR
Definition: at_ble_api.h:576
at_ble_connect_cancel
at_ble_status_t at_ble_connect_cancel(void)
Cancels an ongoing connection attempt.
AT_BLE_PAIR_PASSKEY
Definition: at_ble_api.h:616
at_ble_resolv_rand_addr_status_t::status
at_ble_status_t status
Definition: at_ble_api.h:1139
at_ble_primary_service_found_t::start_handle
at_ble_handle_t start_handle
Definition: at_ble_api.h:1154
at_ble_secondary_service_define
at_ble_status_t at_ble_secondary_service_define(at_ble_uuid_t *uuid, at_ble_handle_t *service_handle, at_ble_included_service_t *included_service_list, uint16_t included_service_count, at_ble_characteristic_t *charactristic_list, uint16_t charactristic_count)
Defines a new Secondary service along with its included services and characteristics.
AT_BLE_GAP_CONN_SCAN_INT
Scan interval used during Link Layer Initiating state, when in Connectable mode (n * 0...
Definition: at_ble_api.h:164
AT_BLE_DESCRIPTOR_FOUND
Definition: at_ble_api.h:298
AT_BLE_SCAN_INFO
Definition: at_ble_api.h:224
at_ble_LTK_t::ediv
uint16_t ediv
Encryption Diversifier.
Definition: at_ble_api.h:968
AT_BLE_PRIMARY_SERVICE_FOUND
Definition: at_ble_api.h:286
at_ble_CSRK_t
Connection Signature Resolution Key.
Definition: at_ble_api.h:978
at_ble_adv_start
at_ble_status_t at_ble_adv_start(at_ble_adv_type_t type, at_ble_adv_mode_t mode, at_ble_addr_t *peer_addr, at_ble_filter_type_t filtered, uint16_t interval, uint16_t timeout, bool disable_randomness)
Start advertising (GAP Discoverable, Connectable modes, Broadcast Procedure).
at_ble_htpt_temp_send_cfm_t::status
uint8_t status
Status.
Definition: at_ble_api.h:1333
AT_BLE_PRES_FORMAT_NIBBLE
Definition: at_ble_api.h:585
AT_BLE_KEY_DIS_ALL
Definition: at_ble_api.h:468
at_ble_event_parameter_t::at_ble_signature_info_t
at_ble_signature_info_t at_ble_signature_info_t
Definition: at_ble_api.h:1377
at_ble_primary_service_discover_by_uuid
at_ble_status_t at_ble_primary_service_discover_by_uuid(at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle, at_ble_uuid_t *uuid)
Discover all Primary services of a given UUID declared in a connected device.
at_ble_adv_set_tx_power
at_ble_status_t at_ble_adv_set_tx_power(int8_t power)
Set the Advertising transmission power.
at_ble_htpt_cfg_indntf_ind_t::conhdl
uint16_t conhdl
Connection handle.
Definition: at_ble_api.h:1350
HTPT_INTERM_TEMP_CHAR_SUP
Indicate if Intermediate Temperature Char. is supported.
Definition: at_ble_api.h:695
at_ble_l2cap_rx_t::data
uint8_t * data
Definition: at_ble_api.h:1268
at_ble_notification_recieved_t
Definition: at_ble_api.h:1206
at_ble_tx_power_get
int8_t at_ble_tx_power_get(at_ble_handle_t conn_handle)
Gets TX power of a given connection.
at_ble_event_parameter_t::at_ble_rx_power_value_t
at_ble_rx_power_value_t at_ble_rx_power_value_t
Definition: at_ble_api.h:1385
at_ble_prf_date_time_t
Time profile information.
Definition: at_ble_api.h:1284
at_ble_pair_done_t::peer_ltk
at_ble_LTK_t peer_ltk
Definition: at_ble_api.h:1091
at_ble_characteristic_t
Characteristic structure.
Definition: at_ble_api.h:911
AT_BLE_SLAVE_SEC_REQUEST
Definition: at_ble_api.h:264
at_ble_event_parameter_t::at_ble_characteristic_t
at_ble_characteristic_t at_ble_characteristic_t
Definition: at_ble_api.h:1371
at_ble_event_parameter_t::at_ble_addr_t
at_ble_addr_t at_ble_addr_t
Definition: at_ble_api.h:1363
at_ble_characteristic_found_t::conn_handle
at_ble_handle_t conn_handle
Definition: at_ble_api.h:1172
at_ble_indication_recieved_t::conn_handle
at_ble_handle_t conn_handle
Definition: at_ble_api.h:1216
HTPT_NORMAL_CONN
Definition: at_ble_api.h:778
at_ble_event_parameter_t::at_ble_characteristic_write_response_t
at_ble_characteristic_write_response_t at_ble_characteristic_write_response_t
Definition: at_ble_api.h:1402
AT_BLE_MAX_KEY_LEN
#define AT_BLE_MAX_KEY_LEN
BLE security key maximum length.
Definition: at_ble_api.h:58
AT_BLE_INSUFF_RESOURCE
Resources not sufficient to complete the request.
Definition: at_ble_api.h:138
at_ble_pair_features_t::oob_avaiable
bool oob_avaiable
Definition: at_ble_api.h:953
at_ble_rx_power_value_t::rx_value
uint16_t rx_value
Definition: at_ble_api.h:1062
at_ble_htpt_temp_send_cfm_t::conhdl
uint16_t conhdl
Connection handle.
Definition: at_ble_api.h:1331
HTPT_CHAR_MAX
Definition: at_ble_api.h:731
AT_BLE_GAP_CONN_EST_ADV
Advertising interval, when using Connection Establishment proc (n * 0.625 mSec). Obsolete - Do not us...
Definition: at_ble_api.h:172
AT_BLE_CHARACTERISTIC_CHANGED
Definition: at_ble_api.h:332
at_ble_addr_t::type
at_ble_addr_type_t type
Definition: at_ble_api.h:817
AT_BLE_ADV_GEN_DISCOVERABLE
Mode in general discoverable, AD type general flag in Flags set to 1.
Definition: at_ble_api.h:536
HTPT_DISABLE
Service can be browsed but attributes cannot be accessed.
Definition: at_ble_api.h:713
at_ble_l2cap_tx
at_ble_status_t at_ble_l2cap_tx(at_ble_handle_t conn_handle, uint16_t cid, uint8_t *data, uint16_t len)
Sends a custom L2CAP message using the given CID.
AT_BLE_PRES_FORMAT_SINT128
Definition: at_ble_api.h:601
at_ble_characteristic_found_t::properties
uint8_t properties
Definition: at_ble_api.h:1175
at_ble_l2cap_rx_t::len
uint16_t len
Definition: at_ble_api.h:1267
AT_BLE_TIMEOUT
Time-out.
Definition: at_ble_api.h:142
at_ble_htpt_sec_level
at_ble_htpt_sec_level
Health Thermometer Service Security Level.
Definition: at_ble_api.h:710
at_ble_uuid_type_t
at_ble_uuid_type_t
UUID Type.
Definition: at_ble_api.h:492
AT_BLE_INVALID_STATE
Operation disallowed in this state.
Definition: at_ble_api.h:134
AT_BLE_CHARACTERISTIC_READ_MULTIBLE_RESPONSE
Definition: at_ble_api.h:310
at_ble_event_parameter_t::at_ble_slave_sec_request_t
at_ble_slave_sec_request_t at_ble_slave_sec_request_t
Definition: at_ble_api.h:1392
AT_BLE_INVALID_HANDLE
Invalid attribute handle.
Definition: at_ble_api.h:136
at_ble_max_PA_gain_get
int8_t at_ble_max_PA_gain_get(at_ble_handle_t conn_handle)
Gets maximum allowed TX gain of a given connection.
AT_BLE_DISCOVERY_SUCCESS
GATTC discover operation complete.
Definition: at_ble_api.h:683
at_ble_spcp_t::superv_to
uint16_t superv_to
Slave preferred Link supervision time-out.
Definition: at_ble_api.h:840
at_ble_characteristic_read_response_t::char_handle
at_ble_handle_t char_handle
Definition: at_ble_api.h:1192
at_ble_event_parameter_t::at_ble_rand_addr_changed_t
at_ble_rand_addr_changed_t at_ble_rand_addr_changed_t
Definition: at_ble_api.h:1381
at_ble_gap_deviceinfo_t::spcp_param
at_ble_spcp_t spcp_param
Slave preferred connection parameters.
Definition: at_ble_api.h:846
at_ble_handle_t
uint16_t at_ble_handle_t
Definition: at_ble_api.h:114
HTPT_CFG_MEAS_INTV_IND
Measurement interval indication.
Definition: at_ble_api.h:803
AT_BLE_UUID_16_LEN
#define AT_BLE_UUID_16_LEN
UUID 16 size in bytes.
Definition: at_ble_api.h:75
at_ble_pair_features_t::mitm_protection
bool mitm_protection
Definition: at_ble_api.h:951
at_ble_conn_param_update_done_t::status
at_ble_status_t status
Definition: at_ble_api.h:1045
at_ble_conn_param_update_request_t::params
at_ble_connection_params_t params
Definition: at_ble_api.h:1055
AT_BLE_ADV_FP_ANY
Definition: at_ble_api.h:521
at_ble_characteristic_t::value_permissions
at_ble_attr_permissions_t value_permissions
Definition: at_ble_api.h:920
at_ble_prf_con_type_t
at_ble_prf_con_type_t
Connection type.
Definition: at_ble_api.h:671
at_ble_pair_features_t::max_key_size
uint8_t max_key_size
Definition: at_ble_api.h:955
at_ble_gattc_discovery_complete_status_t
at_ble_gattc_discovery_complete_status_t
Discovery status.
Definition: at_ble_api.h:680
AT_BLE_MODE2_L2_AUTH_DATA_SGN
Definition: at_ble_api.h:486
AT_BLE_RX_POWER_VALUE
Definition: at_ble_api.h:252
AT_BLE_KEY_DIST_NONE
Definition: at_ble_api.h:460
at_ble_addr_t
Blue-tooth Low Energy address Type.
Definition: at_ble_api.h:815
at_ble_included_service_found_t
Definition: at_ble_api.h:1160
at_ble_rx_power_subscribe
at_ble_status_t at_ble_rx_power_subscribe(at_ble_handle_t conn_handle, uint16_t range_max, uint16_t range_min)
Subscribes for RX power level notifications.
AT_BLE_UUID_32
Definition: at_ble_api.h:496
at_ble_included_service_t::service_handle
at_ble_handle_t service_handle
Definition: at_ble_api.h:941
at_ble_event_parameter_t::at_ble_tx_power_value_t
at_ble_tx_power_value_t at_ble_tx_power_value_t
Definition: at_ble_api.h:1387
at_ble_encryption_status_changed_t::handle
at_ble_handle_t handle
Definition: at_ble_api.h:1132
at_ble_encryption_status_changed_t
Definition: at_ble_api.h:1130
at_ble_event_parameter_t::at_ble_pair_key_request_t
at_ble_pair_key_request_t at_ble_pair_key_request_t
Definition: at_ble_api.h:1391
AT_BLE_CHAR_WRITE_WITHOUT_RESPONSE
Definition: at_ble_api.h:508
AT_BLE_PRES_FORMAT_SINT48
Definition: at_ble_api.h:599
at_ble_conn_param_update_done_t::con_latency
uint16_t con_latency
Definition: at_ble_api.h:1047
at_ble_pair_features_t::responder_keys
at_ble_key_dis_t responder_keys
Definition: at_ble_api.h:957
at_ble_discovery_complete_t::status
at_ble_gattc_discovery_complete_status_t status
Definition: at_ble_api.h:1148
AT_BLE_CHAR_BROADCST
Definition: at_ble_api.h:506
at_ble_event_parameter_t::at_ble_scan_info_t
at_ble_scan_info_t at_ble_scan_info_t
Definition: at_ble_api.h:1378
at_ble_characteristic_t::user_desc_len
uint16_t user_desc_len
Definition: at_ble_api.h:923
at_ble_event_parameter_t::at_ble_uuid_t
at_ble_uuid_t at_ble_uuid_t
Definition: at_ble_api.h:1369
AT_BLE_COMMAND_DISALLOWED
Request not allowed in current state.
Definition: at_ble_api.h:132
at_ble_read_authorize_request_t::char_handle
at_ble_handle_t char_handle
Definition: at_ble_api.h:1258
at_ble_connected_t
AT_BLE_CONNECTED message format. This message is sent to the APP when the link request is complete...
Definition: at_ble_api.h:1021
HTPT_FLAG_FAHRENHEIT
Temperature Units Flag - Fahrenheit.
Definition: at_ble_api.h:741
AT_BLE_ADV_TYPE_DIRECTED
Definition: at_ble_api.h:208
AT_BLE_PRES_FORMAT_UINT16
Definition: at_ble_api.h:588
at_ble_rx_power_value_t::handle
at_ble_handle_t handle
Definition: at_ble_api.h:1061
at_ble_att_write_perm_t
at_ble_att_write_perm_t
Write access.
Definition: at_ble_api.h:658
at_ble_indication_confirmed_t::status
at_ble_status_t status
Definition: at_ble_api.h:1226
at_ble_indication_confirmed_t::conn_handle
at_ble_handle_t conn_handle
Definition: at_ble_api.h:1224
AT_BLE_UUID_16
Definition: at_ble_api.h:494
AT_BLE_GAP_CONN_HIGH_SCAN_WIND
Scan window used during Link Layer Initiating state, when in Connectable mode, high duty scan cycle s...
Definition: at_ble_api.h:167
at_ble_event_parameter_t::at_ble_included_service_found_t
at_ble_included_service_found_t at_ble_included_service_found_t
Definition: at_ble_api.h:1398
at_ble_pair_key_request_t::type
at_ble_pair_key_type_t type
Definition: at_ble_api.h:1107
HTP_TYPE_TYMPANUM
Tympanum (ear drum)
Definition: at_ble_api.h:770
AT_BLE_CHAR_NOTIFY
Definition: at_ble_api.h:510
at_ble_characteristic_changed_t::status
at_ble_status_t status
Definition: at_ble_api.h:1237
HTPT_INTERM_TEMP_CHAR
Definition: at_ble_api.h:728
at_ble_characteristic_t::uuid
at_ble_uuid_t uuid
Definition: at_ble_api.h:914
AT_BLE_ADV_FP_FILTER_SCANREQ
Definition: at_ble_api.h:523
AT_BLE_PRES_FORMAT_SINT8
Definition: at_ble_api.h:594
at_ble_device_name_set
at_ble_status_t at_ble_device_name_set(uint8_t *dev_name, uint8_t len)
Set device name.
at_ble_char_presentation_t::exponent
int8_t exponent
Definition: at_ble_api.h:902
at_ble_event_parameter_t::at_ble_pair_request_t
at_ble_pair_request_t at_ble_pair_request_t
Definition: at_ble_api.h:1390
at_ble_connection_params_t::con_intv_min
uint16_t con_intv_min
Minimum of connection interval.
Definition: at_ble_api.h:868
at_ble_pair_request_t::handle
at_ble_handle_t handle
Definition: at_ble_api.h:1099
AT_BLE_ATTR_WRITABLE_NO_AUTHN_REQ_AUTHR
Definition: at_ble_api.h:575
AT_BLE_PRIVACY_CFG_PB
Problem with privacy configuration.
Definition: at_ble_api.h:130
at_ble_encryption_request_t
Definition: at_ble_api.h:1120
HTPT_UNAUTH
Service can be used with minimum Unauthenticated Link (Just Work Pairing)
Definition: at_ble_api.h:717
AT_BLE_ADV_FP_FILTER_CONNREQ
Definition: at_ble_api.h:525
at_ble_gap_whitelist_t::ppIrks
at_ble_gap_irk_t ** ppIrks
Definition: at_ble_api.h:858
AT_BLE_AUTH_NO_MITM_BOND
Definition: at_ble_api.h:638
AT_BLE_UUID_128
Definition: at_ble_api.h:498
at_ble_random_address_resolve
at_ble_status_t at_ble_random_address_resolve(uint8_t nb_key, at_ble_addr_t *rand_addr, uint8_t *irk_key)
Handles request of resolving a resolvable random address ,AT_BLE_RESOLV_RAND_ADDR_STATUS event is use...
HTPT_MEAS_INTV_IND_SUP
Indicate if Measurement Interval Char. supports indications.
Definition: at_ble_api.h:699
AT_BLE_IO_CAP_NO_INPUT_NO_OUTPUT
Definition: at_ble_api.h:450
at_ble_event_parameter_t::at_ble_primary_service_found_t
at_ble_primary_service_found_t at_ble_primary_service_found_t
Definition: at_ble_api.h:1397
AT_BLE_CHARACTERISTIC_FOUND
Definition: at_ble_api.h:294
at_ble_characteristic_t::server_config_handle
at_ble_handle_t server_config_handle
Definition: at_ble_api.h:930
AT_BLE_CHAR_SIGNED_WRITE
Definition: at_ble_api.h:512
at_ble_pair_request_t
Definition: at_ble_api.h:1097
at_ble_connection_params_t::con_latency
uint16_t con_latency
Connection latency.
Definition: at_ble_api.h:872
AT_BLE_KEY_DIST_ID
Definition: at_ble_api.h:464
at_ble_IRK_t
Definition: at_ble_api.h:983
AT_BLE_GAP_GEN_DISC_SCAN
Minimum time to perform scanning, when performing General Discovery proc (mSec)
Definition: at_ble_api.h:152
at_ble_event_parameter_t::at_ble_included_service_t
at_ble_included_service_t at_ble_included_service_t
Definition: at_ble_api.h:1372
at_ble_slave_sec_request_t::mitm_protection
bool mitm_protection
Definition: at_ble_api.h:1116
at_ble_event_user_defined_post
at_ble_status_t at_ble_event_user_defined_post(void *params)
Posts a user defined custom event into the event queue, allowing the user code to process other event...
AT_BLE_IO_CAP_KB_DISPLAY
Definition: at_ble_api.h:452
at_ble_characteristic_t::presentation_format
at_ble_char_presentation_t * presentation_format
Definition: at_ble_api.h:932
AT_BLE_TX_POWER_SET
Definition: at_ble_api.h:398
at_ble_prf_date_time_t::hour
uint8_t hour
hour time element
Definition: at_ble_api.h:1293
AT_BLE_PRES_FORMAT_FLOAT32
Definition: at_ble_api.h:602
at_ble_descriptor_found_t::conn_handle
at_ble_handle_t conn_handle
Definition: at_ble_api.h:1182
AT_BLE_GAP_LIM_ADV_TIMEOUT
Maximum time to remain advertising, when in Limited Discoverable mode. In seconds (default 180 second...
Definition: at_ble_api.h:151
at_ble_whitelist_add
at_ble_status_t at_ble_whitelist_add(at_ble_addr_t *address)
Adds a peer device address to the white-list.
AT_BLE_ADV_BROADCASTER_MODE
Broadcaster mode which is a non discoverable and non connectable mode.
Definition: at_ble_api.h:540
at_ble_htpt_enable
at_ble_status_t at_ble_htpt_enable(at_ble_handle_t conn_handle, at_ble_htpt_ntf_ind_cfg ntf_ind_cfg)
This API message is used for enabling the Thermometer role of the Health Thermometer profile...
at_ble_write_authorize_request_t::status
at_ble_status_t status
Definition: at_ble_api.h:1251
AT_BLE_WRITE_UNAUTH
Definition: at_ble_api.h:665
at_ble_event_parameter_t::at_ble_htpt_disable_ind_t
at_ble_htpt_disable_ind_t at_ble_htpt_disable_ind_t
Definition: at_ble_api.h:1414
at_ble_characteristic_discover_all
at_ble_status_t at_ble_characteristic_discover_all(at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle)
Discover all Characteristics declared in a connected device.
at_ble_characteristic_t::user_desc_permissions
at_ble_attr_permissions_t user_desc_permissions
Definition: at_ble_api.h:925
at_ble_characteristic_write_response_t::char_handle
at_ble_handle_t char_handle
Definition: at_ble_api.h:1201
at_ble_disconnected_t::handle
at_ble_handle_t handle
Definition: at_ble_api.h:1037
at_ble_characteristic_write_response_t::conn_handle
at_ble_handle_t conn_handle
Definition: at_ble_api.h:1200
HTPT_FLAG_TIME
Time Stamp Flag.
Definition: at_ble_api.h:743
at_ble_max_PA_gain_value_t::max_PA_gain_value
uint16_t max_PA_gain_value
Definition: at_ble_api.h:1069
AT_BLE_PRES_FORMAT_SINT64
Definition: at_ble_api.h:600
at_ble_adv_stop
at_ble_status_t at_ble_adv_stop(void)
Stop advertising (GAP Discoverable, Connectable modes, Broadcast Procedure).
AT_BLE_PRES_FORMAT_FLOAT64
Definition: at_ble_api.h:603
AT_BLE_INVALID_ATTRIBUTE_VAL_LEN
Invalid length of the attribute value.
Definition: at_ble_api.h:140
at_ble_LTK_t
Long Term Key.
Definition: at_ble_api.h:963
at_ble_write_authorize_reply
at_ble_status_t at_ble_write_authorize_reply(at_ble_handle_t conn_handle, at_ble_handle_t attr_handle, bool grant_authorization)
Replies to a write authorization request requested by by AT_BLE_WRITE_AUTHORIZE_REQUEST event...
at_ble_htpt_temp_send_cfm_t
Parameters of the AT_BLE_HTPT_TEMP_SEND_CFM message.
Definition: at_ble_api.h:1328
AT_BLE_ADDRESS_RANDOM_PRIVATE_NON_RESOLVABLE
Definition: at_ble_api.h:426
AT_BLE_PAIR_KEY_REQUEST
Definition: at_ble_api.h:268
at_ble_gap_whitelist_t
White-list structure.
Definition: at_ble_api.h:854
AT_BLE_PRES_FORMAT_UTF8S
Definition: at_ble_api.h:607
AT_BLE_SERVICE_CHANGED_NOTIFICATION_CONFIRMED
Definition: at_ble_api.h:336
at_ble_char_presentation_t::description
uint16_t description
Definition: at_ble_api.h:905
HTPT_ALL_FEAT_SUP
All Features supported.
Definition: at_ble_api.h:704
AT_BLE_ADV_TYPE_SCAN_RESPONSE
Definition: at_ble_api.h:211
at_ble_event_parameter_t::at_ble_htpt_temp_send_cfm_t
at_ble_htpt_temp_send_cfm_t at_ble_htpt_temp_send_cfm_t
Definition: at_ble_api.h:1415
at_ble_event_parameter_t::at_ble_htpt_create_db_cfm_t
at_ble_htpt_create_db_cfm_t at_ble_htpt_create_db_cfm_t
Definition: at_ble_api.h:1413
HTP_TYPE_BODY
Body (general)
Definition: at_ble_api.h:756
at_ble_connection_params_t::con_intv_max
uint16_t con_intv_max
Maximum of connection interval.
Definition: at_ble_api.h:870
AT_BLE_CONN_PARAM_UPDATE_DONE
Definition: at_ble_api.h:244
AT_BLE_NOTIFICATION_CONFIRMED
Definition: at_ble_api.h:411
AT_BLE_ADV_LIM_DISCOVERABLE
Mode in limited discoverable, AD type limited flag in Flags set to 1 (This mode is automatically stop...
Definition: at_ble_api.h:538
at_ble_event_parameter_t::at_ble_characteristic_found_t
at_ble_characteristic_found_t at_ble_characteristic_found_t
Definition: at_ble_api.h:1399
AT_BLE_UUID_128_LEN
#define AT_BLE_UUID_128_LEN
UUID 128 size in bytes.
Definition: at_ble_api.h:81
AT_BLE_WRITE_DISABLE
Definition: at_ble_api.h:661
at_ble_descriptor_found_t::desc_uuid
at_ble_uuid_t desc_uuid
Definition: at_ble_api.h:1184
AT_BLE_PAIR_PASSKEY_DISPLAY
Definition: at_ble_api.h:628
AT_BLE_PRES_FORMAT_FLOAT
Definition: at_ble_api.h:605
at_ble_event_parameter_t::at_ble_read_authorize_request_t
at_ble_read_authorize_request_t at_ble_read_authorize_request_t
Definition: at_ble_api.h:1409
at_ble_descriptor_found_t::desc_handle
at_ble_handle_t desc_handle
Definition: at_ble_api.h:1183
at_ble_notification_send
at_ble_status_t at_ble_notification_send(at_ble_handle_t conn_handle, at_ble_handle_t attr_handle)
Sends a Notification.
at_ble_encryption_request_reply
at_ble_status_t at_ble_encryption_request_reply(at_ble_handle_t conn_handle, uint8_t auth, bool key_found, at_ble_LTK_t key)
Responds to encryption start request from master device AT_BLE_ENCRYPTION_REQUEST ...
at_ble_prf_server_error_ind_t::conhdl
uint16_t conhdl
Connection Handle.
Definition: at_ble_api.h:1277
at_ble_gap_deviceinfo_t::dev_name_perm
at_ble_att_write_perm_t dev_name_perm
Device name write permission for peer device.
Definition: at_ble_api.h:850
at_ble_encryption_request_t::ediv
uint16_t ediv
Encryption Diversifier.
Definition: at_ble_api.h:1124
at_ble_char_presentation_t::format
at_ble_char_pres_format_t format
Definition: at_ble_api.h:901
at_ble_characteristic_write_response_t::status
at_ble_status_t status
Definition: at_ble_api.h:1202
at_ble_htpt_cfg_indntf_ind_t
Parameters of the AT_BLE_HTPT_CFG_INDNTF_IND message.
Definition: at_ble_api.h:1347
at_ble_gap_get_param
at_ble_status_t at_ble_gap_get_param(at_ble_parameters_t param, uint8_t *value_buff, uint16_t value_len)
Fetch a GAP Parameter value.
AT_BLE_GAP_CONN_SCAN_WIND
Scan window used during Link Layer Initiating state, when in Connectable mode (n * 0...
Definition: at_ble_api.h:165
at_ble_characteristic_read_by_uuid
at_ble_status_t at_ble_characteristic_read_by_uuid(at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle, at_ble_uuid_t *uuid)
Read a characteristic given its UUID.
at_ble_prf_server_error_ind_t::status
uint8_t status
Status.
Definition: at_ble_api.h:1281
AT_BLE_ENCRYPTION_STATUS_CHANGED
Definition: at_ble_api.h:276
at_ble_htpt_disable_ind_t::meas_intv
uint16_t meas_intv
Measurement interval.
Definition: at_ble_api.h:1323
at_ble_included_service_found_t::attr_handle
at_ble_handle_t attr_handle
Definition: at_ble_api.h:1163
at_ble_l2cap_rx_t
Definition: at_ble_api.h:1263
HTP_TYPE_ARMPIT
Armpit.
Definition: at_ble_api.h:754
at_ble_set_gap_deviceinfo
at_ble_status_t at_ble_set_gap_deviceinfo(at_ble_gap_deviceinfo_t *gap_deviceinfo)
Set GAP attribute data base in BLE API (Appearance , slave preferred connection parameters ...
at_ble_events_t
at_ble_events_t
Events delivered from BLE stack to the application layer.
Definition: at_ble_api.h:217
at_ble_spcp_t::con_intv_min
uint16_t con_intv_min
Slave preferred minimum connection interval.
Definition: at_ble_api.h:834
at_ble_pair_done_t::peer_csrk
at_ble_CSRK_t peer_csrk
Definition: at_ble_api.h:1092
at_ble_scan_report_t
Definition: at_ble_api.h:1014
at_ble_characteristic_t::char_val_handle
at_ble_handle_t char_val_handle
Definition: at_ble_api.h:913
AT_BLE_ATTR_NO_PERMISSIONS
Definition: at_ble_api.h:566
at_ble_characteristic_t::client_config_permissions
at_ble_attr_permissions_t client_config_permissions
Definition: at_ble_api.h:926
at_ble_addr_get
at_ble_status_t at_ble_addr_get(at_ble_addr_t *address)
Get device public BT Address.
at_ble_pair_features_t
Pairing Features.
Definition: at_ble_api.h:948
AT_BLE_TERMINATED_BY_USER
Definition: at_ble_api.h:436
AT_BLE_SCAN_PASSIVE
Definition: at_ble_api.h:558
AT_BLE_FAILURE
Failure.
Definition: at_ble_api.h:126
AT_BLE_GAP_CONN_PARAM_TIMEOUT
Link Layer connection parameter update notification timer, connection parameter update proc (mSec) ...
Definition: at_ble_api.h:155
AT_BLE_GAP_CONN_EST_SCAN_WIND
Scan window used during Link Layer Initiating state, when using Connection Establishment proc (n * 0...
Definition: at_ble_api.h:176
AT_BLE_MODE1_L2_AUTH_PAIR_ENC
Definition: at_ble_api.h:482
at_ble_included_service_discover_all
at_ble_status_t at_ble_included_service_discover_all(at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle)
Discover all included services declared in a connected device.
at_ble_characteristic_reliable_write_execute
at_ble_status_t at_ble_characteristic_reliable_write_execute(at_ble_handle_t conn_handle)
Executes a pending prepared write operation.
at_ble_gap_whitelist_t::ppAddrs
at_ble_addr_t ** ppAddrs
Definition: at_ble_api.h:856
AT_BLE_ADV_NON_DISCOVERABLE
Mode in non-discoverable.
Definition: at_ble_api.h:534
at_ble_set_dev_config
at_ble_status_t at_ble_set_dev_config(at_ble_gap_role role)
Set GAP attribute data base into BLE chip.
at_ble_scan_info_t
Definition: at_ble_api.h:1004
at_ble_char_presentation_t::unit
uint16_t unit
Definition: at_ble_api.h:903
at_ble_descriptor_discover_all
at_ble_status_t at_ble_descriptor_discover_all(at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle)
Discover all Descriptors declared in a connected device.
AT_BLE_AUTH_MITM_BOND
Definition: at_ble_api.h:642
at_ble_characteristic_found_t::value_handle
at_ble_handle_t value_handle
Definition: at_ble_api.h:1174
at_ble_read_authorize_request_t::status
at_ble_status_t status
Definition: at_ble_api.h:1259
AT_BLE_CUSTOM_EVENT
Definition: at_ble_api.h:389
at_ble_event_parameter_t::at_ble_conn_param_update_done_t
at_ble_conn_param_update_done_t at_ble_conn_param_update_done_t
Definition: at_ble_api.h:1383
AT_BLE_MTU_CHANGED_CMD_COMPLETE
Definition: at_ble_api.h:405
at_ble_char_presentation_t
Characteristic presentation format.
Definition: at_ble_api.h:899
AT_BLE_TX_POWER_VALUE
Definition: at_ble_api.h:394
AT_BLE_CHAR_RELIABLE_WRITE
Definition: at_ble_api.h:513
at_ble_signature_info_t::peer_csrk
at_ble_CSRK_t peer_csrk
Remote CSRK value.
Definition: at_ble_api.h:994
at_ble_prf_server_error_ind_t
Message structure used to inform APP that an error has occurred in the profile server role task...
Definition: at_ble_api.h:1274
at_ble_indication_send
at_ble_status_t at_ble_indication_send(at_ble_handle_t conn_handle, at_ble_handle_t attr_handle)
Sends an Indication.
AT_BLE_UUID_INVALID
Definition: at_ble_api.h:500
at_ble_IRK_t::addr
at_ble_addr_t addr
Device BD Address.
Definition: at_ble_api.h:988
AT_BLE_GAP_GEN_DISC_SCAN_WIND
Scan window used during Link Layer Scanning state, when in General Discovery proc (n * 0...
Definition: at_ble_api.h:169
at_ble_event_parameter_t::at_ble_connection_params_t
at_ble_connection_params_t at_ble_connection_params_t
Definition: at_ble_api.h:1368
AT_BLE_GAP_GEN_DISC_ADV_INT_MAX
Maximum advertising interval, when in General discoverable mode (n * 0.625 mSec)
Definition: at_ble_api.h:161
AT_BLE_AUTH_NO_MITM_NO_BOND
Definition: at_ble_api.h:636
at_ble_connection_param_update
at_ble_status_t at_ble_connection_param_update(at_ble_handle_t handle, at_ble_connection_params_t *connection_params)
Update the connection parameters of an ongoing connection.
at_ble_connected_t::conn_status
at_ble_status_t conn_status
Definition: at_ble_api.h:1025
at_ble_slave_sec_request_t
Definition: at_ble_api.h:1112
AT_BLE_GAP_PERIPHERAL_SLV
Peripheral/Slave role.
Definition: at_ble_api.h:202
at_ble_pair_done_t::handle
at_ble_handle_t handle
Definition: at_ble_api.h:1089
at_ble_event_parameter_t::at_ble_l2cap_rx_t
at_ble_l2cap_rx_t at_ble_l2cap_rx_t
Definition: at_ble_api.h:1410
HTPT_CFG_STABLE_MEAS_IND
Stable measurement interval indication enabled.
Definition: at_ble_api.h:799
AT_BLE_READ_AUTHORIZE_REQUEST
Definition: at_ble_api.h:344
AT_BLE_GAP_CONN_EST_LATENCY
Link Layer connection slave latency, when using Connection Establishment proc (in number of connectio...
Definition: at_ble_api.h:178
at_ble_event_parameter_t::at_ble_resolv_rand_addr_status_t
at_ble_resolv_rand_addr_status_t at_ble_resolv_rand_addr_status_t
Definition: at_ble_api.h:1395
at_ble_event_parameter_t::at_ble_indication_confirmed_t
at_ble_indication_confirmed_t at_ble_indication_confirmed_t
Definition: at_ble_api.h:1405
at_ble_conn_param_update_request_t::handle
at_ble_handle_t handle
Definition: at_ble_api.h:1054
at_ble_signature_info_t::local_csrk
at_ble_CSRK_t local_csrk
Local CSRK value.
Definition: at_ble_api.h:996
at_ble_pair_features_t::bond
bool bond
Definition: at_ble_api.h:952
AT_BLE_PRES_FORMAT_UINT8
Definition: at_ble_api.h:586
at_ble_characteristic_changed_t::char_offset
uint16_t char_offset
Definition: at_ble_api.h:1236
at_ble_addr_set
at_ble_status_t at_ble_addr_set(at_ble_addr_t *address)
Set the local device BT Address.
AT_BLE_GAP_OBSERVER_SCA
Observer role.
Definition: at_ble_api.h:193
AT_BLE_WIFIPROV_COMPLETE_IND
Definition: at_ble_api.h:385
AT_BLE_PRES_FORMAT_UINT24
Definition: at_ble_api.h:589
at_ble_encryption_status_changed_t::status
at_ble_status_t status
Definition: at_ble_api.h:1133
AT_BLE_PRES_FORMAT_UINT64
Definition: at_ble_api.h:592
HTPT_START_IND
Start indication.
Definition: at_ble_api.h:790
AT_BLE_PRES_FORMAT_STRUCT
Definition: at_ble_api.h:609
AT_BLE_HTPT_CFG_INDNTF_IND
Definition: at_ble_api.h:375
AT_BLE_SUCCESS
Success.
Definition: at_ble_api.h:124
at_ble_event_parameter_t::at_ble_scan_report_t
at_ble_scan_report_t at_ble_scan_report_t
Definition: at_ble_api.h:1379
at_ble_notification_recieved_t::conn_handle
at_ble_handle_t conn_handle
Definition: at_ble_api.h:1208
AT_BLE_WRITE_ENABLE
Definition: at_ble_api.h:663
at_ble_htpt_create_db_cfm_t::status
uint8_t status
Status.
Definition: at_ble_api.h:1306
at_ble_characteristic_changed_t::char_handle
at_ble_handle_t char_handle
Definition: at_ble_api.h:1233
at_ble_read_authorize_request_t
Definition: at_ble_api.h:1255
at_ble_connection_params_t::ce_len_max
uint16_t ce_len_max
Maximum CE length.
Definition: at_ble_api.h:878
at_ble_event_parameter_t::at_ble_characteristic_changed_t
at_ble_characteristic_changed_t at_ble_characteristic_changed_t
Definition: at_ble_api.h:1406
at_ble_conn_param_update_done_t::handle
at_ble_handle_t handle
Definition: at_ble_api.h:1044
at_ble_event_parameter_t::at_ble_disconnected_t
at_ble_disconnected_t at_ble_disconnected_t
Definition: at_ble_api.h:1382
at_ble_indication_confirmed_t
Definition: at_ble_api.h:1222
at_ble_htpt_temp_flags
at_ble_htpt_temp_flags
Health Thermometer Temperature Measurement Flags field bit values.
Definition: at_ble_api.h:736
at_ble_included_service_found_t::conn_handle
at_ble_handle_t conn_handle
Definition: at_ble_api.h:1162
at_ble_event_parameter_t::at_ble_htpt_cfg_indntf_ind_t
at_ble_htpt_cfg_indntf_ind_t at_ble_htpt_cfg_indntf_ind_t
Definition: at_ble_api.h:1417
at_ble_pair_features_t::initiator_keys
at_ble_key_dis_t initiator_keys
Definition: at_ble_api.h:956
at_ble_pair_done_t::auth
at_ble_auth_t auth
Definition: at_ble_api.h:1088
AT_BLE_GAP_CONN_PAUSE_CENTRAL
Central idle timer. In seconds (default 1 second)
Definition: at_ble_api.h:182
at_ble_sec_info_set
at_ble_status_t at_ble_sec_info_set(at_ble_handle_t handle, at_ble_signature_info_t signature_info, at_ble_auth_t authen, at_ble_author_t author)
Set specific link security configuration and bonding data.
at_ble_read_authorize_request_t::conn_handle
at_ble_handle_t conn_handle
Definition: at_ble_api.h:1257
at_ble_adv_mode_t
at_ble_adv_mode_t
Advertising Mode.
Definition: at_ble_api.h:532
AT_BLE_MAX_PA_GAIN_VALUE
Definition: at_ble_api.h:402
HTP_TYPE_FINGER
Finger.
Definition: at_ble_api.h:760
at_ble_prf_server_error_ind_t::msg_id
uint16_t msg_id
Message ID.
Definition: at_ble_api.h:1279
AT_BLE_GAP_GEN_DISC_SCAN_INT
Scan interval used during Link Layer Scanning state, when in General Discovery proc (n * 0...
Definition: at_ble_api.h:168
at_ble_event_parameter_t::at_ble_encryption_status_changed_t
at_ble_encryption_status_changed_t at_ble_encryption_status_changed_t
Definition: at_ble_api.h:1394
at_ble_htpt_create_db
at_ble_status_t at_ble_htpt_create_db(at_ble_htpt_db_config_flag features, at_ble_htpt_temp_type temp_type, uint16_t valid_range_min, uint16_t valid_range_max, uint16_t meas_intv, at_ble_htpt_sec_level sec_lvl)
This API message shall be used to add an instance of the Health Thermometer service into the database...
at_ble_htpt_disable_ind_t::interm_temp_ntf_en
uint16_t interm_temp_ntf_en
Intermediate temperature notification configuration.
Definition: at_ble_api.h:1319
at_ble_characteristic_read
at_ble_status_t at_ble_characteristic_read(at_ble_handle_t conn_handle, at_ble_handle_t char_handle, uint16_t offset, uint16_t length)
Read a characteristic given its handle.
at_ble_characteristic_t::value_init_len
uint16_t value_init_len
Definition: at_ble_api.h:918
at_ble_conn_param_update_request_t
Definition: at_ble_api.h:1052
at_ble_whitelist_remove
at_ble_status_t at_ble_whitelist_remove(at_ble_addr_t *address)
Removes a peer device address from the white-list.
at_ble_characteristic_reliable_write_prepare
at_ble_status_t at_ble_characteristic_reliable_write_prepare(at_ble_handle_t conn_handle, at_ble_handle_t char_handle, uint16_t offset, uint16_t length, uint8_t *data)
Add a new prepared write request.
at_ble_connect
at_ble_status_t at_ble_connect(at_ble_addr_t peers[], uint8_t peer_count, uint16_t scan_interval, uint16_t scan_window, at_ble_connection_params_t *connection_params)
Connect to a peer device.
HTP_TYPE_GASTRO_INTESTINAL_TRACT
Gastro-intestinal Tract.
Definition: at_ble_api.h:762
at_ble_conn_update_reply
void at_ble_conn_update_reply(at_ble_handle_t conn_handle, at_ble_connection_params_t *connection_params)
Reply to connection parameters update request AT_BLE_CONN_PARAM_UPDATE_REQUEST.
at_ble_event_parameter_t::at_ble_connected_t
at_ble_connected_t at_ble_connected_t
Definition: at_ble_api.h:1380
at_ble_htpt_conn_type
at_ble_htpt_conn_type
Health Thermometer Connection Type.
Definition: at_ble_api.h:775
at_ble_rand_addr_changed_t
Definition: at_ble_api.h:1029
AT_BLE_GAP_LIM_DISC_ADV_INT_MIN
Minimum advertising interval, when in limited discoverable mode (n * 0.625 mSec)
Definition: at_ble_api.h:158
AT_BLE_SCAN_GEN_DISCOVERY
Definition: at_ble_api.h:547
at_ble_characteristic_value_set
at_ble_status_t at_ble_characteristic_value_set(at_ble_handle_t handle, uint8_t *value, uint16_t offset, uint16_t len)
Sets a characteristic value.
AT_BLE_INDICATION_RECIEVED
Definition: at_ble_api.h:322
AT_BLE_GAP_CONN_EST_ADV_TIMEOUT
Advertising time-out, when performing Connection Establishment proc (mSec)
Definition: at_ble_api.h:154
at_ble_characteristic_t::client_config_handle
at_ble_handle_t client_config_handle
Definition: at_ble_api.h:929
at_ble_characteristic_changed_t::char_len
uint16_t char_len
Definition: at_ble_api.h:1235
AT_BLE_SCAN_ACTIVE
Definition: at_ble_api.h:560
at_ble_prf_date_time_t::day
uint8_t day
day time element
Definition: at_ble_api.h:1291
at_ble_included_service_t::uuid
at_ble_uuid_t uuid
Definition: at_ble_api.h:940
at_ble_discovery_complete_t
Definition: at_ble_api.h:1146
at_ble_primary_service_found_t::end_handle
at_ble_handle_t end_handle
Definition: at_ble_api.h:1155
at_ble_scan_info_t::dev_addr
at_ble_addr_t dev_addr
Definition: at_ble_api.h:1007
AT_BLE_GAP_NO_ROLE
No role set yet.
Definition: at_ble_api.h:190
at_ble_htpt_create_db_cfm_t
Parameters of the AT_BLE_HTPT_CREATE_DB_CFM message.
Definition: at_ble_api.h:1303
AT_BLE_HTPT_CREATE_DB_CFM
Definition: at_ble_api.h:355
at_ble_notification_recieved_t::char_len
uint16_t char_len
Definition: at_ble_api.h:1211
AT_BLE_ATTR_READABLE_REQ_AUTHN_REQ_AUTHR
Definition: at_ble_api.h:571
at_ble_htpt_ntf_ind_cfg
at_ble_htpt_ntf_ind_cfg
Health Thermometer Enable Notification/Indication for HTPT characteristics.
Definition: at_ble_api.h:796
AT_BLE_MODE2_L1_NOAUTH_DATA_SGN
Definition: at_ble_api.h:484
AT_BLE_SCAN_LIM_DISCOVERY
Definition: at_ble_api.h:549
AT_BLE_ADV_TYPE_NONCONN_UNDIRECTED
Definition: at_ble_api.h:210
at_ble_connection_params_t::superv_to
uint16_t superv_to
Link supervision time-out.
Definition: at_ble_api.h:874
at_ble_htpt_temp_type
at_ble_htpt_temp_type
Health Thermometer Temperature Type Description.
Definition: at_ble_api.h:751
AT_BLE_DISCOVERY_COMPLETE
Definition: at_ble_api.h:302
AT_BLE_GAP_LIM_DISC_ADV_INT_MAX
Maximum advertising interval, when in limited discoverable mode (n * 0.625 mSec)
Definition: at_ble_api.h:159
at_ble_service_changed_notification_send
at_ble_status_t at_ble_service_changed_notification_send(at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle)
Sends a Service changed Notification.
at_ble_included_service_found_t::start_handle
at_ble_handle_t start_handle
Definition: at_ble_api.h:1164
at_ble_characteristic_t::user_desc_max_len
uint16_t user_desc_max_len
Definition: at_ble_api.h:924
GAP_AUTHZ_NOT_SET
Authorization not set, application informed when authorization requested.
Definition: at_ble_api.h:649
AT_BLE_PRES_FORMAT_UINT32
Definition: at_ble_api.h:590
AT_BLE_ATTR_READABLE_REQ_AUTHN_NO_AUTHR
Definition: at_ble_api.h:569
at_ble_included_service_t::end_group_handle
at_ble_handle_t end_group_handle
Definition: at_ble_api.h:942
at_ble_pair_key_request_t::handle
at_ble_handle_t handle
Definition: at_ble_api.h:1106
AT_BLE_MAX_ATT_LEN
#define AT_BLE_MAX_ATT_LEN
ATT Maximum Attribute Length.
Definition: at_ble_api.h:103
at_ble_characteristic_read_multible
at_ble_status_t at_ble_characteristic_read_multible(at_ble_handle_t conn_handle, at_ble_handle_t *char_handle_list, uint16_t *char_val_lenght, uint8_t char_handle_count)
Read a list of characteristics given their handles.
at_ble_disconnected_t
Definition: at_ble_api.h:1035
AT_BLE_GAP_CONN_EST_MIN_CE_LEN
Local informational parameter about min length of connection needed, when using Connection Establishm...
Definition: at_ble_api.h:179
AT_BLE_GAP_CONN_EST_SCAN_INT
Scan interval used during Link Layer Initiating state, when using Connection Establishment proc (n * ...
Definition: at_ble_api.h:175
AT_BLE_INVALID_PARAM
Input Parameter invalid.
Definition: at_ble_api.h:128
at_ble_whitelist_clear
at_ble_status_t at_ble_whitelist_clear(void)
Clear the white-list.
at_ble_pair_key_request_t::passkey_type
at_ble_passkey_type_t passkey_type
Definition: at_ble_api.h:1108
AT_BLE_IO_CAP_DISPLAY_ONLY
Definition: at_ble_api.h:444
at_ble_service_changed_notification_confirmed_t::conn_handle
at_ble_handle_t conn_handle
Definition: at_ble_api.h:1243
at_ble_auth_t
at_ble_auth_t
Authorization Types.
Definition: at_ble_api.h:633
AT_BLE_GAP_LIM_DISC_SCAN_WIND
Scan window used during Link Layer Scanning state, when in Limited Discovery proc (n * 0...
Definition: at_ble_api.h:171
at_ble_key_dis_t
at_ble_key_dis_t
Security keys distribution list.
Definition: at_ble_api.h:458
AT_BLE_HTPT_ERROR_IND
Definition: at_ble_api.h:359
at_ble_characteristic_write_response_t
Definition: at_ble_api.h:1198
at_ble_slave_sec_request_t::bond
bool bond
Definition: at_ble_api.h:1115
at_ble_conn_param_update_done_t
Definition: at_ble_api.h:1042
at_ble_primary_service_discover_all
at_ble_status_t at_ble_primary_service_discover_all(at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle)
Discover all Primary services declared in a connected device.
at_ble_htpt_cfg_indntf_ind_t::char_code
at_ble_htpt_attr_index char_code
Own code for differentiating between Temperature Measurement, Intermediate Temperature and Measuremen...
Definition: at_ble_api.h:1354
at_ble_char_pres_format_t
at_ble_char_pres_format_t
Presentation Formats.
Definition: at_ble_api.h:582
AT_BLE_UNDEFINED_EVENT
Definition: at_ble_api.h:220
AT_BLE_ADDRESS_PUBLIC
Definition: at_ble_api.h:420
at_ble_characteristic_value_get
at_ble_status_t at_ble_characteristic_value_get(at_ble_handle_t handle, uint8_t *value, uint16_t offset, uint16_t len, uint16_t actual_read_len)
Reads a characteristic value.
at_ble_spcp_t::con_intv_max
uint16_t con_intv_max
Slave preferred maximum connection interval.
Definition: at_ble_api.h:836
AT_BLE_GAP_CONN_EST_SUPERV_TIMEOUT
Link Layer connection supervision time-out, when using Connection Establishment proc (n * 10 mSec) ...
Definition: at_ble_api.h:177
PRF_CON_DISCOVERY
Discovery type connection.
Definition: at_ble_api.h:674
AT_BLE_CHARACTERISTIC_WRITE_RESPONSE
Definition: at_ble_api.h:314
at_ble_characteristic_found_t::char_uuid
at_ble_uuid_t char_uuid
Definition: at_ble_api.h:1176
AT_BLE_IO_CAP_DISPLAY_YES_NO
Definition: at_ble_api.h:446
AT_BLE_GAP_BROADCASTER_ADV
Broadcaster role.
Definition: at_ble_api.h:196
at_ble_characteristic_reliable_write_cancel
at_ble_status_t at_ble_characteristic_reliable_write_cancel(at_ble_handle_t conn_handle)
Cancels a pending prepared write operation.
at_ble_signature_info_t::lsign_counter
uint32_t lsign_counter
Local signature counter value.
Definition: at_ble_api.h:998
AT_BLE_ADDRESS_INVALID
Definition: at_ble_api.h:428
AT_BLE_GAP_CONN_EST_INT_MIN
Minimum Link Layer connection interval, when using Connection Establishment proc (n * 1...
Definition: at_ble_api.h:173
AT_BLE_GAP_CONN_ADV_INT_MIN
Minimum advertising interval, when in Connectable mode (n * 0.625 mSec)
Definition: at_ble_api.h:162
AT_BLE_CHAR_READ
Definition: at_ble_api.h:507
AT_BLE_ATTR_READABLE_NO_AUTHN_NO_AUTHR
Definition: at_ble_api.h:568
at_ble_primary_service_found_t::service_uuid
at_ble_uuid_t service_uuid
Definition: at_ble_api.h:1156
AT_BLE_CHAR_WRITE
Definition: at_ble_api.h:509
at_ble_LTK_t::key_size
uint8_t key_size
Encryption key size (7 to 16)
Definition: at_ble_api.h:972
at_ble_disconnect
at_ble_status_t at_ble_disconnect(at_ble_handle_t handle, at_ble_disconnect_reason_t reason)
Disconnect a connected peer device.
at_ble_filter_type_t
at_ble_filter_type_t
Advertising Filter Policy.
Definition: at_ble_api.h:519
at_ble_event_parameter_t::at_ble_discovery_complete_t
at_ble_discovery_complete_t at_ble_discovery_complete_t
Definition: at_ble_api.h:1396
at_ble_read_authorize_reply
at_ble_status_t at_ble_read_authorize_reply(at_ble_handle_t conn_handle, at_ble_handle_t attr_handle, bool grant_authorization, bool update_value, uint8_t *value, uint16_t offset, uint16_t len)
Replies to a read authorization request requested by by AT_BLE_READ_AUTHORIZE_REQUEST event...
at_ble_event_parameter_t::at_ble_pair_features_t
at_ble_pair_features_t at_ble_pair_features_t
Definition: at_ble_api.h:1373
at_ble_event_parameter_t::at_ble_descriptor_found_t
at_ble_descriptor_found_t at_ble_descriptor_found_t
Definition: at_ble_api.h:1400
at_ble_connection_params_t::ce_len_min
uint16_t ce_len_min
Minimum CE length.
Definition: at_ble_api.h:876
AT_BLE_ADV_TYPE_SCANNABLE_UNDIRECTED
Definition: at_ble_api.h:209
at_ble_scan_info_t::type
at_ble_adv_type_t type
Definition: at_ble_api.h:1006
at_ble_char_properties_t
at_ble_char_properties_t
Characteristic properties (Each enum value is a single bit; multiple properties can be indicated simu...
Definition: at_ble_api.h:505
HTPT_START_NTF
Start notification.
Definition: at_ble_api.h:788
at_ble_characteristic_t::properties
at_ble_char_properties_t properties
Definition: at_ble_api.h:915
at_ble_signature_info_t
Definition: at_ble_api.h:991
AT_BLE_GAP_LIM_DISC_SCAN_INT
Scan interval used during Link Layer Scanning state, when in Limited Discovery proc (n * 0...
Definition: at_ble_api.h:170
at_ble_auth_levels_t
at_ble_auth_levels_t
Security authentication level.
Definition: at_ble_api.h:476
at_ble_event_parameter_t::at_ble_notification_recieved_t
at_ble_notification_recieved_t at_ble_notification_recieved_t
Definition: at_ble_api.h:1403
at_ble_htpt_attr_index
at_ble_htpt_attr_index
Health Thermometer Attribute Table Indexes.
Definition: at_ble_api.h:724
AT_BLE_PRES_FORMAT_UTF16S
Definition: at_ble_api.h:608
AT_BLE_PRES_FORMAT_SFLOAT
Definition: at_ble_api.h:604
at_ble_uuid_t
UUID type.
Definition: at_ble_api.h:884
at_ble_characteristic_t::user_desc
uint8_t * user_desc
Definition: at_ble_api.h:922
AT_BLE_PRES_FORMAT_UINT128
Definition: at_ble_api.h:593
AT_BLE_NOTIFICATION_RECIEVED
Definition: at_ble_api.h:318
AT_BLE_WRITE_AUTHORIZE_REQUEST
Definition: at_ble_api.h:340
at_ble_disconnected_t::reason
uint8_t reason
Definition: at_ble_api.h:1038
at_ble_descriptor_found_t
Definition: at_ble_api.h:1180
at_ble_signature_info_t::peer_sign_counter
uint32_t peer_sign_counter
Remote signature counter value.
Definition: at_ble_api.h:1000
at_ble_status_t
at_ble_status_t
Enumeration for BLE Status.
Definition: at_ble_api.h:121
at_ble_write_authorize_request_t::char_handle
at_ble_handle_t char_handle
Definition: at_ble_api.h:1250
at_ble_l2cap_rx_t::cid
uint16_t cid
Definition: at_ble_api.h:1266
at_ble_pair_features_t::desired_auth
at_ble_auth_levels_t desired_auth
Definition: at_ble_api.h:958
at_ble_htpt_temp_send_cfm_t::cfm_type
uint8_t cfm_type
Confirmation Type.
Definition: at_ble_api.h:1335
at_ble_event_parameter_t::at_ble_gap_whitelist_t
at_ble_gap_whitelist_t at_ble_gap_whitelist_t
Definition: at_ble_api.h:1367
HTPT_TEMP_TYPE_CHAR_SUP
Indicate if Temperature Type Char. is supported.
Definition: at_ble_api.h:693
HTPT_MEAS_INTV_CHAR_SUP
Indicate if Measurement Interval Char. is supported.
Definition: at_ble_api.h:697
at_ble_l2cap_rx_t::conn_handle
at_ble_handle_t conn_handle
Definition: at_ble_api.h:1265
AT_BLE_L2CAP_RX
Definition: at_ble_api.h:349
at_ble_htpt_disable_ind_t::conhdl
uint16_t conhdl
Connection handle.
Definition: at_ble_api.h:1314
at_ble_characteristic_changed_t::conn_handle
at_ble_handle_t conn_handle
Definition: at_ble_api.h:1232
at_ble_htpt_disable_ind_t::temp_meas_ind_en
uint16_t temp_meas_ind_en
Temperature measurement indication configuration.
Definition: at_ble_api.h:1317
at_ble_event_parameter_t::at_ble_indication_recieved_t
at_ble_indication_recieved_t at_ble_indication_recieved_t
Definition: at_ble_api.h:1404
AT_BLE_WRITE_AUTH
Definition: at_ble_api.h:667
AT_BLE_HTPT_DISABLE_IND
Definition: at_ble_api.h:363
at_ble_rx_power_get
int8_t at_ble_rx_power_get(at_ble_handle_t conn_handle)
Gets RX power of a given connection.
at_ble_gap_deviceinfo_t
Definition: at_ble_api.h:843
at_ble_conn_param_update_done_t::con_intv
uint16_t con_intv
Definition: at_ble_api.h:1046
AT_BLE_PRES_FORMAT_BOOLEAN
Definition: at_ble_api.h:583
AT_BLE_CHAR_INDICATE
Definition: at_ble_api.h:511
AT_BLE_HTPT_MEAS_INTV_CHG_IND
Definition: at_ble_api.h:371
HTPT_ENABLE
Service can be browsed and attributes can be accessed according to attribute permission.
Definition: at_ble_api.h:715
at_ble_characteristic_read_response_t
Definition: at_ble_api.h:1189
HTPT_TEMP_MEAS_CHAR
Definition: at_ble_api.h:726
at_ble_connected_t::peer_addr
at_ble_addr_t peer_addr
Definition: at_ble_api.h:1023
AT_BLE_GAP_CONN_EST_MAX_CE_LEN
Local informational parameter about max length of connection needed, when using Connection Establishm...
Definition: at_ble_api.h:180
at_ble_characteristic_found_t::char_handle
at_ble_handle_t char_handle
Definition: at_ble_api.h:1173
at_ble_primary_service_found_t
Definition: at_ble_api.h:1151
AT_BLE_PRES_FORMAT_DUINT16
Definition: at_ble_api.h:606
at_ble_scan_start
at_ble_status_t at_ble_scan_start(uint16_t interval, uint16_t window, uint16_t timeout, at_ble_scan_type_t type, at_ble_scan_mode_t mode, bool filter_whitelist, bool filter_duplicates)
Start scan operation.
GAP_AUTHZ_ACCEPT
Authorization request automatically accepted.
Definition: at_ble_api.h:651
at_ble_htpt_meas_intv_chg_ind_t::intv
uint16_t intv
Definition: at_ble_api.h:1342
at_ble_max_PA_gain_value_t
Definition: at_ble_api.h:1066
AT_BLE_ATTR_WRITABLE_NO_AUTHN_NO_AUTHR
Definition: at_ble_api.h:573
AT_BLE_GAP_CENTRAL_MST
Master/Central role.
Definition: at_ble_api.h:199
HTPT_FLAG_CELSIUS
Temperature Units Flag - Celsius.
Definition: at_ble_api.h:739
AT_BLE_GAP_GEN_DISC_ADV_MIN
Minimum time to remain advertising, when in Discoverable mode (mSec). Setting this parameter to 0 tur...
Definition: at_ble_api.h:150
AT_BLE_GAP_CONN_EST_INT_MAX
Maximum Link Layer connection interval, when using Connection Establishment proc (n * 1...
Definition: at_ble_api.h:174
at_ble_tx_power_value_t::handle
at_ble_handle_t handle
Definition: at_ble_api.h:1074
at_ble_send_slave_sec_request
at_ble_status_t at_ble_send_slave_sec_request(at_ble_handle_t conn_handle, bool mitm_protection, bool bond)
Send slave security request to master.
at_ble_event_parameter_t::at_ble_write_authorize_request_t
at_ble_write_authorize_request_t at_ble_write_authorize_request_t
Definition: at_ble_api.h:1408
at_ble_gap_whitelist_t::addrCount
uint8_t addrCount
Definition: at_ble_api.h:857
AT_BLE_PRES_FORMAT_UINT48
Definition: at_ble_api.h:591
AT_BLE_SCAN_OBSERVER_MODE
Definition: at_ble_api.h:551
GAP_AUTHZ_REJECT
Authorization request automatically rejected.
Definition: at_ble_api.h:653
at_ble_l2cap_cid_register
at_ble_status_t at_ble_l2cap_cid_register(at_ble_handle_t conn_handle, uint16_t cid)
Registers a custom CID to received data from, when the L2CAP received data on the registered CID an A...
at_ble_characteristic_t::init_value
uint8_t * init_value
Definition: at_ble_api.h:917
AT_BLE_DISCOVERY_FAILURE
GATTC discover operation found no services.
Definition: at_ble_api.h:685
at_ble_event_parameter_t::at_ble_conn_param_update_request_t
at_ble_conn_param_update_request_t at_ble_conn_param_update_request_t
Definition: at_ble_api.h:1384
AT_BLE_ATTR_READABLE_NO_AUTHN_REQ_AUTHR
Definition: at_ble_api.h:570
HTP_TYPE_MOUTH
Mouth.
Definition: at_ble_api.h:764
at_ble_event_parameter_t::at_ble_max_PA_gain_value_t
at_ble_max_PA_gain_value_t at_ble_max_PA_gain_value_t
Definition: at_ble_api.h:1386
at_ble_htpt_disable_ind_t::meas_intv_ind_en
uint16_t meas_intv_ind_en
Measurement interval indication configuration.
Definition: at_ble_api.h:1321
at_ble_characteristic_t::user_desc_handle
at_ble_handle_t user_desc_handle
Definition: at_ble_api.h:928
at_ble_gap_irk_t
Identity Resolving Key.
Definition: at_ble_api.h:824
at_ble_pair_key_reply
at_ble_status_t at_ble_pair_key_reply(at_ble_handle_t conn_handle, at_ble_pair_key_type_t type, uint8_t *key)
Provides a passkey or OOB data that was requested via AT_BLE_PAIR_KEY_REQUEST event, If key type is AT_BLE_PAIR_PASSKEY, then a 6-byte ASCII string (digit 0..9 only). If key type is AT_BLE_PAIR_OOB , then a 16-byte OOB key value in Little Endian format.
at_ble_indication_recieved_t
Definition: at_ble_api.h:1214
HTPT_CONFIG_CONN
Definition: at_ble_api.h:777
at_ble_prf_date_time_t::min
uint8_t min
minute time element
Definition: at_ble_api.h:1295
at_ble_connected_t::handle
at_ble_handle_t handle
Definition: at_ble_api.h:1024
at_ble_authenticate
at_ble_status_t at_ble_authenticate(at_ble_handle_t conn_handle, at_ble_pair_features_t *features, at_ble_LTK_t *ltk, at_ble_CSRK_t *csrk)
Starts Pairing procedure for a given connection.
AT_BLE_PAIR_REQUEST
Definition: at_ble_api.h:260
at_ble_scan_mode_t
at_ble_scan_mode_t
Scan modes used at at_ble_scan_start.
Definition: at_ble_api.h:545
at_ble_gap_deviceinfo_t::appearance
uint16_t appearance
Appearance configuration.
Definition: at_ble_api.h:848
at_ble_iocab_t
at_ble_iocab_t
IO capabilities of a device.
Definition: at_ble_api.h:442
at_ble_set_privacy_key
at_ble_status_t at_ble_set_privacy_key(at_ble_gap_irk_t *irk, uint16_t interval)
Set device Identity Resolving Key.
AT_BLE_SCAN_REPORT
Definition: at_ble_api.h:228
at_ble_pair_features_t::min_key_size
uint8_t min_key_size
Definition: at_ble_api.h:954
at_ble_primary_service_found_t::conn_handle
at_ble_handle_t conn_handle
Definition: at_ble_api.h:1153
at_ble_pair_request_t::peer_features
at_ble_pair_features_t peer_features
Definition: at_ble_api.h:1100
AT_BLE_PRES_FORMAT_2BIT
Definition: at_ble_api.h:584
at_ble_htpt_meas_intv_update
at_ble_status_t at_ble_htpt_meas_intv_update(uint16_t meas_intv)
This message is used by the application to order the HTPT profile to generate an indication (if enabl...
HTPT_AUTH
Service can be used with Authenticated Link (Pin code Pairing)
Definition: at_ble_api.h:719
AT_BLE_PRES_FORMAT_SINT24
Definition: at_ble_api.h:597
AT_BLE_ADV_TYPE_UNDIRECTED
Definition: at_ble_api.h:207
at_ble_attr_permissions_t
at_ble_attr_permissions_t
Attribute Permissions.
Definition: at_ble_api.h:565
at_ble_characteristic_read_response_t::char_len
uint16_t char_len
Definition: at_ble_api.h:1193
at_ble_pair_key_type_t
at_ble_pair_key_type_t
Pairing Key Types.
Definition: at_ble_api.h:614
HTPT_STOP_NTFIND
Stop notification/indication.
Definition: at_ble_api.h:786
AT_BLE_CHARACTERISTIC_WRITE_CMD_CMP
Definition: at_ble_api.h:408
at_ble_gap_set_param
at_ble_status_t at_ble_gap_set_param(at_ble_parameters_t param, uint8_t *value_buff, uint16_t value_len)
Change the GAP related parameters.
at_ble_event_parameter_t::at_ble_prf_date_time_t
at_ble_prf_date_time_t at_ble_prf_date_time_t
Definition: at_ble_api.h:1412
at_ble_event_parameter_t::at_ble_CSRK_t
at_ble_CSRK_t at_ble_CSRK_t
Definition: at_ble_api.h:1375
at_ble_event_parameter_t::at_ble_htpt_meas_intv_chg_ind_t
at_ble_htpt_meas_intv_chg_ind_t at_ble_htpt_meas_intv_chg_ind_t
Definition: at_ble_api.h:1416
AT_BLE_PRES_FORMAT_SINT32
Definition: at_ble_api.h:598
AT_BLE_DISCONNECTED
Definition: at_ble_api.h:240
at_ble_event_parameter_t::at_ble_IRK_t
at_ble_IRK_t at_ble_IRK_t
Definition: at_ble_api.h:1376
AT_BLE_CHAR_WRITEABLE_AUX
Definition: at_ble_api.h:514
at_ble_pair_done_t
Pairing done message.
Definition: at_ble_api.h:1086
at_ble_uuid_t::type
at_ble_uuid_type_t type
Definition: at_ble_api.h:886
at_ble_gap_role
at_ble_gap_role
GAP Role.
Definition: at_ble_api.h:187
at_ble_write_authorize_request_t::conn_handle
at_ble_handle_t conn_handle
Definition: at_ble_api.h:1249
at_ble_prf_date_time_t::sec
uint8_t sec
second time element
Definition: at_ble_api.h:1297
HTP_TYPE_TOE
Toe.
Definition: at_ble_api.h:768
at_ble_event_parameter_t::at_ble_spcp_t
at_ble_spcp_t at_ble_spcp_t
Definition: at_ble_api.h:1365
AT_BLE_INDICATION_CONFIRMED
Definition: at_ble_api.h:328
at_ble_htpt_temp_send
at_ble_status_t at_ble_htpt_temp_send(uint32_t temp, at_ble_prf_date_time_t *time_stamp, at_ble_htpt_temp_flags flags, at_ble_htpt_temp_type type, bool flag_stable_meas)
This message is used by the application (which handles the temperature device driver and measurements...
at_ble_service_changed_notification_confirmed_t
Definition: at_ble_api.h:1241
at_ble_htpt_ntfind
at_ble_htpt_ntfind
Health Thermometer Enable/Disable Notification/Indication.
Definition: at_ble_api.h:783
at_ble_event_parameter_t::at_ble_service_changed_notification_confirmed_t
at_ble_service_changed_notification_confirmed_t at_ble_service_changed_notification_confirmed_t
Definition: at_ble_api.h:1407
AT_BLE_GAP_CONN_PAUSE_PERIPHERAL
Minimum time upon connection establishment before the peripheral starts a connection update procedure...
Definition: at_ble_api.h:183
at_ble_exchange_mtu
at_ble_status_t at_ble_exchange_mtu(at_ble_handle_t conn_handle)
This message is used by the application to initiate the MTU exchange.
AT_BLE_PAIR_DONE
Definition: at_ble_api.h:256
at_ble_rx_power_value_t
Definition: at_ble_api.h:1059
at_ble_encryption_start
at_ble_status_t at_ble_encryption_start(at_ble_handle_t conn_handle, at_ble_LTK_t key, at_ble_auth_t auth)
Starts encryption, once encryption starts AT_BLE_ENCRYPTION_STATUS_CHANGED event is delivered...
at_ble_characteristic_read_response_t::char_offset
uint16_t char_offset
Definition: at_ble_api.h:1194
at_ble_disconnect_reason_t
at_ble_disconnect_reason_t
Disconnection reasons.
Definition: at_ble_api.h:435
at_ble_event_parameter_t::at_ble_char_presentation_t
at_ble_char_presentation_t at_ble_char_presentation_t
Definition: at_ble_api.h:1370
at_ble_indication_recieved_t::char_len
uint16_t char_len
Definition: at_ble_api.h:1219
at_ble_write_authorize_request_t
Definition: at_ble_api.h:1247
at_ble_tx_power_set_t::tx_set_status
uint8_t tx_set_status
Definition: at_ble_api.h:1081
at_ble_indication_recieved_t::char_handle
at_ble_handle_t char_handle
Definition: at_ble_api.h:1217
at_ble_tx_power_value_t::tx_value
uint16_t tx_value
Definition: at_ble_api.h:1075
AT_BLE_GAP_PRIVATE_ADDR_INT
Minimum Time Interval between private (resolvable) address changes. In minutes (default 15 minutes) ...
Definition: at_ble_api.h:181
at_ble_event_parameter_t::at_ble_gap_deviceinfo_t
at_ble_gap_deviceinfo_t at_ble_gap_deviceinfo_t
Definition: at_ble_api.h:1366
AT_BLE_ADDRESS_RANDOM_STATIC
Definition: at_ble_api.h:422
AT_BLE_ADDRESS_RANDOM_PRIVATE_RESOLVABLE
Definition: at_ble_api.h:424
AT_BLE_KEY_DIST_SIGN
Definition: at_ble_api.h:466
at_ble_indication_confirmed_t::char_handle
at_ble_handle_t char_handle
Definition: at_ble_api.h:1225
AT_BLE_AUTH_MITM_NO_BOND
Definition: at_ble_api.h:640
at_ble_tx_power_set
at_ble_status_t at_ble_tx_power_set(at_ble_handle_t conn_handle, int8_t powerdBm)
Sets TX gain, relative to maximum gain, for a given connection.
at_ble_prf_date_time_t::year
uint16_t year
year time element
Definition: at_ble_api.h:1287
at_ble_encryption_request_t::handle
at_ble_handle_t handle
Definition: at_ble_api.h:1122
at_ble_spcp_t::con_latency
uint16_t con_latency
Slave preferred Connection latency.
Definition: at_ble_api.h:838
at_ble_adv_type_t
at_ble_adv_type_t
GAP Advertising types.
Definition: at_ble_api.h:206
at_ble_notification_recieved_t::char_handle
at_ble_handle_t char_handle
Definition: at_ble_api.h:1209
at_ble_htpt_disable_ind_t
Parameters of the AT_BLE_HTPT_DISABLE_IND message.
Definition: at_ble_api.h:1311
AT_BLE_PRES_FORMAT_SINT12
Definition: at_ble_api.h:595
at_ble_characteristic_read_response_t::conn_handle
at_ble_handle_t conn_handle
Definition: at_ble_api.h:1191
at_ble_author_t
at_ble_author_t
Authorization setting.
Definition: at_ble_api.h:646
at_ble_prf_date_time_t::month
uint8_t month
month time element
Definition: at_ble_api.h:1289
at_ble_included_service_found_t::service_uuid
at_ble_uuid_t service_uuid
Definition: at_ble_api.h:1166
at_ble_rx_power_unsubscribe
at_ble_status_t at_ble_rx_power_unsubscribe(at_ble_handle_t conn_handle)
Unsubscribe form RX power level notifications.
PRF_CON_NORMAL
Normal type connection.
Definition: at_ble_api.h:676
AT_BLE_RESOLV_RAND_ADDR_STATUS
Definition: at_ble_api.h:280
at_ble_characteristic_write
at_ble_status_t at_ble_characteristic_write(at_ble_handle_t conn_handle, at_ble_handle_t char_handle, uint16_t offset, uint16_t length, uint8_t *data, bool signed_write, bool with_response)
Write a characteristic.
at_ble_adv_data_set
at_ble_status_t at_ble_adv_data_set(uint8_t const *const adv_data, uint8_t adv_data_len, uint8_t const *const scan_resp_data, uint8_t scan_response_data_len)
Set, clear or update advertisement and scan response data.
AT_BLE_WIFIPROV_SCAN_MODE_CHANGE_IND
Definition: at_ble_api.h:381
AT_BLE_RAND_ADDR_CHANGED
Definition: at_ble_api.h:232
at_ble_event_parameter_t
Definition: at_ble_api.h:1361
at_ble_event_parameter_t::at_ble_characteristic_read_response_t
at_ble_characteristic_read_response_t at_ble_characteristic_read_response_t
Definition: at_ble_api.h:1401
at_ble_tx_power_set_t
Definition: at_ble_api.h:1078
at_ble_characteristic_t::server_config_permissions
at_ble_attr_permissions_t server_config_permissions
Definition: at_ble_api.h:927
HTPT_FLAG_TYPE
Temperature Type Flag.
Definition: at_ble_api.h:745
AT_BLE_ENCRYPTION_REQUEST
Definition: at_ble_api.h:272
at_ble_connection_params_t
Connection parameters.
Definition: at_ble_api.h:865
AT_BLE_GAP_LIM_DISC_SCAN
Minimum time to perform scanning, when performing Limited Discovery proc (mSec)
Definition: at_ble_api.h:153
at_ble_characteristic_found_t
Definition: at_ble_api.h:1170
at_ble_parameters_t
at_ble_parameters_t
Enumeration for GAP Parameters.
Definition: at_ble_api.h:147
HTPT_MEAS_INTV_WR_SUP
Indicate if Measurement Interval Char. is writable.
Definition: at_ble_api.h:701
at_ble_tx_power_set_t::handle
at_ble_handle_t handle
Definition: at_ble_api.h:1080
at_ble_event_parameter_t::at_ble_prf_server_error_ind_t
at_ble_prf_server_error_ind_t at_ble_prf_server_error_ind_t
Definition: at_ble_api.h:1411
at_ble_addr_type_t
at_ble_addr_type_t
BLE can accept either public or random addresses.
Definition: at_ble_api.h:418
at_ble_scan_info_t::adv_data_len
uint8_t adv_data_len
Definition: at_ble_api.h:1009
AT_BLE_PRES_FORMAT_UINT12
Definition: at_ble_api.h:587
at_ble_characteristic_t::value_max_len
uint16_t value_max_len
Definition: at_ble_api.h:919
at_ble_characteristic_discover_by_uuid
at_ble_status_t at_ble_characteristic_discover_by_uuid(at_ble_handle_t conn_handle, at_ble_handle_t start_handle, at_ble_handle_t end_handle, at_ble_uuid_t *uuid)
Discover all Characteristics of a given UUID declared in a connected device.
at_ble_characteristic_changed_t
Definition: at_ble_api.h:1230
at_ble_htpt_db_config_flag
at_ble_htpt_db_config_flag
Health Thermometer Database Configuration Flags.
Definition: at_ble_api.h:690
HTP_TYPE_RECTUM
Rectum.
Definition: at_ble_api.h:766
HTPT_TEMP_TYPE_CHAR
Definition: at_ble_api.h:727
at_ble_pair_key_request_t
Definition: at_ble_api.h:1104
at_ble_spcp_t
Slave preferred connection parameters.
Definition: at_ble_api.h:831
at_ble_event_parameter_t::at_ble_encryption_request_t
at_ble_encryption_request_t at_ble_encryption_request_t
Definition: at_ble_api.h:1393
at_ble_l2cap_cid_unregister
at_ble_status_t at_ble_l2cap_cid_unregister(at_ble_handle_t conn_handle, uint16_t cid)
Unregister a previously registered custom CID.
AT_BLE_CONN_PARAM_UPDATE_REQUEST
Definition: at_ble_api.h:248
at_ble_tx_power_value_t
Definition: at_ble_api.h:1072
AT_BLE_INCLUDED_SERVICE_FOUND
Definition: at_ble_api.h:290
AT_BLE_UNACCEPTABLE_INTERVAL
Definition: at_ble_api.h:437
AT_BLE_NO_SEC
Definition: at_ble_api.h:478
at_ble_scan_stop
at_ble_status_t at_ble_scan_stop(void)
Stops an ongoing scan operation.
AT_BLE_CHARACTERISTIC_READ_RESPONSE
Definition: at_ble_api.h:306
at_ble_event_parameter_t::at_ble_gap_irk_t
at_ble_gap_irk_t at_ble_gap_irk_t
Definition: at_ble_api.h:1364
at_ble_event_parameter_t::at_ble_LTK_t
at_ble_LTK_t at_ble_LTK_t
Definition: at_ble_api.h:1374
HTPT_CFG_INTERM_MEAS_NTF
Intermediate measurement notification enabled.
Definition: at_ble_api.h:801
AT_BLE_ADV_FP_FILTER_BOTH
Definition: at_ble_api.h:527
at_ble_pair_done_t::peer_irk
at_ble_IRK_t peer_irk
Definition: at_ble_api.h:1093
Generated on Fri Aug 18 2017 00:42:10 for Atmel BLE API by doxygen 1.8.13


Atmel BLE API: Data Structure Index

Data Structure Index
_ | a | w
_
at_ble_conn_param_update_request_t at_ble_htpt_create_db_cfm_t at_ble_pair_features_t at_ble_slave_sec_request_t
at_ble_connected_t at_ble_htpt_disable_ind_t at_ble_pair_key_request_t at_ble_spcp_t
_plf_params at_ble_connection_params_t at_ble_htpt_meas_intv_chg_ind_t at_ble_pair_request_t at_ble_tx_power_set_t
_scanitem at_ble_CSRK_t at_ble_htpt_temp_send_cfm_t at_ble_prf_date_time_t at_ble_tx_power_value_t
a
at_ble_descriptor_found_t at_ble_included_service_found_t at_ble_prf_server_error_ind_t at_ble_uuid_t
at_ble_disconnected_t at_ble_included_service_t at_ble_primary_service_found_t at_ble_wifiprov_complete_ind
at_ble_addr_t at_ble_discovery_complete_t at_ble_indication_confirmed_t at_ble_rand_addr_changed_t at_ble_wifiprov_scan_mode_change_ind_t
at_ble_char_presentation_t at_ble_encryption_request_t at_ble_indication_recieved_t at_ble_read_authorize_request_t at_ble_write_authorize_request_t
at_ble_characteristic_changed_t at_ble_encryption_status_changed_t at_ble_IRK_t at_ble_resolv_rand_addr_status_t
w
at_ble_characteristic_found_t at_ble_event_parameter_t at_ble_l2cap_rx_t at_ble_rx_power_value_t
at_ble_characteristic_read_response_t at_ble_gap_deviceinfo_t at_ble_LTK_t at_ble_scan_info_t wifiprov_scanlist_ind
at_ble_characteristic_t at_ble_gap_irk_t at_ble_max_PA_gain_value_t at_ble_scan_report_t wr_apis
at_ble_characteristic_write_response_t at_ble_gap_whitelist_t at_ble_notification_recieved_t at_ble_service_changed_notification_confirmed_t
at_ble_conn_param_update_done_t at_ble_htpt_cfg_indntf_ind_t at_ble_pair_done_t at_ble_signature_info_t
_ | a | w


Atmel BLE API: include Directory Reference

  • ble
  • atmel_ble_api
  • include
include Directory Reference

Files

file | at_ble_api.h [code]
file | platform.h [code]
file | wifiprov_api.h [code]


Atmel BLE API: atmel_ble_api Directory Reference

  • ble
  • atmel_ble_api
atmel_ble_api Directory Reference

Directories

directory include


Atmel BLE API: ble Directory Reference

  • ble
ble Directory Reference

Directories

directory atmel_ble_api


Atmel BLE API: Main Page

Atmel BLE API Documentation
  • Main Page
  • Modules
  • Data Structures
    • Data Structures
    • Data Fields


Atmel BLE API: platform.h Source File

  • ble
  • atmel_ble_api
  • include
platform.h
1
26 #ifndef __PLATFORM_H__
27 #define __PLATFORM_H__
28
29 #include <stdio.h>
30 #include <stdint.h>
31 #include <stdbool.h>
32 #include <string.h>
33 #include "at_ble_api.h"
34 #ifndef WIN32
35 #include "bsp/include/nm_bsp.h"
36 #endif
37 typedef struct{
38 uint8_t (*wr_api32) (uint32_t memAddr,uint32_t* data,uint8_t size);
39 uint8_t (*wr_api32_reset) (uint32_t memAddr,uint32_t* data,uint8_t size);
40 }wr_apis;
55 at_ble_status_t platform_init(void* platform_params);
56
67 void platform_interface_send(uint8_t* data, uint32_t len);
68
69 void platform_receive(uint8_t* data, uint32_t len);
70
80 void platform_interface_callback(uint8_t* data, uint32_t len);
81
86 void platform_cmd_cmpl_signal(void);
87
93 void platform_cmd_cmpl_wait(bool* timeout);
94
99 void platform_event_signal(void);
100
107 uint8_t platform_event_wait(uint32_t timeout);
108 void fw_led(bool tempo);
111 typedef void (*ble_api_callback_t)(uint8_t* msg, uint32_t len);
112 typedef void (*plf_wait_callback_t)(void);
113 typedef struct _plf_params {
114 ble_api_callback_t ble_write_cb;
115 plf_wait_callback_t plf_wait_cb;
116 }plf_params_t;
117
118 #endif // __PLATFORM_H__
platform_cmd_cmpl_wait
void platform_cmd_cmpl_wait(bool *timeout)
blocks until the command-complete signal is fired
platform_event_signal
void platform_event_signal(void)
fires the event signal
_plf_params
Definition: platform.h:113
platform_receive
void platform_receive(uint8_t *data, uint32_t len)
platform_init
at_ble_status_t platform_init(void *platform_params)
implements platform-specific initialization
_plf_params::plf_wait_cb
plf_wait_callback_t plf_wait_cb
Definition: platform.h:115
platform_cmd_cmpl_signal
void platform_cmd_cmpl_signal(void)
fires the command-complete signal
wr_apis
Definition: platform.h:37
fw_led
void fw_led(bool tempo)
_plf_params::ble_write_cb
ble_api_callback_t ble_write_cb
Definition: platform.h:114
at_ble_status_t
at_ble_status_t
Enumeration for BLE Status.
Definition: at_ble_api.h:121
platform_interface_send
void platform_interface_send(uint8_t *data, uint32_t len)
sends a message over the platform-specific bus
platform_interface_callback
void platform_interface_callback(uint8_t *data, uint32_t len)
the callback to upper layers to process received packets
platform_event_wait
uint8_t platform_event_wait(uint32_t timeout)
blocks until the event signal is fired
Generated on Fri Aug 18 2017 00:42:10 for Atmel BLE API by doxygen 1.8.13


Atmel BLE API: wifiprov_api.h Source File

  • ble
  • atmel_ble_api
  • include
wifiprov_api.h
1
30 /*
31 * wifiprov_api.h
32 *
33 */
34 #ifndef WIFIPROV_API_H_
35 #define WIFIPROV_API_H_
36
37 #include "at_ble_api.h"
38
39 #define MAX_WIPROVTASK_AP_NUM 15
40 #define MAX_WIPROVTASK_SSID_LENGTH 32
41 #define MAX_WIPROVTASK_PASS_LENGTH 63
42
43 #define MAX_LOCALNAME_LENGTH 11
44
45 /*
46 * msgs from APP to wifiprov
47 *
48 *
49 */
51 enum
52 {
53 WIFIPROV_CONFIGURE_REQ = 0xDC00,
54 WIFIPROV_CONFIGURE_CFM,
56 WIFIPROV_CREATE_DB_REQ,
58 WIFIPROV_CREATE_DB_CFM,
60 WIFIPROV_START_CMD,
62 WIFIPROV_DISABLE_CMD,
64 WIFIPROV_COMPLETE_IND,
66 WIFIPROV_SCANLIST_IND,
68 WIFIPROV_CONNECTION_STATE_CHANGE_IND,
70 WIFIPROV_SCAN_MODE_CHANGE_IND,
71 };
72
73 // When scan mode is used to send indication from App to the WiFi Prov profile,
74 // WIFIPROV_SCANMODE_SCANNING indicates Scanning is in progress
75 // WIFIPROV_SCANMODE_DONE indicates scanning is completed - note that this
76 // indication should only be used when no scan results were obtained during the scan
77 // These result in the database being updated
78 // When scan mode is used to send indication from WiFi Prov profile to the App,
79 // WIFIPROV_SCANMODE_SCANNING request to start WiFi scanning and supply scan results
80 enum
81 {
82 WIFIPROV_SCANMODE_SCANNING = 1,
83 WIFIPROV_SCANMODE_DONE // Scanning is indicated as
84 };
85 typedef struct
86 {
88 uint8_t scanmode;
89 }at_ble_wifiprov_scan_mode_change_ind_t;
90
91 //store the scan list and then later populate when creating the database
92 typedef struct _scanitem {
93 uint8_t sec_type;
94 uint8_t rssi;
95 uint8_t ssid[MAX_WIPROVTASK_SSID_LENGTH];
96 } scanitem;
97
98 struct wifiprov_scanlist_ind
99 {
100 uint8_t num_valid;
101 scanitem scandetails[MAX_WIPROVTASK_AP_NUM];
102 };
103
104 at_ble_status_t wifiprov_scan_mode_change_ind_send(uint8_t scanmode);
105 at_ble_status_t wifiprov_scan_list_ind_send(struct wifiprov_scanlist_ind *param);
106
107 typedef struct
108 {
109 uint8_t status;
110 uint8_t sec_type;
111 uint8_t ssid_length;
112 uint8_t ssid[MAX_WIPROVTASK_SSID_LENGTH];
113 uint8_t passphrase_length;
114 uint8_t passphrase[MAX_WIPROVTASK_PASS_LENGTH];
115 } at_ble_wifiprov_complete_ind;
116
117 void wifiprov_complete_ind_handler(uint8_t *data, at_ble_wifiprov_complete_ind *param);
118
119 enum
120 {
121 WIFIPROV_CON_STATE_DISCONNECTED,
122 WIFIPROV_CON_STATE_CONNECTING,
123 WIFIPROV_CON_STATE_CONNECTED
124 };
125 at_ble_status_t wifiprov_wifi_con_update(uint8_t con_state);
126
127 //Localname must be a null terminated string
128 at_ble_status_t wifiprov_configure_provisioning(uint8_t* localname);
129 at_ble_status_t wifiprov_create_db(void);
130 at_ble_status_t wifiprov_start(uint8_t *pin, uint8_t len);
131 at_ble_status_t wifiprov_disable(void);
132
133 // Internal API
134 void wifiprov_scan_mode_change_ind_handler(uint8_t *data, at_ble_wifiprov_scan_mode_change_ind_t *param);
135 #endif // WIFIPROV_API_H_
_scanitem::ssid
uint8_t ssid[MAX_WIPROVTASK_SSID_LENGTH]
Definition: wifiprov_api.h:95
wifiprov_scanlist_ind
Definition: wifiprov_api.h:98
_scanitem::sec_type
uint8_t sec_type
Definition: wifiprov_api.h:93
at_ble_wifiprov_complete_ind::ssid_length
uint8_t ssid_length
Definition: wifiprov_api.h:111
at_ble_wifiprov_scan_mode_change_ind_t::scanmode
uint8_t scanmode
Scan Mode.
Definition: wifiprov_api.h:88
at_ble_wifiprov_complete_ind::sec_type
uint8_t sec_type
Definition: wifiprov_api.h:110
at_ble_wifiprov_complete_ind::status
uint8_t status
Definition: wifiprov_api.h:109
_scanitem::rssi
uint8_t rssi
Definition: wifiprov_api.h:94
at_ble_wifiprov_scan_mode_change_ind_t
Definition: wifiprov_api.h:85
at_ble_status_t
at_ble_status_t
Enumeration for BLE Status.
Definition: at_ble_api.h:121
_scanitem
Definition: wifiprov_api.h:92
wifiprov_scanlist_ind::num_valid
uint8_t num_valid
Definition: wifiprov_api.h:100
at_ble_wifiprov_complete_ind::passphrase_length
uint8_t passphrase_length
Definition: wifiprov_api.h:113
at_ble_wifiprov_complete_ind
Definition: wifiprov_api.h:107
Generated on Fri Aug 18 2017 00:42:10 for Atmel BLE API by doxygen 1.8.13